]> git.pld-linux.org Git - packages/cdrdao.git/blob - cdrdao.spec
- updated gcdmaster files, enabled by default
[packages/cdrdao.git] / cdrdao.spec
1 #
2 # Conditional build:
3 %bcond_without  gnome   # don't build gcdmaster
4 %bcond_without  mp3     # without MP3 support
5 %bcond_without  ogg     # without Ogg support
6 #
7 Summary:        Tools for burning CDRs in Disk At Once mode
8 Summary(pl.UTF-8):      Narzędzia do wypalania płyt w trybie Disk At Once
9 Summary(pt_BR.UTF-8):   Cdrdao - Escreve CD-Rs de áudio em modo "disk-at-once"
10 Name:           cdrdao
11 Version:        1.2.2
12 Release:        1
13 License:        GPL v2+
14 Group:          Applications/System
15 Source0:        http://dl.sourceforge.net/cdrdao/%{name}-%{version}.tar.bz2
16 # Source0-md5:  f0cbf36907406cb4f4c568f9e6669a34
17 Source1:        %{name}.desktop
18 # http://cdrdao.sourceforge.net/drives.html#dt
19 Source2:        %{name}.drivers
20 Patch0:         %{name}-nolibs.patch
21 Patch1:         %{name}-pccts-antlr.patch
22 Patch2:         %{name}-gcc4.patch
23 URL:            http://cdrdao.sourceforge.net/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  cdrtools-devel >= 3:2.01a25
27 %{?with_gnome:BuildRequires:    gtkmm-devel >= 2.4.0}
28 %{?with_mp3:BuildRequires:      lame-libs-devel >= 3.92}
29 %if %{with mp3} || %{with ogg}
30 BuildRequires:  libao-devel >= 0.8
31 %endif
32 %{?with_mp3:BuildRequires:      libmad-devel >= 0.15.1b-4}
33 %{?with_gnome:BuildRequires:    libgnomeuimm-devel >= 2.6.0}
34 BuildRequires:  libmad-devel >= 0.15.1b-4
35 %{?with_gnome:BuildRequires:    libsigc++-devel >= 2.0.0}
36 BuildRequires:  libstdc++-devel
37 %{?with_ogg:BuildRequires:      libvorbis-devel >= 1:1.0}
38 BuildRequires:  pccts >= 1.33MR33-8
39 BuildRequires:  pkgconfig
40 BuildRequires:  rpmbuild(macros) >= 1.311
41 BuildRequires:  sed >= 4.0
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Cdrdao records audio and data CD-Rs in Disk At Once mode. This mode
46 gives much better control over contents of CD.
47
48 %description -l pl.UTF-8
49 Cdrdao zapisuje płytki audio i z danymi w trybie Disk At Once. W tym
50 trybie masz znacznie większą kontrolę nad zawartością płytki.
51
52 %description -l pt_BR.UTF-8
53 Escreve CD-Rs de áudio em modo "disk-at-once" (DAO) permitindo
54 controle sobre pre-gaps (tamanho reduzido a 0, dados não zerados de
55 áudio) e informações de sub-canais como códigos ISRC. Todos os dados
56 que são escritos no disco devem ser especificados através de um
57 arquivo texto. Dados de áudio também podem estar no formato WAVE ou
58 raw.
59
60 %package gcdmaster
61 Summary:        GNOME frontend to cdrdao for composing audio CDs
62 Summary(pl.UTF-8):      Frontend GNOME do cdrdao do składania płyt CD-Audio
63 Group:          X11/Applications
64 Requires:       %{name} = %{version}-%{release}
65 Requires(post,postun):  shared-mime-info
66
67 %description gcdmaster
68 gcdmaster allows the creation of toc-files for cdrdao and can control
69 the recording process. Its main application is the composition of
70 audio CDs from one or more audio files. It supports PQ-channel
71 editing, entry of meta data like ISRC codes/CD-TEXT and non
72 destructive cut of the audio data.
73
74 %description gcdmaster -l pl.UTF-8
75 gcdmaster pozwala na tworzenie plików toc dla cdrdao oraz może
76 kontrolować proces nagrywania. Głównym celem jest składanie płyt
77 CD-Audio z jednego lub więcej plików z dźwiękiem. Obsługuje edycję
78 kanału PQ, wpisy meta-danych takich jak kody ISRC/CD-TEXT oraz
79 niedestruktywne cięcie danych audio.
80
81 %prep
82 %setup -q
83 %patch0 -p1
84 %patch1 -p1
85 %patch2 -p1
86
87 sed -i -e 's#/usr/src/linux/include##g' scsilib/DEFAULT*/Defaults.linux
88 %if !%{with gnome}
89 sed -i -e 's/^en_xdao=yes$/en_xdao=no/' configure.ac
90 %endif
91
92 %build
93 %{__aclocal}
94 %{__autoconf}
95 %{__autoheader}
96 %{__automake}
97 PKG_CONFIG=%{_bindir}/pkg-config \
98 %configure \
99         --with-pcctsbin=%{_bindir} \
100         --with-pcctsinc=%{_libdir}/pccts/h \
101         --with-scglib-inc=%{_includedir}/schily \
102         --with-scglib-lib=%{_libdir} \
103         --with%{!?with_gnome:out}-xdao \
104         --with%{!?with_mp3:out}-mp3-support \
105         --with%{!?with_ogg:out}-ogg-support
106
107 %{__make} \
108         CC="%{__cc}" \
109         COPTOPT="%{rpmcflags}"
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_datadir}/%{name}}
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{name}/drivers
119
120 rm -r $RPM_BUILD_ROOT%{_datadir}/{application-registry,mime-info}
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post gcdmaster
126 %update_mime_database
127
128 %postun gcdmaster
129 %update_mime_database
130
131 %files
132 %defattr(644,root,root,755)
133 %doc CREDITS README README.PlexDAE 
134 %attr(755,root,root) %{_bindir}/cdrdao
135 %attr(755,root,root) %{_bindir}/toc2*
136 %attr(755,root,root) %{_bindir}/cue2toc
137 %{_datadir}/%{name}
138 %{_mandir}/man1/cdrdao.1*
139 %{_mandir}/man1/cue2toc.1*
140
141 %if %{with gnome}
142 %files gcdmaster
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/gcdmaster
145 %{_datadir}/gcdmaster
146 %{_datadir}/mime/packages/gcdmaster.xml
147 %{_desktopdir}/gcdmaster.desktop
148 %{_pixmapsdir}/*
149 %{_mandir}/man1/gcdmaster.1*
150 %endif
This page took 0.216456 seconds and 4 git commands to generate.