]> git.pld-linux.org Git - packages/cdrdao.git/blob - cdrdao.spec
- add gcc4.patch
[packages/cdrdao.git] / cdrdao.spec
1 #
2 # Conditional build:
3 %bcond_with     gnome   # without gcdmaster
4 #
5 Summary:        Tools for burning CDRs in Disk At Once mode
6 Summary(pl):    Narzêdzia do wypalania p³yt w trybie Disk At Once
7 Summary(pt_BR): Cdrdao - Escreve CD-Rs de áudio em modo "disk-at-once"
8 Name:           cdrdao
9 Version:        1.2.0
10 Release:        1
11 License:        GPL v2+
12 Group:          Applications/System
13 Source0:        http://dl.sourceforge.net/cdrdao/%{name}-%{version}.tar.gz
14 # Source0-md5:  dc2bdef7a7c8973e678ba4a4a2d9cc7e
15 Source1:        %{name}.desktop
16 # http://cdrdao.sourceforge.net/drives.html#dt
17 Source2:        %{name}.drivers
18 Patch0:         %{name}-nolibs.patch
19 Patch1:         %{name}-pccts-antlr.patch
20 Patch2:         %{name}-gcc4.patch
21 URL:            http://cdrdao.sourceforge.net/
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  cdrtools-devel >= 3:2.01a25
25 %{?with_gnome:BuildRequires:    libgnomeuimm-devel >= 2.0.0}
26 %{?with_gnome:BuildRequires:    gtkmm-devel >= 2.2.8}
27 BuildRequires:  lame-libs-devel >= 3.92
28 BuildRequires:  libao-devel >= 0.8
29 BuildRequires:  libmad-devel >= 0.15.1b-4
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libvorbis-devel >= 1.0
32 BuildRequires:  pccts >= 1.33MR33-8
33 BuildRequires:  sed >= 4.0
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Cdrdao records audio and data CD-Rs in Disk At Once mode. This mode
38 gives much better control over contents of CD.
39
40 %description -l pl
41 Cdrdao zapisuje p³ytki audio i z danymi w trybie Disk At Once. W tym
42 trybie masz znacznie wiêksz± kontrolê nad zawarto¶ci± p³ytki.
43
44 %description -l pt_BR
45 Escreve CD-Rs de áudio em modo "disk-at-once" (DAO) permitindo
46 controle sobre pre-gaps (tamanho reduzido a 0, dados não zerados de
47 áudio) e informações de sub-canais como códigos ISRC. Todos os dados
48 que são escritos no disco devem ser especificados através de um
49 arquivo texto. Dados de áudio também podem estar no formato WAVE ou
50 raw.
51
52 %package gcdmaster
53 Summary:        GNOME frontend to cdrdao for composing audio CDs
54 Summary(pl):    Frontend GNOME do cdrdao do sk³adania p³yt CD-Audio
55 Group:          X11/Applications
56 Requires:       %{name} = %{version}-%{release}
57
58 %description gcdmaster
59 gcdmaster allows the creation of toc-files for cdrdao and can control
60 the recording process. Its main application is the composition of
61 audio CDs from one or more audio files. It supports PQ-channel
62 editing, entry of meta data like ISRC codes/CD-TEXT and non
63 destructive cut of the audio data.
64
65 %description gcdmaster -l pl
66 gcdmaster pozwala na tworzenie plików toc dla cdrdao oraz mo¿e
67 kontrolowaæ proces nagrywania. G³ównym celem jest sk³adanie p³yt
68 CD-Audio z jednego lub wiêcej plików z d¼wiêkiem. Obs³uguje edycjê
69 kana³u PQ, wpisy meta-danych takich jak kody ISRC/CD-TEXT oraz
70 niedestruktywne ciêcie danych audio.
71
72 %prep
73 %setup -q
74 %patch0 -p1
75 %patch1 -p1
76 %patch2 -p1
77
78 sed -i -e 's#/usr/src/linux/include##g' scsilib/DEFAULT*/Defaults.linux
79 %if %{without gnome}
80 sed -i -e 's/^en_xdao=yes$/en_xdao=no/' configure.ac
81 %endif
82
83 %build
84 %{__aclocal}
85 %{__autoconf}
86 %{__autoheader}
87 %{__automake}
88 PKG_CONFIG=%{_bindir}/pkg-config \
89 %configure \
90         --with-pcctsbin=%{_bindir} \
91         --with-pcctsinc=/usr/lib/pccts/h \
92         --with-scglib-inc=/usr/include/schily \
93         %if %{with gnome}
94         --with-xdao \ 
95         %else
96         --without-xdao \
97         %endif
98         --with-scglib-lib=/usr/lib 
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_datadir}/%{name}}
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/gcdmaster.desktop
110 install xdao/stock/gcdmaster.png $RPM_BUILD_ROOT%{_pixmapsdir}
111 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{name}/drivers
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(644,root,root,755)
118 %doc CREDITS README README.PlexDAE 
119 %attr(755,root,root) %{_bindir}/cdrdao
120 %attr(755,root,root) %{_bindir}/toc2*
121 %attr(755,root,root) %{_bindir}/cue2toc
122 %{_datadir}/%{name}
123 %{_mandir}/man1/cdrdao.1*
124 %{_mandir}/man1/cue2toc.1*
125
126 %if %{with gnome}
127 %files gcdmaster
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_bindir}/gcdmaster
130 %{_desktopdir}/gcdmaster.desktop
131 %{_pixmapsdir}/*
132 %{_mandir}/man1/gcdmaster.*
133 %endif
This page took 0.074968 seconds and 4 git commands to generate.