]> git.pld-linux.org Git - packages/cdk.git/blob - cdk.spec
- updated to 4.9.10
[packages/cdk.git] / cdk.spec
1 %define         ver_ver     4.9.10
2 %define         ver_release 20000923
3
4 Summary:        Curses Development Kit
5 Name:           cdk
6 Version:        %{ver_ver}_td%{ver_release}
7 Release:        1
8 License:        BSD
9 Group:          Libraries
10 Group(fr):      Librairies
11 Group(pl):      Biblioteki
12 URL:            http://dickey.his.com/cdk/cdk.html
13 Source0:        ftp://dickey.his.com/cdk/%{name}-%{ver_ver}-%{ver_release}.tgz
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 CDK is a widget set developed on top of the basic curses library. It
18 contains 21 ready to use widgets. Some which are a text entry field, 
19 a scrolling list, a selection list, a alphalist, pull-down menu, radio
20 list, viewer widget, dialog box, and many more.
21
22 This version of CDK is maintained by Thomas Dickey and is not the same
23 as that at http://www.vexus.ca/CDK.html.
24
25 %package devel
26 Summary:        Header files and development documentation for CDK library
27 Summary(pl):    Pliki nag³ówkowe i dokumentacja do CDK
28 Group:          Development/Libraries
29 Group(fr):      Development/Librairies
30 Group(pl):      Programowanie/Biblioteki
31 Requires:       %{name} = %{version}
32
33 %description devel
34 Header files and development documentation for CDK library. This
35 version is maintained by Thomas Dickey and is not the same as that 
36 at http://www.vexus.ca/CDK.html.
37
38 %package static
39 Summary:        Static version of CDK library
40 Summary(pl):    Statyczna wersja biblioteki CDK
41 Group:          Development/Libraries
42 Group(fr):      Development/Librairies
43 Group(pl):      Programowanie/Biblioteki
44 Requires:       %{name}-devel = %{version}
45
46 %description static
47 Static version of CDK library. This version is maintained by Thomas
48 Dickey and is not the same as that at http://www.vexus.ca/CDK.html.
49
50 %prep
51 %setup -q -n %{name}-%{ver_ver}-%{ver_release}
52
53 %build
54 # -funsigned-char gets valid 8bit display
55 CFLAGS="$RPM_OPT_FLAGS -funsigned-char"; 
56 %configure --disable-x --with-ncurses
57 %{__make}
58 %{__make} cdkshlib
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} DESTDIR="$RPM_BUILD_ROOT" installCDKSHLibrary installCDKLibrary  
64
65 %{__make} DESTDIR="$RPM_BUILD_ROOT" installCDKHeaderFiles installCDKManPages
66 gzip -9nf {BUGS,CHANGES,COPYING,EXPANDING,INSTALL,NOTES,README,TODO}
67
68 for d in demos examples; do 
69    rm -f $d/Makefile.in
70    mkf=$d/Makefile
71    sed 's|\-I%{_prefix}/X11R6/include|\-I%{_includedir}/cdk/|' <$mkf >$mkf.fix
72    mv -f $mkf.fix $mkf
73 done
74
75 %post   -p /sbin/ldconfig
76 %postun -p /sbin/ldconfig
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %attr(755,root,root) %{_libdir}/lib*.so.*.*
84
85 %files devel
86 %defattr(644,root,root,755)
87 %attr(755,root,root) %{_libdir}/lib*.so
88 %{_includedir}/*
89 %{_mandir}/man3/*
90 %doc {BUGS,CHANGES,COPYING,EXPANDING,INSTALL,NOTES,README,TODO}.gz
91 %doc examples demos
92
93 %files static
94 %defattr(644,root,root,755)
95 %{_libdir}/lib*.a
This page took 0.034946 seconds and 4 git commands to generate.