]> git.pld-linux.org Git - packages/cdk.git/blob - cdk.spec
f851cd469a8721ae29a1f1308185afe2e796ff25
[packages/cdk.git] / cdk.spec
1 %define         ver_ver     4.9.10
2 %define         ver_release 20010106
3
4 Summary:        Curses Development Kit
5 Summary(pl):    Zestaw programistyczny do Curses
6 Name:           cdk
7 Version:        %{ver_ver}_td%{ver_release}
8 Release:        2
9 License:        BSD
10 Group:          Libraries
11 URL:            http://dickey.his.com/cdk/cdk.html
12 Source0:        ftp://dickey.his.com/cdk/%{name}-%{ver_ver}-%{ver_release}.tgz
13 Patch0:         %{name}-includes.patch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 CDK is a widget set developed on top of the basic curses library. It
18 contains 21 ready to use widgets. Some which are a text entry field, a
19 scrolling list, a selection list, a alphalist, pull-down menu, radio
20 list, viewer widget, dialog box, and many more.
21
22 This version of CDK is maintained by Thomas Dickey and is not the same
23 as that at http://www.vexus.ca/CDK.html.
24
25 %description -l pl
26 CDK to zestaw widgetów zbudowanych na podstawie biblioteki curses.
27 Zawiera 21 gotowych go u¿ycia widgetów. W¶ród nich jest pole
28 wprowadzania tekstu, lista przewijana, lista wyboru, lista
29 alfabetyczna, menu rozwijane, lista przycisków, przegl±darka, okienko
30 dialogowe i wiele innych.
31
32 Ta wersja CDK jest prowadzona przez Thomasa Dickeya i nie jest tym
33 samym, co znajduje siê pod adresem http://www.vexus.ca/CDK.html.
34
35 %package devel
36 Summary:        Header files and development documentation for CDK library
37 Summary(pl):    Pliki nag³ówkowe i dokumentacja do CDK
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}
40
41 %description devel
42 Header files and development documentation for CDK library. This
43 version is maintained by Thomas Dickey and is not the same as that at
44 http://www.vexus.ca/CDK.html.
45
46 %description devel -l pl
47 Pliki nag³ówkowe i dokumentacja programisty do biblioteki CDK. Ta
48 wersja jest prowadzona przez Thomasa Dickeya i nie jest tym samym, co
49 znajduje siê pod adresem http://www.vexus.ca/CDK.html.
50
51 %package static
52 Summary:        Static version of CDK library
53 Summary(pl):    Statyczna wersja biblioteki CDK
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}
56
57 %description static
58 Static version of CDK library. This version is maintained by Thomas
59 Dickey and is not the same as that at http://www.vexus.ca/CDK.html.
60
61 %description static -l pl
62 Statyczna wersja biblioteki CDK. Ta wersja jest prowadzona przez
63 Thomasa Dickeya i nie jest tym samym, co znajduje siê pod adresem
64 http://www.vexus.ca/CDK.html.
65
66 %prep
67 %setup -q -n %{name}-%{ver_ver}-%{ver_release}
68 %patch0 -p1
69 mkdir include/cdk
70 mv -f include/*.* include/cdk
71
72 %build
73 # -funsigned-char gives valid 8bit display
74 CFLAGS="%{rpmcflags} -funsigned-char"
75 %configure2_13 \
76         --disable-x \
77         --with-ncurses
78 %{__make}
79 %{__make} cdkshlib
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} installCDKSHLibrary installCDKLibrary \
85         DESTDIR="$RPM_BUILD_ROOT"
86
87 %{__make} installCDKHeaderFiles installCDKManPages \
88         DESTDIR="$RPM_BUILD_ROOT"
89
90 gzip -9nf BUGS CHANGES EXPANDING NOTES README TODO
91
92 for d in demos examples; do
93    rm -f $d/Makefile.in
94    mkf=$d/Makefile
95    sed 's|\-I%{_prefix}/X11R6/include|\-I%{_includedir}/cdk/|' <$mkf >$mkf.fix
96    mv -f $mkf.fix $mkf
97 done
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/lib*.so.*.*
108
109 %files devel
110 %defattr(644,root,root,755)
111 %doc *gz examples demos
112 %attr(755,root,root) %{_libdir}/lib*.so
113 %{_includedir}/*
114 %{_mandir}/man3/*
115
116 %files static
117 %defattr(644,root,root,755)
118 %{_libdir}/lib*.a
This page took 0.108065 seconds and 3 git commands to generate.