]> git.pld-linux.org Git - packages/captive.git/blob - captive.spec
- added gnome-vfs module, all files packaged now, rel 0.2
[packages/captive.git] / captive.spec
1 #
2 # Conditional build:
3 #%%bcond_without        gnome   # don't build gnome-vfs support
4 %bcond_without  lufs    # don't build LUFS support
5 #
6 Summary:        Captive - NTFS read/write filesystem for Linux
7 Summary(pl):    Captive - obs³uga NTFS dla Linuksa z odczytem i zapisem
8 Name:           captive
9 Version:        1.1.5
10 Release:        0.2
11 Epoch:          0
12 License:        GPL
13 Group:          Base/Kernel
14 Source0:        http://www.jankratochvil.net/project/captive/dist/%{name}-%{version}.tar.gz
15 # Source0-md5:  dfb7ce617745695e7a908609b9370fd6
16 Patch0:         %{name}-non_root_install.patch
17 Patch1:         %{name}-use_lufis.patch
18 Patch2:         %{name}-no_lufsd.patch
19 Patch3:         %{name}-fix_headers.patch
20 URL:            http://www.jankratochvil.net/project/captive/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  gnome-vfs2-devel >= 2.0
24 BuildRequires:  gtk-doc
25 BuildRequires:  libxml2-devel >= 2.5.9
26 %{?with_lufs:BuildRequires:     lufs-devel}
27 BuildRequires:  openssl-devel
28 BuildRequires:  pkgconfig
29 BuildRequires:  readline-devel
30 BuildRequires:  ntfsprogs-devel
31 BuildRequires:  libgnomeui-devel
32 BuildRequires:  libglade2-devel
33 Provides:       group(captive)
34 Provides:       user(captive)
35 Requires:       lufis
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Captive project implements the first full read/write free access to
40 NTFS disk drives. You can mount your Microsoft Windows NT, 200x or XP
41 partition as a transparently accessible volume for your GNU/Linux.
42
43 This compatibility was achieved in the Wine way by using the original
44 Microsoft Windows ntfs.sys driver. It emulates the required subsystems
45 of the Microsoft Windows kernel by reusing one of the original
46 ntoskrnl.exe, ReactOS parts, or this project's own reimplementations,
47 on a case by case basis. Project includes the first open source
48 MS-Windows kernel API for Free operating systems. Involvement of the
49 original driver files was chosen to achieve the best and unprecedented
50 filesystem compatibility and safety.
51
52 %description -l pl
53 Projekt Captive implementuje pierwszy pe³ny, swobodny dostêp z
54 odczytem i zapisem do partycji NTFS. Pozwala zamontowaæ partycje z
55 Microsoft Windows NT, 200x i XP jako dostêpny w sposób przezroczysty
56 wolumen pod Linuksem.
57
58 Kompatybilno¶æ osi±gniêto metod± Wine poprzez u¿ycie oryginalnego
59 sterownika ntfs.sys. Captive emuluje wymagane podsystemy j±dra
60 Microsoft Windows poprzez wykorzystanie oryginalnego ntoskrnl.exe,
61 czê¶ci ReactOS-a lub w³asne implementacje z tego projektu w zale¿no¶ci
62 od danego przypadku. Projekt zawiera pierwsze API j±dra MS-Windows z
63 otwartymi ¼ród³ami dla wolnodostêpnych systemów operacyjnych. Wybrano
64 wykorzystanie plików oryginalnego sterownika aby osi±gn±æ lepsz±
65 kompatybilno¶æ i bezpieczeñstwo.
66
67 %package -n gnome-vfs2-module-captive
68 Summary:        Captive module for gnome-vfs
69 Summary(pl):    Modu³ captive dla gnome-vfs
70 Group:          Libraries
71 Requires:       %{name} = %{epoch}:%{version}-%{release}
72
73 %description -n gnome-vfs2-module-captive
74 Captive module for gnome-vfs.
75
76 %description -n gnome-vfs2-module-captive -l pl
77 Modu³ captive dla gnome-vfs.
78
79 %package install
80 Summary:        Windows filesystem drivers installer for captive
81 Summary(pl):    Instalator windowsowych sterowników systemu plików dla captive
82 Group:          Base/Utilities
83 Requires:       %{name} = %{epoch}:%{version}-%{release}
84 Requires:       ntfsprogs
85
86 %description install
87 Windows filesystem drivers installer for captive.
88
89 %description install -l pl
90 Instalator windowsowych sterowników systemu plików dla captive.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p1
97 %patch3 -p1
98
99 %build
100 rm -f missing
101 %{__libtoolize}
102 %{__aclocal} -I macros
103 %{__autoconf}
104 %{__autoheader}
105 %{__automake}
106 %configure \
107         --enable-lufs \
108         --enable-install-pkg \
109         --with-readline \
110         --enable-sandbox-setuid=captive \
111         --enable-sandbox-setgid=captive \
112         --enable-sandbox-chroot=/var/lib/captive \
113         --enable-man-pages \
114         --enable-sbin-mountdir=/sbin \
115         --enable-sbin-mount-fs=ntfs:fastfat:cdfs:ext2fsd \
116         --with-orbit-line=link \
117         --with-tmpdir=/tmp \
118         --localstatedir=/var \
119         --enable-gtk-doc
120
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 install -d $RPM_BUILD_ROOT%{_docdir}
130 mv $RPM_BUILD_ROOT/usr/share/gtk-doc  $RPM_BUILD_ROOT%{_docdir}
131
132 %clean
133 #rm -rf $RPM_BUILD_ROOT
134
135 %pre
136 if [ -n "`getgid captive`" ]; then
137         if [ "`getgid http`" != "141" ]; then
138                 echo "Error: group captive doesn't have gid=141. Correct this before installing captive." 1>&2
139                 exit 1
140         fi
141 else
142         /usr/sbin/groupadd -g 141 -r -f captive
143 fi
144 if [ -n "`id -u captive 2>/dev/null`" ]; then
145         if [ "`id -u http`" != "141" ]; then
146                 echo "Error: user captive doesn't have uid=141. Correct this before installing captive." 1>&2
147                 exit 1
148         fi
149 else
150         /usr/sbin/useradd -u 141 -r -d /var/lib/captive -s /bin/false -c "Captive User" -g captive captive 1>&2
151 fi
152
153 %files
154 %defattr(644,root,root,755)
155 %doc AUTHORS NEWS README THANKS TODO
156 %attr(755,root,root) %{_bindir}/*
157 %attr(755,root,root) %{_sbindir}/captive-sandbox-server
158 %attr(755,root,root) /sbin/*
159 %{_libdir}/lib*
160 %{_libdir}/gnome-vfs-2.0/modules/*
161 %{_includedir}/captive/*
162 %{_mandir}/man1/captive-cmdline.1*
163 %{_mandir}/man1/captive-sandbox-server.1*
164 %{_mandir}/man7/*
165 %{_mandir}/man8/*
166 /var/lib/captive
167 /etc/w32-mod-id.captivemodid.xml
168 %lang(cs) /usr/share/locale/cs/LC_MESSAGES/captive.mo
169 %{_gtkdocdir}/captive-apiref
170
171 %files -n gnome-vfs2-module-captive
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_libdir}/gnome-vfs-2.0/modules/libcaptive-gnomevfs*.so
174 %{_sysconfdir}/gnome-vfs-2.0/modules/captive.conf
175
176 %files install
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_sbindir}/captive-install*
179 %{_mandir}/man1/captive-install*
This page took 0.082545 seconds and 4 git commands to generate.