]> git.pld-linux.org Git - packages/cairo.git/blob - cairo.spec
6e1b76946cff4b31eedd056870b0049d05c176d6
[packages/cairo.git] / cairo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     glitz           # build with glitz backend
5 %bcond_with     xcb             # enable XCB backend (XCB not released yet)
6 %bcond_with     tests           # perform tests (can fail due to out of memory)
7 #
8 Summary:        Cairo - multi-platform 2D graphics library
9 Summary(pl):    Cairo - wieloplatformowa biblioteka graficzna 2D
10 Name:           cairo
11 Version:        1.0.2
12 Release:        8
13 License:        LGPL v2.1 or MPL v1.1
14 Group:          Libraries
15 Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
16 # Source0-md5:  d0b7111a14f90ec3afa777ec40c44984
17 Patch0:         %{name}-gcc4.patch
18 Patch1:         %{name}-link.patch
19 URL:            http://cairographics.org/
20 BuildRequires:  autoconf >= 2.54
21 BuildRequires:  automake >= 1.7
22 BuildRequires:  fontconfig-devel
23 BuildRequires:  freetype-devel >= 1:2.1.10
24 %{?with_glitz:BuildRequires:    glitz-devel >= 0.4.4}
25 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.3}
26 BuildRequires:  libpng-devel
27 BuildRequires:  libtool
28 BuildRequires:  pkgconfig
29 %{?with_xcb:BuildRequires:      xcb-devel}
30 BuildRequires:  xorg-lib-libXrender-devel >= 0.6
31 BuildRequires:  zlib-devel
32 Requires:       freetype >= 1:2.1.10
33 %{?with_glitz:Requires: glitz >= 0.4.4}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Cairo provides anti-aliased vector-based rendering for X. Paths
38 consist of line segments and cubic splines and can be rendered at any
39 width with various join and cap styles. All colors may be specified
40 with optional translucence (opacity/alpha) and combined using the
41 extended Porter/Duff compositing algebra as found in the X Render
42 Extension.
43
44 Cairo exports a stateful rendering API similar in spirit to the path
45 construction, text, and painting operators of PostScript, (with the
46 significant addition of translucence in the imaging model). When
47 complete, the API is intended to support the complete imaging model of
48 PDF 1.4.
49
50 Cairo relies on the Xc library for backend rendering. Xc provides an
51 abstract interface for rendering to multiple target types. As of this
52 writing, Xc allows Cairo to target X drawables as well as generic
53 image buffers. Future backends such as PostScript, PDF, and perhaps
54 OpenGL are currently being planned.
55
56 %description -l pl
57 Cairo obs³uguje oparty na wektorach rendering z antyaliasingiem dla X.
58 ¦cie¿ki sk³adaj± siê z odcinków i splajnów kubicznych, a renderowane
59 mog± byæ z dowoln± grubo¶ci± i ró¿nymi stylami po³±czeñ i zakoñczeñ.
60 Wszystkie kolory mog± byæ podane z opcjonaln± pó³przezroczysto¶ci±
61 (podan± przez wspó³czynnik nieprzezroczysto¶ci lub alpha) i ³±czone
62 przy u¿yciu rozszerzonego algorytmu mieszania Portera-Duffa, który
63 mo¿na znale¼æ w rozszerzeniu X Render.
64
65 Cairo eksportuje stanowe API renderuj±ce w duchu podobne do operatorów
66 konstruowania ¶cie¿ek, tekstu i rysowania z PostScriptu (ze znacznym
67 dodatkiem pó³przezroczysto¶ci w modelu obrazu). Kiedy API zostanie
68 ukoñczone, ma obs³ugiwaæ pe³ny model obrazu z PDF w wersji 1.4.
69
70 Cairo do backendowego renderowania wykorzystuje bibliotekê Xc. Xc
71 dostarcza abstrakcyjny interfejs do renderowania na wiele rodzajów
72 wyj¶æ. Aktualnie Xc pozwala Cairo tworzyæ obiekty X, a tak¿e ogólne
73 bufory obrazu. W przysz³o¶ci planowane s± takie backendy jak
74 PostScript, PDF i byæ mo¿e OpenGL.
75
76 %package devel
77 Summary:        Development files for Cairo library
78 Summary(pl):    Pliki programistyczne biblioteki Cairo
79 Group:          Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       fontconfig-devel
82 Requires:       freetype-devel >= 1:2.1.10
83 %{?with_glitz:Requires: glitz-devel >= 0.4.4}
84 Requires:       libpng-devel
85 %{?with_xcb:Requires:   xcb-devel}
86 Requires:       xorg-lib-libXrender-devel >= 0.6
87
88 %description devel
89 Development files for Cairo library.
90
91 %description devel -l pl
92 Pliki programistyczne biblioteki Cairo.
93
94 %package static
95 Summary:        Static Cairo library
96 Summary(pl):    Statyczna biblioteka Cairo
97 Group:          Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99
100 %description static
101 Static Cairo library.
102
103 %description static -l pl
104 Statyczna biblioteka Cairo.
105
106 %prep
107 %setup -q
108 %patch0 -p1
109 %patch1 -p1
110
111 %build
112 %{__libtoolize}
113 %{__aclocal}
114 %{__autoheader}
115 %{__autoconf}
116 %{__automake}
117 %configure \
118         %{?with_apidocs:--enable-gtk-doc} \
119         %{?with_xcb:--enable-xcb} \
120         %{?with_glitz:--enable-glitz} \
121         --enable-ps \
122         --enable-pdf \
123         --with-html-dir=%{_gtkdocdir}
124 %{__make}
125 %{?with_tests:%{__make} check}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post   -p /sbin/ldconfig
137 %postun -p /sbin/ldconfig
138
139 %files
140 %defattr(644,root,root,755)
141 # COPYING contains only notes, not LGPL/MPL texts
142 %doc AUTHORS COPYING ChangeLog NEWS README TODO
143 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/lib*.so
148 %{_libdir}/lib*.la
149 %{_includedir}/*
150 %{_pkgconfigdir}/*.pc
151 %{_gtkdocdir}/cairo
152
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/lib*.a
This page took 0.028634 seconds and 2 git commands to generate.