]> git.pld-linux.org Git - packages/bzip2.git/blob - bzip2.spec
- added %clean section.
[packages/bzip2.git] / bzip2.spec
1 Summary:     Extremely powerful file compression utility
2 Summary(pl): Extremalnie wydajny program do kompresowania plików
3 Name:        bzip2
4 Version:     0.9.0b
5 Release:     3
6 Copyright:   Distributable (see LICENSE)
7 Vendor:      Julian Seward <jseward@acm.org>
8 Group:       Utilities/Archiving
9 Source:      http://www.muraroa.demon.co.uk/%{name}-%{version}.tar.gz
10 BuildRoot:   /tmp/%{name}-%{version}-root
11
12 %description
13 Bzip2 compresses files using the Burrows-Wheeler block-sorting text
14 compression algorithm, and Huffman coding. Compression is generally
15 considerably better than that achieved by more conventional LZ77/LZ78-based
16 compressors, and approaches the performance of the PPM family of statistical
17 compressors.
18
19 The command-line options are deliberately very similar to those of GNU Gzip,
20 but they are not identical.
21
22 %description -l pl
23 Bzip2 kompresuje pliki u¿ywaj±c algorymtu kompresji blokowego-sortowania tekstu
24 Burrows-Wheeler'a oraz kodowania Huffmana. Generalnie kompresja jest znacznie
25 lepsza ni¿ w konwencjonalnych kompresorach u¿ywaj±cych algorytmów LZ77/LZ78
26 i zbli¿a siê do wydajno¶ci statystycznych kompresorów z rodziny PPM.
27
28 %prep
29 %setup -q
30
31 %build
32 mkdir shared
33 make CFLAGS="$RPM_OPT_FLAGS"
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT/usr/{bin,lib,man/man1}
38
39 install -s bzip2 bzip2recover $RPM_BUILD_ROOT/usr/bin
40
41 ln -sf bzip2 $RPM_BUILD_ROOT/usr/bin/bunzip2
42
43 install bzip2.1 $RPM_BUILD_ROOT/usr/man/man1
44 echo ".so bzip2.1" > $RPM_BUILD_ROOT/usr/man/man1/bunzip2.1
45
46 cat > $RPM_BUILD_ROOT/usr/bin/bzless <<EOF
47 #!/bin/sh
48 /usr/bin/bunzip2 -c "\$@" | /usr/bin/less
49 EOF
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %attr(644, root, root, 755) %doc README LICENSE
56 %attr(755, root, root) /usr/bin/*
57 %attr(644, root,  man) /usr/man/man1/*
58
59 %changelog
60 * Sun Nov  1 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
61   [0.9.0b-3]
62 - added %clean section.
63
64 * Sat Sep 26 1998 Arkadiusz Mi¶kiewicz <misiek@misiek.eu.org>
65   [0.9.0b-2]
66 - added pl translation.
67
68 * Mon Sep  7 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
69   [0.9-1]
70 - changed base source Url to http://www.muraroa.demon.co.uk/,
71 - changed Copyright,
72 - added Vendor.
73
74 * Thu Aug 13 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
75   [0.1pl2-3]
76 - added -q %setup parameter,
77 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
78 - added using %%{name} and %%{version} in Source,
79 - bunzip2(1) man page is now maked as nroff include to bzip(1) instead
80   making sym link to bzip2.1 (this allow compress man pages in future),
81 - added %attr and %defattr macros in %files (allow build package from
82   non-root account).
This page took 0.318798 seconds and 4 git commands to generate.