]> git.pld-linux.org Git - packages/bzip2.git/blob - bzip2.spec
- added -q %setup parameter,
[packages/bzip2.git] / bzip2.spec
1 Summary:   Extremely powerful file compression utility
2 Name:      bzip2
3 Version:   0.1pl2
4 Release:   3
5 Copyright: GPL
6 Group:     Utilities/Archiving
7 Source:    http://www.digistar.com/bzip2/%{name}-%{version}.tar.gz
8 BuildRoot: /tmp/%{name}-%{version}-root
9
10 %description
11 Bzip2  compresses  files  using the Burrows-Wheeler block-sorting text
12 compression algorithm, and Huffman coding. Compression is generally
13 considerably better than that achieved by more conventional LZ77/LZ78-based
14 compressors, and approaches the performance of the PPM family of statistical
15 compressors.
16
17 The command-line options are deliberately very similar to those of GNU Gzip,
18 but they are not identical.
19
20 %prep
21 %setup -q
22
23 %build
24 make CFLAGS="$RPM_OPT_FLAGS"
25
26 %install
27 rm -rf $RPM_BUILD_ROOT
28 install -d $RPM_BUILD_ROOT/usr/{bin,man/man1}
29 install -s bzip2 bzip2recover $RPM_BUILD_ROOT/usr/bin
30
31 ln -sf bzip2 $RPM_BUILD_ROOT/usr/bin/bunzip2
32
33 install bzip2.1 $RPM_BUILD_ROOT/usr/man/man1
34 echo ".so bzip2.1" > $RPM_BUILD_ROOT/usr/man/man1/bunzip2.1
35
36 cat > $RPM_BUILD_ROOT/usr/bin/bzless <<EOF
37 #!/bin/sh
38 /usr/bin/bunzip2 -c "\$@" | /usr/bin/less
39 EOF
40
41 %files
42 %attr(644, root, root, 755) %doc  README ALGORITHMS
43 %attr(755, root root) /usr/bin/*
44 %attr(644, root  man) /usr/man/man1/*
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %changelog
50 * Thu Aug 13 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
51   [0.1pl2-3]
52 - added -q %setup parameter,
53 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
54 - added using %%{name} and %%{version} in Source,
55 - bunzip2(1) man page is now maked as nroff include to bzip(1) instead
56   making sym link to bzip2.1 (this allow compress man pages in future),
57 - added %attr and %defattr macros in %files (allow build package from
58   non-root account).
This page took 0.062519 seconds and 4 git commands to generate.