]> git.pld-linux.org Git - packages/bzip2.git/blob - bzip2.spec
25eb25d640f049a8d61c30fba0f9aef1ba85499e
[packages/bzip2.git] / bzip2.spec
1 Summary:     Extremely powerful file compression utility
2 Summary(pl): Extremalnie wydajny program do kompresowania plików
3 Name:        bzip2
4 Version:     0.9.0b
5 Release:     3
6 Copyright:   Distributable (see LICENSE)
7 Vendor:      Julian Seward <jseward@acm.org>
8 Group:       Utilities/Archiving
9 Group(pl):   Narzêdzia/Archiwizacja
10 Source:      http://www.muraroa.demon.co.uk/%{name}-%{version}.tar.gz
11 BuildRoot:   /tmp/%{name}-%{version}-root
12
13 %description
14 Bzip2 compresses files using the Burrows-Wheeler block-sorting text
15 compression algorithm, and Huffman coding. Compression is generally
16 considerably better than that achieved by more conventional LZ77/LZ78-based
17 compressors, and approaches the performance of the PPM family of statistical
18 compressors.
19
20 The command-line options are deliberately very similar to those of GNU Gzip,
21 but they are not identical.
22
23 %description -l pl
24 Bzip2 kompresuje pliki u¿ywaj±c algorymtu kompresji blokowego-sortowania tekstu
25 Burrows-Wheeler'a oraz kodowania Huffmana. Generalnie kompresja jest znacznie
26 lepsza ni¿ w konwencjonalnych kompresorach u¿ywaj±cych algorytmów LZ77/LZ78
27 i zbli¿a siê do wydajno¶ci statystycznych kompresorów z rodziny PPM.
28
29 %prep
30 %setup -q
31
32 %build
33 mkdir shared
34 make CFLAGS="$RPM_OPT_FLAGS"
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT/usr/{bin,lib,man/man1}
39
40 install -s bzip2 bzip2recover $RPM_BUILD_ROOT/usr/bin
41
42 ln -sf bzip2 $RPM_BUILD_ROOT/usr/bin/bunzip2
43
44 install bzip2.1 $RPM_BUILD_ROOT/usr/man/man1
45 echo ".so bzip2.1" > $RPM_BUILD_ROOT/usr/man/man1/bunzip2.1
46
47 cat > $RPM_BUILD_ROOT/usr/bin/bzless <<EOF
48 #!/bin/sh
49 /usr/bin/bunzip2 -c "\$@" | /usr/bin/less
50 EOF
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %attr(644, root, root, 755) %doc README LICENSE
57 %attr(755, root, root) /usr/bin/*
58 %attr(644, root,  man) /usr/man/man1/*
59
60 %changelog
61 * Sun Nov  1 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
62   [0.9.0b-3]
63 - added %clean section.
64
65 * Sat Sep 26 1998 Arkadiusz Mi¶kiewicz <misiek@misiek.eu.org>
66   [0.9.0b-2]
67 - added pl translation.
68
69 * Mon Sep  7 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
70   [0.9-1]
71 - changed base source Url to http://www.muraroa.demon.co.uk/,
72 - changed Copyright,
73 - added Vendor.
74
75 * Thu Aug 13 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
76   [0.1pl2-3]
77 - added -q %setup parameter,
78 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
79 - added using %%{name} and %%{version} in Source,
80 - bunzip2(1) man page is now maked as nroff include to bzip(1) instead
81   making sym link to bzip2.1 (this allow compress man pages in future),
82 - added %attr and %defattr macros in %files (allows build package from
83   non-root account).
This page took 0.069032 seconds and 3 git commands to generate.