]> git.pld-linux.org Git - packages/bzip2.git/blob - bzip2.spec
- removed /usr/lib/lib*so.*.* from %files.
[packages/bzip2.git] / bzip2.spec
1 Summary:   Extremely powerful file compression utility
2 Name:      bzip2
3 Version:   0.9.0
4 Release:   1
5 Copyright: Distributable (see LICENSE)
6 Vendor:    Julian Seward <jseward@acm.org>
7 Group:     Utilities/Archiving
8 Source:    http://www.muraroa.demon.co.uk/%{name}-%{version}.tar.gz
9 BuildRoot: /tmp/%{name}-%{version}-root
10
11 %description
12 Bzip2 compresses files using the Burrows-Wheeler block-sorting text
13 compression algorithm, and Huffman coding. Compression is generally
14 considerably better than that achieved by more conventional LZ77/LZ78-based
15 compressors, and approaches the performance of the PPM family of statistical
16 compressors.
17
18 The command-line options are deliberately very similar to those of GNU Gzip,
19 but they are not identical.
20
21 %prep
22 %setup -q
23
24 %build
25 mkdir shared
26 make CFLAGS="$RPM_OPT_FLAGS"
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 install -d $RPM_BUILD_ROOT/usr/{bin,lib,man/man1}
31 install -s bzip2 bzip2recover $RPM_BUILD_ROOT/usr/bin
32
33 ln -sf bzip2 $RPM_BUILD_ROOT/usr/bin/bunzip2
34
35 install bzip2.1 $RPM_BUILD_ROOT/usr/man/man1
36 echo ".so bzip2.1" > $RPM_BUILD_ROOT/usr/man/man1/bunzip2.1
37
38 cat > $RPM_BUILD_ROOT/usr/bin/bzless <<EOF
39 #!/bin/sh
40 /usr/bin/bunzip2 -c "\$@" | /usr/bin/less
41 EOF
42
43 %files
44 %attr(644, root, root, 755) %doc README LICENSE
45 %attr(755, root, root) /usr/bin/*
46 %attr(644, root,  man) /usr/man/man1/*
47
48 %changelog
49 * Mon Sep  7 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
50   [0.9-1]
51 - changed base source URl to http://www.muraroa.demon.co.uk/,
52 - changed Copyright:,
53 - added Vendor:,
54
55 * Thu Aug 13 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
56   [0.1pl2-3]
57 - added -q %setup parameter,
58 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
59 - added using %%{name} and %%{version} in Source,
60 - bunzip2(1) man page is now maked as nroff include to bzip(1) instead
61   making sym link to bzip2.1 (this allow compress man pages in future),
62 - added %attr and %defattr macros in %files (allow build package from
63   non-root account).
This page took 0.120075 seconds and 3 git commands to generate.