]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- rel 2; important fixes for initrd
[packages/busybox.git] / busybox.spec
1 # TODO:
2 #       - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
3 #       - make internal commands work even if busybox is not in /bin/busybox (initrd)
4 #         or when /proc is not mounted (static / normal)
5 #
6 # Conditional build:
7 # alternative busybox config file (replaces default one) you should
8 # define cfgfile macro, i.e.
9 #
10 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
11 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
12 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
13 # Options below are useful, when you want fileutils and grep providing.
14 # For example, ash package requires fileutils and grep.
15 %bcond_with     fileutl_prov    # adds fileutils providing
16 %bcond_with     grep_prov       # adds grep providing
17 # Option below is useful, when busybox is built with shell support.
18 %bcond_with     sh_prov         # adds /bin/sh providing
19 # WARNING! Shell, fileutils and grep providing may depend on config file!
20 # Fileutils, grep and shell provided with busybox have not such
21 # functionality as their GNU countenders.
22 #
23 %bcond_without  static          # don't build static version
24 %bcond_without  initrd          # don't build initrd version
25 %bcond_with     dietlibc        # build dietlibc-based initrd version
26 %bcond_with     glibc           # build glibc-based initrd version
27 #
28 %ifnarch %{ix86} %{x8664} ppc sparc64
29 %define with_glibc 1
30 %endif
31 Summary:        Set of common unix utils for embeded systems
32 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
33 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
34 Name:           busybox
35 Version:        1.6.0
36 Release:        2
37 License:        GPL
38 Group:          Applications
39 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
40 # Source0-md5:  b587dd978fed23467b42ef959b6aa449
41 Source1:        %{name}.config
42 Source2:        %{name}-initrd.config
43 %{?with_altconfig:Source3:      %{cfgfile}}
44 Patch1:         %{name}-logconsole.patch
45 Patch2:         %{name}-printf-gettext.patch
46 Patch3:         %{name}-loadfont.patch
47 Patch4:         %{name}-ash_exec.patch
48 Patch5:         %{name}-kernel_headers.patch
49 Patch6:         %{name}-insmod-morearchs.patch
50 Patch7:         %{name}-dhcp.patch
51 Patch8:         %{name}-fix_64_archs.patch
52 URL:            http://www.busybox.net/
53 BuildRequires:  gcc >= 3.2
54 BuildRequires:  perl-tools-pod
55 BuildRequires:  rpmbuild(macros) >= 1.333
56 %{?with_static:BuildRequires:   glibc-static}
57 %if %{with initrd}
58         %if %{with dietlibc}
59 BuildRequires:  dietlibc-static
60         %else
61                 %if %{with glibc}
62 BuildRequires:  glibc-static
63                 %else
64 %if "%{_target_base_arch}" != "%{_arch}"
65 BuildRequires:  cross%{_target_base_arch}-uClibc-static
66 %else
67         %ifarch ppc %{x8664}
68 BuildRequires:  uClibc-static >= 2:0.9.29
69         %else
70 BuildRequires:  uClibc-static >= 2:0.9.21
71         %endif
72 %endif
73                 %endif
74         %endif
75 %endif
76 %{?with_fileutl_prov:Provides:  fileutils}
77 %{?with_grep_prov:Provides:     grep}
78 %{?with_sh_prov:Provides:       /bin/sh}
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %define         _bindir         /bin
82 %define         _initrd_bindir  /bin
83
84 %if "%{_target_base_arch}" != "%{_arch}"
85         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
86 %else
87         %define CrossOpts %{nil}
88 %endif
89
90 %description
91 BusyBox combines tiny versions of many common UNIX utilities into a
92 single small executable. It provides minimalist replacements for most
93 of the utilities you usually find in fileutils, shellutils, findutils,
94 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
95 POSIX environment for any small or embedded system. The utilities in
96 BusyBox generally have fewer options than their full-featured GNU
97 cousins; however, the options that are included provide the expected
98 functionality and behave very much like their GNU counterparts.
99
100 BusyBox has been written with size-optimization and limited resources
101 in mind. It is also extremely modular so you can easily include or
102 exclude commands (or features) at compile time. This makes it easy to
103 customize your embedded systems. To create a working system, just add
104 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
105 ae).
106
107 %description -l pl.UTF-8
108 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
109 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
110 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
111 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
112 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
113 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
114 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
115 (np. elvis-tiny albo ae).
116
117 %description -l pt_BR.UTF-8
118 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
119 executável, fornecendo substitutos minimalistas para muitos dos
120 executáveis encontrados em pacotes como fileutils, shellutils,
121 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
122 em geral têm menos opções que os utilitários GNU, mas as opções
123 implementadas comportam-se de maneira similar aos equivalentes GNU.
124
125 %package static
126 Summary:        Static busybox
127 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
128 Group:          Applications
129
130 %description static
131 Static busybox.
132
133 %description static -l pl.UTF-8
134 Statycznie skonsolidowany busybox.
135
136 %package initrd
137 Summary:        Static busybox for initrd
138 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
139 Group:          Applications
140 Conflicts:      geninitrd < 3075
141
142 %description initrd
143 Static busybox for initrd.
144
145 %description initrd -l pl.UTF-8
146 Statycznie skonsolidowany busybox dla initrd.
147
148 %prep
149 %setup -q
150 %patch1 -p1
151 %patch2 -p1
152 %patch3 -p1
153 %patch4 -p1
154 %patch5 -p1
155 %patch6 -p1
156 %patch7 -p1
157 %patch8 -p1
158
159 %build
160 install -d built
161 %if %{with initrd}
162 install %{SOURCE2} .config
163 %{__make} oldconfig
164 %{__make} \
165         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
166         LDFLAGS="%{ld_rpmldflags} -static" \
167 %if %{with dietlibc}
168         LIBRARIES="-lrpc" \
169         CC="diet gcc"
170 %else
171 %if %{with glibc}
172         %{CrossOpts} \
173         CC="%{__cc}"
174 %else
175     %if "%{_target_base_arch}" != "%{_arch}"
176         CROSS="%{_target_cpu}-uclibc-" \
177     %endif
178         CC="%{_target_cpu}-uclibc-gcc"
179 %endif
180 %endif
181
182 mv -f busybox built/busybox.initrd
183 %{__make} clean
184 %endif
185
186
187 %if %{with altconfig}
188 install %{SOURCE3} .config
189 %else
190 install %{SOURCE1} .config
191 %endif
192
193 %if %{with static}
194 %{__make} oldconfig
195 %{__make} \
196         %{CrossOpts} \
197         CFLAGS_EXTRA="%{rpmcflags}" \
198         LDFLAGS="%{ld_rpmldflags} -static" \
199         CC="%{__cc}"
200 mv -f busybox built/busybox.static
201 %{__make} clean
202 %endif
203
204 %{__make} oldconfig
205 %{__make} \
206         %{CrossOpts} \
207         CFLAGS_EXTRA="%{rpmcflags}" \
208         LDFLAGS="%{ld_rpmldflags}" \
209         CC="%{__cc}"
210 %{__make} busybox.links docs/BusyBox.1
211
212 %install
213 rm -rf $RPM_BUILD_ROOT
214 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
215
216 %{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
217 %{?with_initrd:install built/busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
218
219 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
220 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
221 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
222
223 # install links to busybox binary, when linkfl is defined
224 %if %{with linkfl}
225 %{__make} install \
226         PREFIX=$RPM_BUILD_ROOT
227 %else
228 install busybox $RPM_BUILD_ROOT%{_bindir}
229 %endif
230
231 %clean
232 rm -rf $RPM_BUILD_ROOT
233
234 %files
235 %defattr(644,root,root,755)
236 %doc AUTHORS README .config
237
238 %if %{with linkfl}
239 %attr(755,root,root) /bin/*
240 %attr(755,root,root) /sbin/*
241 %attr(755,root,root) %{_bindir}/*
242 %attr(755,root,root) %{_sbindir}/*
243 %else
244 %attr(755,root,root) %{_bindir}/busybox
245 %endif
246
247 %{_libdir}/busybox
248 %{_mandir}/man1/*
249
250 %if %{with static}
251 %files static
252 %defattr(644,root,root,755)
253 %attr(755,root,root) %{_bindir}/busybox.static
254 %endif
255
256 %if %{with initrd}
257 %files initrd
258 %defattr(644,root,root,755)
259 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
260 %endif
This page took 0.13401 seconds and 4 git commands to generate.