]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- pass CC to make
[packages/busybox.git] / busybox.spec
1 # _without_static - don't build static version
2 Summary:        Set of common unix utils for embeded systems
3 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
4 Name:           busybox
5 Version:        0.60.1
6 Release:        17
7 License:        GPL
8 Group:          Applications
9 Source0:        ftp://ftp.lineo.com/pub/busybox/%{name}-%{version}.tar.gz
10 Source1:        %{name}-config.h
11 Patch0:         %{name}-logconsole.patch
12 Patch1:         %{name}-tee.patch
13 Patch3:         %{name}-printf-gettext.patch
14 Patch4:         %{name}-loadfont.patch
15 Patch5:         %{name}-cread.patch
16 Patch6:         %{name}-malloc.patch
17 Patch7:         %{name}-pivot_root.patch
18 URL:            http://busybox.lineo.com/
19 %{!?_without_static:BuildRequires:      glibc-static}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 BusyBox combines tiny versions of many common UNIX utilities into a
24 single small executable. It provides minimalist replacements for most
25 of the utilities you usually find in fileutils, shellutils, findutils,
26 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
27 POSIX environment for any small or embedded system. The utilities in
28 BusyBox generally have fewer options than their full-featured GNU
29 cousins; however, the options that are included provide the expected
30 functionality and behave very much like their GNU counterparts.
31
32 BusyBox has been written with size-optimization and limited resources
33 in mind. It is also extremely modular so you can easily include or
34 exclude commands (or features) at compile time. This makes it easy to
35 customize your embedded systems. To create a working system, just add
36 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
37 ae).
38
39 %description -l pl
40 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
41 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
42 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
43 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
44 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
45 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
46 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
47 (np. elvis-tiny albo ae).
48
49 %package static
50 Summary:        Static busybox
51 Summary(pl):    Statycznie linkowany busybox
52 Group:          Applications
53
54 %description static
55 Static busybox.
56
57 %description static -l pl
58 Statycznie linkowany busybox.
59
60 %prep
61 %setup -q
62 %patch0 -p1
63 %patch1 -p1
64 %patch3 -p1
65 %patch4 -p1
66 %patch5 -p1
67 %patch6 -p1
68 %patch7 -p1
69
70 %build
71 cp -f %{SOURCE1} Config.h
72
73 %if %{?_without_static:0}%{!?_without_static:1}
74 %{__make} \
75         CFLAGS_EXTRA="%{rpmcflags}" \
76         LDFLAGS="%{rpmldflags} -static"
77 mv -f busybox busybox.static
78 %{__make} clean
79 %endif
80
81 %{__make} \
82         CFLAGS_EXTRA="%{rpmcflags}" \
83         LDFLAGS="%{rpmldflags}" \
84         CC="%{__cc}"
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
89
90 %{!?_without_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
91
92 install busybox $RPM_BUILD_ROOT%{_bindir}
93 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
94 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
95 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
96
97 gzip -9nf AUTHORS TODO Changelog README
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %files
103 %defattr(644,root,root,755)
104 %doc *.gz
105 %attr(755,root,root) %{_bindir}/busybox
106 %{_libdir}/busybox
107 %{_mandir}/man1/*
108
109 %if %{?_without_static:0}%{!?_without_static:1}
110 %files static
111 %defattr(644,root,root,755)
112 %attr(755,root,root) %{_bindir}/busybox.static
113 %endif
This page took 0.105466 seconds and 4 git commands to generate.