]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- added sh_name patch and change /bin/sh to /bin/lash (sh is in ash-BOOT)
[packages/busybox.git] / busybox.spec
1 Summary:        Set of common unix utils for embeded systems
2 Name:           busybox
3 Version:        0.51
4 Release:        2
5 License:        GPL
6 Group:          Applications
7 Group(de):      Applikationen
8 Group(pl):      Aplikacje
9 Source0:        ftp://ftp.lineo.com/pub/busybox/%{name}-%{version}.tar.gz
10 Source1:        %{name}-config.h
11 Patch0:         %{name}-logconsole.patch
12 Patch1:         %{name}-tee.patch
13 Patch2:         %{name}-sh-name.patch
14 URL:            http://busybox.lineo.com/
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16 BuildRequires:  uClibc-devel-BOOT
17
18 %description
19 BusyBox combines tiny versions of many common UNIX utilities into a
20 single small executable. It provides minimalist replacements for most
21 of the utilities you usually find in fileutils, shellutils, findutils,
22 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
23 POSIX environment for any small or embedded system. The utilities in
24 BusyBox generally have fewer options than their full-featured GNU
25 cousins; however, the options that are included provide the expected
26 functionality and behave very much like their GNU counterparts.
27
28 BusyBox has been written with size-optimization and limited resources
29 in mind. It is also extremely modular so you can easily include or
30 exclude commands (or features) at compile time. This makes it easy to
31 customize your embedded systems. To create a working system, just add
32 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
33 ae).
34
35 %package BOOT
36 Summary:        busybox for bootdisk
37 Group:          Applications
38
39 %description BOOT
40
41 %prep
42 %setup -q
43 %patch0
44 %patch1
45 %patch2 -p1
46
47
48 %build
49 # BOOT
50 cp %{SOURCE1} Config.h
51 %{__make} \
52         CFLAGS_EXTRA="-I%{_libdir}/bootdisk%{_includedir}" \
53         LDFLAGS="-nostdlib -s" \
54         LIBRARIES="%{_libdir}/bootdisk%{_libdir}/crt0.o %{_libdir}/bootdisk%{_libdir}/libc.a -lgcc"
55
56 # TODO make main package dynamically linked
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 # BOOT
61 %{__install} -d $RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/
62 %{__install} -d $RPM_BUILD_ROOT%{_libdir}/bootdisk%{_libdir}/busybox
63 %{__install} busybox $RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/busybox
64 for i in `cat busybox.links`; do ln -sfn busybox "$RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/`basename $i`"; done
65 %{__install} busybox.links $RPM_BUILD_ROOT%{_libdir}/bootdisk%{_libdir}/busybox
66 # change sh to lash (see sh_name patch)
67 mv -f $RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/{sh,lash}
68
69 %{__install} -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/busybox,%{_mandir}/man1}
70 %{__install} busybox $RPM_BUILD_ROOT%{_bindir}
71 %{__install} busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
72 %{__install} docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
73 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
74
75
76 gzip -9nf AUTHORS TODO Changelog README
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc *.gz
84 %attr(755,root,root) %{_bindir}/*
85 %{_libdir}/busybox
86 %{_mandir}/man1/*
87
88 %files BOOT
89 %defattr(644,root,root,755)
90 %attr(755,root,root) %{_libdir}/bootdisk/bin/*
91 %{_libdir}/bootdisk%{_libdir}/*
This page took 0.037004 seconds and 4 git commands to generate.