]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- added full_initrd bcond
[packages/busybox.git] / busybox.spec
1 # TODO:
2 #       - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
3 #       - make internal commands work even if busybox is not in /bin/busybox (initrd)
4 #         or when /proc is not mounted (static / normal)
5 #
6 # Conditional build:
7 # alternative busybox config file (replaces default one) you should
8 # define cfgfile macro, i.e.
9 #
10 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
11 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
12 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
13 # Options below are useful, when you want fileutils and grep providing.
14 # For example, ash package requires fileutils and grep.
15 %bcond_with     fileutl_prov    # adds fileutils providing
16 %bcond_with     grep_prov       # adds grep providing
17 # Option below is useful, when busybox is built with shell support.
18 %bcond_with     sh_prov         # adds /bin/sh providing
19 # WARNING! Shell, fileutils and grep providing may depend on config file!
20 # Fileutils, grep and shell provided with busybox have not such
21 # functionality as their GNU countenders.
22 #
23 %bcond_without  static          # don't build static version
24 %bcond_without  initrd          # don't build initrd version
25 %bcond_with     full_initrd     # build full featured initrd version
26 %bcond_with     dietlibc        # build dietlibc-based initrd version
27 %bcond_with     glibc           # build glibc-based initrd version
28 %bcond_with     verbose
29 #
30 %ifnarch %{ix86} %{x8664} ppc
31 %define with_glibc 1
32 %endif
33 Summary:        Set of common Unix utilities for embeded systems
34 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
35 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
36 Name:           busybox
37 # stable line only
38 Version:        1.12.4
39 Release:        3
40 License:        GPL
41 Group:          Applications
42 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
43 # Source0-md5:  5b8c427bf596732d6b6156672e6e093f
44 Source1:        %{name}.config
45 Source2:        %{name}-initrd.config
46 %{?with_altconfig:Source3:      %{cfgfile}}
47 Patch1:         %{name}-logconsole.patch
48 Patch2:         %{name}-printf-gettext.patch
49 Patch3:         %{name}-loadfont.patch
50 Patch4:         %{name}-kernel_headers.patch
51 Patch5:         %{name}-insmod-morearchs.patch
52 Patch6:         %{name}-dhcp.patch
53 Patch7:         %{name}-fix_64_archs.patch
54 Patch8:         %{name}-inotify.patch
55 Patch9:         %{name}-ash-export-PATH.patch
56 URL:            http://www.busybox.net/
57 BuildRequires:  gcc >= 3.2
58 BuildRequires:  perl-tools-pod
59 BuildRequires:  rpmbuild(macros) >= 1.333
60 %{?with_static:BuildRequires:   glibc-static}
61 %if %{with initrd}
62         %if %{with dietlibc}
63 BuildRequires:  dietlibc-static
64         %else
65                 %if %{with glibc}
66 BuildRequires:  glibc-static
67                 %else
68 %if "%{_target_base_arch}" != "%{_arch}"
69 BuildRequires:  cross%{_target_base_arch}-uClibc-static
70 %else
71         %ifarch ppc %{x8664}
72 BuildRequires:  uClibc-static >= 2:0.9.29
73         %else
74 BuildRequires:  uClibc-static >= 2:0.9.21
75         %endif
76 %endif
77                 %endif
78         %endif
79 %endif
80 %{?with_fileutl_prov:Provides:  fileutils}
81 %{?with_grep_prov:Provides:     grep}
82 %{?with_sh_prov:Provides:       /bin/sh}
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %define         _bindir         /bin
86 %define         _initrd_bindir  /bin
87
88 %if "%{_target_base_arch}" != "%{_arch}"
89         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
90 %else
91         %define CrossOpts %{nil}
92 %endif
93
94 %define         filterout_ld    -Wl,-z,(combreloc|relro)
95
96 %description
97 BusyBox combines tiny versions of many common UNIX utilities into a
98 single small executable. It provides minimalist replacements for most
99 of the utilities you usually find in fileutils, shellutils, findutils,
100 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
101 POSIX environment for any small or embedded system. The utilities in
102 BusyBox generally have fewer options than their full-featured GNU
103 cousins; however, the options that are included provide the expected
104 functionality and behave very much like their GNU counterparts.
105
106 BusyBox has been written with size-optimization and limited resources
107 in mind. It is also extremely modular so you can easily include or
108 exclude commands (or features) at compile time. This makes it easy to
109 customize your embedded systems. To create a working system, just add
110 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
111 ae).
112
113 %description -l pl.UTF-8
114 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
115 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
116 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
117 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
118 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
119 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
120 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
121 (np. elvis-tiny albo ae).
122
123 %description -l pt_BR.UTF-8
124 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
125 executável, fornecendo substitutos minimalistas para muitos dos
126 executáveis encontrados em pacotes como fileutils, shellutils,
127 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
128 em geral têm menos opções que os utilitários GNU, mas as opções
129 implementadas comportam-se de maneira similar aos equivalentes GNU.
130
131 %package static
132 Summary:        Static busybox
133 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
134 Group:          Applications
135
136 %description static
137 Static busybox.
138
139 %description static -l pl.UTF-8
140 Statycznie skonsolidowany busybox.
141
142 %package initrd
143 Summary:        Static busybox for initrd
144 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
145 Group:          Applications
146 Conflicts:      geninitrd < 3075
147
148 %description initrd
149 Static busybox for initrd.
150
151 %description initrd -l pl.UTF-8
152 Statycznie skonsolidowany busybox dla initrd.
153
154 %prep
155 %setup -q
156 %patch1 -p1
157 %patch2 -p1
158 %patch3 -p1
159 %patch4 -p1
160 %patch5 -p1
161 %patch6 -p1
162 %patch7 -p1
163 %patch8 -p1
164 %patch9 -p1
165
166 %build
167 install -d built
168 %if %{with initrd}
169 %if %{with full_initrd}
170 install %{SOURCE1} .config
171 %else
172 install %{SOURCE2} .config
173 %endif
174 %{__make} oldconfig
175 %{__make} \
176         %{?with_verbose:V=1} \
177         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
178         LDFLAGS="%{ld_rpmldflags} -static" \
179 %if %{with dietlibc}
180         LIBRARIES="-lrpc" \
181         CC="diet gcc"
182 %else
183 %if %{with glibc}
184         %{CrossOpts} \
185         CC="%{__cc}"
186 %else
187     %if "%{_target_base_arch}" != "%{_arch}"
188         CROSS="%{_target_cpu}-uclibc-" \
189     %endif
190         CC="%{_target_cpu}-uclibc-gcc"
191 %endif
192 %endif
193
194 mv -f busybox built/busybox.initrd
195 %{__make} clean
196 %endif
197
198
199 %if %{with altconfig}
200 install %{SOURCE3} .config
201 %else
202 install %{SOURCE1} .config
203 %endif
204
205 %if %{with static}
206 %{__make} oldconfig
207 %{__make} \
208         %{?with_verbose:V=1} \
209         %{CrossOpts} \
210         CFLAGS_EXTRA="%{rpmcflags}" \
211         LDFLAGS="%{ld_rpmldflags} -static" \
212         CC="%{__cc}"
213 mv -f busybox built/busybox.static
214 %{__make} clean
215 %endif
216
217 %{__make} oldconfig
218 %{__make} \
219         %{?with_verbose:V=1} \
220         %{CrossOpts} \
221         CFLAGS_EXTRA="%{rpmcflags}" \
222         LDFLAGS="%{ld_rpmldflags}" \
223         CC="%{__cc}"
224 %{__make} busybox.links docs/BusyBox.1
225
226 %install
227 rm -rf $RPM_BUILD_ROOT
228 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
229
230 %{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
231 %{?with_initrd:install built/busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
232
233 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
234 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
235 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
236
237 # install links to busybox binary, when linkfl is defined
238 %if %{with linkfl}
239 %{__make} install \
240         PREFIX=$RPM_BUILD_ROOT
241 %else
242 install busybox $RPM_BUILD_ROOT%{_bindir}
243 %endif
244
245 %clean
246 rm -rf $RPM_BUILD_ROOT
247
248 %files
249 %defattr(644,root,root,755)
250 %doc AUTHORS README .config
251
252 %if %{with linkfl}
253 %attr(755,root,root) /bin/*
254 %attr(755,root,root) /sbin/*
255 %attr(755,root,root) %{_bindir}/*
256 %attr(755,root,root) %{_sbindir}/*
257 %else
258 %attr(755,root,root) %{_bindir}/busybox
259 %endif
260
261 %{_libdir}/busybox
262 %{_mandir}/man1/*
263
264 %if %{with static}
265 %files static
266 %defattr(644,root,root,755)
267 %attr(755,root,root) %{_bindir}/busybox.static
268 %endif
269
270 %if %{with initrd}
271 %files initrd
272 %defattr(644,root,root,755)
273 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
274 %endif
This page took 0.078756 seconds and 4 git commands to generate.