]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
This commit was manufactured by cvs2git to create branch 'BUSYBOX_1_12'.
[packages/busybox.git] / busybox.spec
1 # TODO:
2 #       - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
3 #       - make internal commands work even if busybox is not in /bin/busybox (initrd)
4 #         or when /proc is not mounted (static / normal)
5 #
6 # Conditional build:
7 # alternative busybox config file (replaces default one) you should
8 # define cfgfile macro, i.e.
9 #
10 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
11 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
12 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
13 # Options below are useful, when you want fileutils and grep providing.
14 # For example, ash package requires fileutils and grep.
15 %bcond_with     fileutl_prov    # adds fileutils providing
16 %bcond_with     grep_prov       # adds grep providing
17 # Option below is useful, when busybox is built with shell support.
18 %bcond_with     sh_prov         # adds /bin/sh providing
19 # WARNING! Shell, fileutils and grep providing may depend on config file!
20 # Fileutils, grep and shell provided with busybox have not such
21 # functionality as their GNU countenders.
22 #
23 %bcond_without  static          # don't build static version
24 %bcond_without  initrd          # don't build initrd version
25 %bcond_with     dietlibc        # build dietlibc-based initrd and static versions
26 %bcond_with     glibc           # build glibc-based initrd and static versions
27 %bcond_with     verbose
28 #
29 %ifnarch %{ix86} %{x8664} ppc
30 %define with_glibc 1
31 %endif
32 Summary:        Set of common Unix utilities for embeded systems
33 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
34 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
35 Name:           busybox
36 # stable line only
37 Version:        1.12.4
38 Release:        4
39 License:        GPL
40 Group:          Applications
41 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
42 # Source0-md5:  5b8c427bf596732d6b6156672e6e093f
43 Source1:        %{name}.config
44 Source2:        %{name}-initrd.config
45 %{?with_altconfig:Source3:      %{cfgfile}}
46 Patch1:         %{name}-logconsole.patch
47 Patch2:         %{name}-printf-gettext.patch
48 Patch3:         %{name}-loadfont.patch
49 Patch4:         %{name}-kernel_headers.patch
50 Patch5:         %{name}-insmod-morearchs.patch
51 Patch6:         %{name}-dhcp.patch
52 Patch7:         %{name}-fix_64_archs.patch
53 Patch8:         %{name}-inotify.patch
54 Patch9:         %{name}-ash-export-PATH.patch
55 URL:            http://www.busybox.net/
56 BuildRequires:  gcc >= 3.2
57 BuildRequires:  perl-tools-pod
58 BuildRequires:  rpmbuild(macros) >= 1.333
59 %if %{with initrd} || %{with static}
60         %if %{with dietlibc}
61 BuildRequires:  dietlibc-static
62         %else
63                 %if %{with glibc}
64 BuildRequires:  glibc-static
65                 %else
66 %if "%{_target_base_arch}" != "%{_arch}"
67 BuildRequires:  cross%{_target_base_arch}-uClibc-static
68 %else
69         %ifarch ppc %{x8664}
70 BuildRequires:  uClibc-static >= 2:0.9.29
71         %else
72 BuildRequires:  uClibc-static >= 2:0.9.21
73         %endif
74 %endif
75                 %endif
76         %endif
77 %endif
78 %{?with_fileutl_prov:Provides:  fileutils}
79 %{?with_grep_prov:Provides:     grep}
80 %{?with_sh_prov:Provides:       /bin/sh}
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %define         _bindir         /bin
84 %define         _initrd_bindir  /bin
85
86 %if "%{_target_base_arch}" != "%{_arch}"
87         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
88 %else
89         %define CrossOpts %{nil}
90 %endif
91
92 %define         filterout_ld    -Wl,-z,(combreloc|relro)
93
94 %description
95 BusyBox combines tiny versions of many common UNIX utilities into a
96 single small executable. It provides minimalist replacements for most
97 of the utilities you usually find in fileutils, shellutils, findutils,
98 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
99 POSIX environment for any small or embedded system. The utilities in
100 BusyBox generally have fewer options than their full-featured GNU
101 cousins; however, the options that are included provide the expected
102 functionality and behave very much like their GNU counterparts.
103
104 BusyBox has been written with size-optimization and limited resources
105 in mind. It is also extremely modular so you can easily include or
106 exclude commands (or features) at compile time. This makes it easy to
107 customize your embedded systems. To create a working system, just add
108 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
109 ae).
110
111 %description -l pl.UTF-8
112 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
113 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
114 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
115 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
116 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
117 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
118 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
119 (np. elvis-tiny albo ae).
120
121 %description -l pt_BR.UTF-8
122 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
123 executável, fornecendo substitutos minimalistas para muitos dos
124 executáveis encontrados em pacotes como fileutils, shellutils,
125 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
126 em geral têm menos opções que os utilitários GNU, mas as opções
127 implementadas comportam-se de maneira similar aos equivalentes GNU.
128
129 %package static
130 Summary:        Static busybox
131 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
132 Group:          Applications
133
134 %description static
135 Static busybox.
136
137 %description static -l pl.UTF-8
138 Statycznie skonsolidowany busybox.
139
140 %package initrd
141 Summary:        Static busybox for initrd
142 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
143 Group:          Applications
144 Conflicts:      geninitrd < 3075
145
146 %description initrd
147 Static busybox for initrd.
148
149 %description initrd -l pl.UTF-8
150 Statycznie skonsolidowany busybox dla initrd.
151
152 %prep
153 %setup -q
154 %patch1 -p1
155 %patch2 -p1
156 %patch3 -p1
157 %patch4 -p1
158 %patch5 -p1
159 %patch6 -p1
160 %patch7 -p1
161 %patch8 -p1
162 %patch9 -p1
163
164 %build
165 install -d built
166 %if %{with initrd}
167 install %{SOURCE2} .config
168 %{__make} oldconfig
169 %{__make} \
170         %{?with_verbose:V=1} \
171         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
172         LDFLAGS="%{ld_rpmldflags} -static" \
173 %if %{with dietlibc}
174         LIBRARIES="-lrpc" \
175         CC="diet gcc"
176 %else
177 %if %{with glibc}
178         %{CrossOpts} \
179         CC="%{__cc}"
180 %else
181     %if "%{_target_base_arch}" != "%{_arch}"
182         CROSS="%{_target_cpu}-uclibc-" \
183     %endif
184         CC="%{_target_cpu}-uclibc-gcc"
185 %endif
186 %endif
187
188 mv -f busybox built/busybox.initrd
189 %{__make} clean
190 %endif
191
192
193 %if %{with altconfig}
194 install %{SOURCE3} .config
195 %else
196 install %{SOURCE1} .config
197 %endif
198
199 %if %{with static}
200 %{__make} oldconfig
201 %{__make} \
202         %{?with_verbose:V=1} \
203         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
204         LDFLAGS="%{ld_rpmldflags} -static" \
205 %if %{with dietlibc}
206         LIBRARIES="-lrpc" \
207         CC="diet gcc"
208 %else
209 %if %{with glibc}
210         %{CrossOpts} \
211         CC="%{__cc}"
212 %else
213     %if "%{_target_base_arch}" != "%{_arch}"
214         CROSS="%{_target_cpu}-uclibc-" \
215     %endif
216         CC="%{_target_cpu}-uclibc-gcc"
217 %endif
218 %endif
219
220 mv -f busybox built/busybox.static
221 %{__make} clean
222 %endif
223
224 %{__make} oldconfig
225 %{__make} \
226         %{?with_verbose:V=1} \
227         %{CrossOpts} \
228         CFLAGS_EXTRA="%{rpmcflags}" \
229         LDFLAGS="%{ld_rpmldflags}" \
230         CC="%{__cc}"
231 %{__make} busybox.links docs/BusyBox.1
232
233 %install
234 rm -rf $RPM_BUILD_ROOT
235 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
236
237 %{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
238 %{?with_initrd:install built/busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
239
240 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
241 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
242 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
243
244 # install links to busybox binary, when linkfl is defined
245 %if %{with linkfl}
246 %{__make} install \
247         PREFIX=$RPM_BUILD_ROOT
248 %else
249 install busybox $RPM_BUILD_ROOT%{_bindir}
250 %endif
251
252 %clean
253 rm -rf $RPM_BUILD_ROOT
254
255 %files
256 %defattr(644,root,root,755)
257 %doc AUTHORS README .config
258
259 %if %{with linkfl}
260 %attr(755,root,root) /bin/*
261 %attr(755,root,root) /sbin/*
262 %attr(755,root,root) %{_bindir}/*
263 %attr(755,root,root) %{_sbindir}/*
264 %else
265 %attr(755,root,root) %{_bindir}/busybox
266 %endif
267
268 %{_libdir}/busybox
269 %{_mandir}/man1/*
270
271 %if %{with static}
272 %files static
273 %defattr(644,root,root,755)
274 %attr(755,root,root) %{_bindir}/busybox.static
275 %endif
276
277 %if %{with initrd}
278 %files initrd
279 %defattr(644,root,root,755)
280 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
281 %endif
This page took 0.081181 seconds and 4 git commands to generate.