]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- added new options:
[packages/busybox.git] / busybox.spec
1
2 #
3 # _with_altconfig <name>  - alternative busybox config file (replaces default one)
4 #                           you should define cfgfile macro, i.e.
5 #
6 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
7 #
8 #
9 # _with_linkfl            - creates links to busybox binary and puts them into file list;
10 #
11 # Options below are useful, when you want fileutils and grep providing.
12 # For example, ash package requires fileutils and grep.
13 #
14 # _with_fileutl_prov      - adds fileutils providing
15 # _with_grep_prov         - adds grep providing
16 #
17 #
18 # Option below is useful, when busybox is built with shell support.
19 #
20 # _with_sh_prov           - adds /bin/sh providing
21 #
22 #
23 # WARNING! Shell, filetuils and grep providing may depend on config file!
24 # Fileutils, grep and shell provided with busybox have not such
25 # functionality as their GNU countenders.
26 #
27 #
28 # _without_static         - don't build static version
29 #
30
31 Summary:        Set of common unix utils for embeded systems
32 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
33 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
34 Name:           busybox
35 Version:        0.60.2
36 Release:        6
37 License:        GPL
38 Group:          Applications
39 Source0:        ftp://ftp.lineo.com/pub/busybox/%{name}-%{version}.tar.gz
40 %{!?_with_altconfig:Source1:    %{name}-config.h}
41 %{?_with_altconfig:Source1:     %{cfgfile}}
42 Patch0:         %{name}-logconsole.patch
43 Patch1:         %{name}-tee.patch
44 Patch3:         %{name}-printf-gettext.patch
45 Patch4:         %{name}-loadfont.patch
46 Patch5:         %{name}-cread.patch
47 Patch6:         %{name}-malloc.patch
48 Patch7:         %{name}-pivot_root.patch
49 URL:            http://busybox.lineo.com/
50 %{?_with_fileutl_prov:Provides: fileutils}
51 %{?_with_grep_prov:Provides:    grep}
52 %{?_with_sh_prov:Provides:      /bin/sh}
53 %{!?_without_static:BuildRequires:      glibc-static}
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 BusyBox combines tiny versions of many common UNIX utilities into a
58 single small executable. It provides minimalist replacements for most
59 of the utilities you usually find in fileutils, shellutils, findutils,
60 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
61 POSIX environment for any small or embedded system. The utilities in
62 BusyBox generally have fewer options than their full-featured GNU
63 cousins; however, the options that are included provide the expected
64 functionality and behave very much like their GNU counterparts.
65
66 BusyBox has been written with size-optimization and limited resources
67 in mind. It is also extremely modular so you can easily include or
68 exclude commands (or features) at compile time. This makes it easy to
69 customize your embedded systems. To create a working system, just add
70 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
71 ae).
72
73 %description -l pl
74 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
75 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
76 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
77 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
78 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
79 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
80 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
81 (np. elvis-tiny albo ae).
82
83 %description -l pt_BR
84 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
85 executável, fornecendo substitutos minimalistas para muitos dos
86 executáveis encontrados em pacotes como fileutils, shellutils,
87 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
88 em geral têm menos opções que os utilitários GNU, mas as opções
89 implementadas comportam-se de maneira similar aos equivalentes GNU.
90
91 %package static
92 Summary:        Static busybox
93 Summary(pl):    Statycznie linkowany busybox
94 Group:          Applications
95
96 %description static
97 Static busybox.
98
99 %description static -l pl
100 Statycznie linkowany busybox.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105 %patch1 -p1
106 %patch3 -p1
107 %patch4 -p1
108 %patch5 -p1
109 %patch6 -p1
110 %patch7 -p1
111
112 %build
113 cp -f %{SOURCE1} Config.h
114
115 %if %{?_without_static:0}%{!?_without_static:1}
116 %{__make} \
117         CFLAGS_EXTRA="%{rpmcflags}" \
118         LDFLAGS="%{rpmldflags} -static"
119 mv -f busybox busybox.static
120 %{__make} clean
121 %endif
122
123 %{__make} \
124         CFLAGS_EXTRA="%{rpmcflags}" \
125         LDFLAGS="%{rpmldflags}" \
126         CC="%{__cc}"
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
131
132 %{!?_without_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
133
134 install busybox $RPM_BUILD_ROOT%{_bindir}
135 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
136 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
137 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
138
139 # install links to busybox binary, when linkfl is defined
140 %{?_with_linkfl:make install PREFIX=$RPM_BUILD_ROOT}
141
142 gzip -9nf AUTHORS TODO Changelog README
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %files
148 %defattr(644,root,root,755)
149 %doc *.gz
150
151 %{?!_with_linkfl: %attr(755,root,root) %{_bindir}/busybox}
152
153 %if %{?_with_linkfl:1}%{?!_with_linkfl:0}
154 %attr(755,root,root) /bin/*
155 %attr(755,root,root) /sbin/*
156 %attr(755,root,root) %{_bindir}/*
157 %attr(755,root,root) %{_sbindir}/*
158 %endif
159
160 %{_libdir}/busybox
161 %{_mandir}/man1/*
162
163 %if %{?_without_static:0}%{!?_without_static:1}
164 %files static
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_bindir}/busybox.static
167 %endif
This page took 0.047647 seconds and 4 git commands to generate.