]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- removed obsolete readahead patch
[packages/busybox.git] / busybox.spec
1 #
2 # TODO:
3 #       - sparc64 modules support in sparc(32) version
4 #       - make internal commands work even if busybox is not in /bin/busybox
5
6 #
7 # Conditional build:
8 # alternative busybox config file (replaces default one) you should
9 # define cfgfile macro, i.e.
10 #
11 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
12 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
13 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
14 # Options below are useful, when you want fileutils and grep providing.
15 # For example, ash package requires fileutils and grep.
16 %bcond_with     fileutl_prov    # adds fileutils providing
17 %bcond_with     grep_prov       # adds grep providing
18 # Option below is useful, when busybox is built with shell support.
19 %bcond_with     sh_prov         # adds /bin/sh providing
20 # WARNING! Shell, filetuils and grep providing may depend on config file!
21 # Fileutils, grep and shell provided with busybox have not such
22 # functionality as their GNU countenders.
23 #
24 %bcond_without  static          # don't build static version
25 %bcond_without  initrd          # don't build initrd version
26 %bcond_with     dietlibc        # build dietlibc-based initrd version
27 %bcond_with     glibc           # build glibc-based initrd version
28 #
29 %ifnarch %{ix86}
30 %define with_glibc 1
31 %endif
32 Summary:        Set of common unix utils for embeded systems
33 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
34 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
35 Name:           busybox
36 Version:        1.00
37 %define pre     rc2
38 Release:        0.%{pre}.1
39 License:        GPL
40 Group:          Applications
41 Source0:        http://www.busybox.net/downloads/%{name}-%{version}-%{pre}.tar.bz2
42 # Source0-md5:  2a8690e02abab283ec6ab9caeac01a85
43 Source1:        %{name}.config
44 Source2:        %{name}-initrd.config
45 %{?with_altconfig:Source3:      %{cfgfile}}
46 Patch0:         %{name}-logconsole.patch
47 Patch1:         %{name}-printf-gettext.patch
48 Patch2:         %{name}-loadfont.patch
49 Patch3:         %{name}-pivot_root.patch
50 Patch4:         %{name}-raid_start.patch
51 Patch5:         %{name}-force-dietlibc.patch
52 Patch6:         %{name}-ash_exec.patch
53 Patch7:         %{name}-kernel_headers.patch
54 Patch8:         %{name}-insmod-morearchs.patch
55 Patch9:         %{name}-dhcp.patch
56 URL:            http://www.busybox.net/
57 BuildRequires:  gcc >= 3.2
58 %{?with_static:BuildRequires:   glibc-static}
59 %if %{with initrd}
60   %if %{with dietlibc}
61 BuildRequires:  dietlibc-static
62   %else
63     %if %{with glibc}
64 BuildRequires:  glibc-static
65     %else
66 BuildRequires:  uClibc-static >= 0.9.21
67     %endif
68   %endif
69 %endif
70 %{?with_fileutl_prov:Provides:  fileutils}
71 %{?with_grep_prov:Provides:     grep}
72 %{?with_sh_prov:Provides:       /bin/sh}
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75
76 %define         _bindir         /bin
77 %define         _initrd_bindir  /bin
78
79 %description
80 BusyBox combines tiny versions of many common UNIX utilities into a
81 single small executable. It provides minimalist replacements for most
82 of the utilities you usually find in fileutils, shellutils, findutils,
83 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
84 POSIX environment for any small or embedded system. The utilities in
85 BusyBox generally have fewer options than their full-featured GNU
86 cousins; however, the options that are included provide the expected
87 functionality and behave very much like their GNU counterparts.
88
89 BusyBox has been written with size-optimization and limited resources
90 in mind. It is also extremely modular so you can easily include or
91 exclude commands (or features) at compile time. This makes it easy to
92 customize your embedded systems. To create a working system, just add
93 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
94 ae).
95
96 %description -l pl
97 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
98 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
99 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
100 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
101 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
102 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
103 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
104 (np. elvis-tiny albo ae).
105
106 %description -l pt_BR
107 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
108 executável, fornecendo substitutos minimalistas para muitos dos
109 executáveis encontrados em pacotes como fileutils, shellutils,
110 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
111 em geral têm menos opções que os utilitários GNU, mas as opções
112 implementadas comportam-se de maneira similar aos equivalentes GNU.
113
114 %package static
115 Summary:        Static busybox
116 Summary(pl):    Statycznie skonsolidowany busybox
117 Group:          Applications
118
119 %description static
120 Static busybox.
121
122 %description static -l pl
123 Statycznie skonsolidowany busybox.
124
125 %package initrd
126 Summary:        Static busybox for initrd
127 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
128 Group:          Applications
129 Conflicts:      geninitrd < 3075
130
131 %description initrd
132 Static busybox for initrd.
133
134 %description initrd -l pl
135 Statycznie skonsolidowany busybox dla initrd.
136
137 %prep
138 %setup -q -n %{name}-%{version}-%{pre}
139 %patch0 -p1
140 %patch1 -p1
141 %patch2 -p1
142 %patch3 -p1
143 %patch4 -p1
144 %patch5 -p1
145 %patch6 -p1
146 %patch7 -p1
147 %patch8 -p1
148 %patch9 -p1
149
150 %build
151 install %{SOURCE1} .config
152
153 %if %{with initrd}
154 install %{SOURCE2} .config
155 %{__make} oldconfig
156 %{__make} \
157         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
158         LDFLAGS="%{rpmldflags} -static" \
159 %if %{with dietlibc}
160         LIBRARIES="-lrpc" \
161         CC="diet gcc"
162 %else
163 %if %{with glibc}
164         CC="%{__cc}"
165 %else
166         CC="%{_target_cpu}-uclibc-gcc"
167 %endif
168 %endif
169
170 mv -f busybox busybox.initrd
171 %{__make} clean
172 install %{SOURCE1} .config
173 %endif
174
175 %if %{with altconfig}
176 install %{SOURCE3} .config
177 %endif
178
179 %if %{with static}
180 %{__make} oldconfig
181 %{__make}  \
182         CFLAGS_EXTRA="%{rpmcflags}" \
183         LDFLAGS="%{rpmldflags} -static" \
184         CC="%{__cc}"
185 mv -f busybox busybox.static
186 %{__make} clean
187 %endif
188
189 %{__make} oldconfig
190 %{__make} \
191         CFLAGS_EXTRA="%{rpmcflags}" \
192         LDFLAGS="%{rpmldflags}" \
193         CC="%{__cc}"
194
195 %install
196 rm -rf $RPM_BUILD_ROOT
197 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
198
199 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
200 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
201
202 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
203 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
204 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
205
206 # install links to busybox binary, when linkfl is defined
207 %if %{with linkfl}
208 %{__make} install \
209         PREFIX=$RPM_BUILD_ROOT
210 %else
211 install busybox $RPM_BUILD_ROOT%{_bindir}
212 %endif
213
214 %clean
215 rm -rf $RPM_BUILD_ROOT
216
217 %files
218 %defattr(644,root,root,755)
219 %doc AUTHORS Changelog README .config
220
221 %if %{with linkfl}
222 %attr(755,root,root) /bin/*
223 %attr(755,root,root) /sbin/*
224 %attr(755,root,root) %{_bindir}/*
225 %attr(755,root,root) %{_sbindir}/*
226 %else
227 %attr(755,root,root) %{_bindir}/busybox
228 %endif
229
230 %{_libdir}/busybox
231 %{_mandir}/man1/*
232
233 %if %{with static}
234 %files static
235 %defattr(644,root,root,755)
236 %attr(755,root,root) %{_bindir}/busybox.static
237 %endif
238
239 %if %{with initrd}
240 %files initrd
241 %defattr(644,root,root,755)
242 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
243 %endif
This page took 0.153085 seconds and 4 git commands to generate.