]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- updated to pre5
[packages/busybox.git] / busybox.spec
1
2 # alternative busybox config file (replaces default one) you should
3 # define cfgfile macro, i.e.
4 #
5 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
6 %bcond_with altconfig
7
8 %bcond_with linkfl # creates links to busybox binary and puts them into file list
9
10 # Options below are useful, when you want fileutils and grep providing.
11 # For example, ash package requires fileutils and grep.
12 %bcond_with fileutl_prov # adds fileutils providing
13 %bcond_with grep_prov    # adds grep providing
14
15 # Option below is useful, when busybox is built with shell support.
16 %bcond_with sh_prov      # adds /bin/sh providing
17
18 # WARNING! Shell, filetuils and grep providing may depend on config file!
19 # Fileutils, grep and shell provided with busybox have not such
20 # functionality as their GNU countenders.
21
22 %bcond_without static  # don't build static version
23 %bcond_without initrd  # don't build initrd version
24
25 %bcond_with dietlibc
26 %bcond_with glibc
27
28 %ifnarch %{ix86}
29 %define with_glibc 1
30 %endif
31
32 %define pre     pre5
33 Summary:        Set of common unix utils for embeded systems
34 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
35 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
36 Name:           busybox
37 Version:        1.00
38 Release:        0.%{pre}.1
39 License:        GPL
40 Group:          Applications
41 Source0:        http://www.busybox.net/downloads/%{name}-%{version}-%{pre}.tar.bz2
42 # Source0-md5:  f89d08842d0a48c73ba4ef1e3c3bdb8b
43 Source1:        %{name}.config
44 Source2:        %{name}-initrd.config
45 %{?with_altconfig:Source3:      %{cfgfile}}
46 Patch0:         %{name}-logconsole.patch
47 Patch1:         %{name}-print_ascii.patch
48 Patch2:         %{name}-printf-gettext.patch
49 Patch3:         %{name}-loadfont.patch
50 Patch4:         %{name}-pivot_root.patch
51 Patch5:         %{name}-malloc.patch
52 Patch6:         %{name}-raid_start.patch
53 Patch8:         %{name}-force-dietlibc.patch
54 Patch9:         %{name}-ash_exec.patch
55 Patch10:        %{name}-amd64.patch
56 Patch11:        %{name}-kernel_headers.patch
57 URL:            http://www.busybox.net/
58 %{?with_fileutl_prov:Provides:  fileutils}
59 %{?with_grep_prov:Provides:     grep}
60 %{?with_sh_prov:Provides:       /bin/sh}
61 %{?with_static:BuildRequires:   glibc-static}
62 %if %{with initrd}
63   %if %{with dietlibc}
64 BuildRequires:  dietlibc-static
65   %else
66     %if %{with glibc}
67 BuildRequires:  glibc-static
68     %else
69 BuildRequires:  uClibc-static >= 0.9.21
70     %endif
71   %endif
72 %endif
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         _initrd_bindir  /bin
76
77 %description
78 BusyBox combines tiny versions of many common UNIX utilities into a
79 single small executable. It provides minimalist replacements for most
80 of the utilities you usually find in fileutils, shellutils, findutils,
81 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
82 POSIX environment for any small or embedded system. The utilities in
83 BusyBox generally have fewer options than their full-featured GNU
84 cousins; however, the options that are included provide the expected
85 functionality and behave very much like their GNU counterparts.
86
87 BusyBox has been written with size-optimization and limited resources
88 in mind. It is also extremely modular so you can easily include or
89 exclude commands (or features) at compile time. This makes it easy to
90 customize your embedded systems. To create a working system, just add
91 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
92 ae).
93
94 %description -l pl
95 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
96 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
97 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
98 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
99 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
100 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
101 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
102 (np. elvis-tiny albo ae).
103
104 %description -l pt_BR
105 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
106 executável, fornecendo substitutos minimalistas para muitos dos
107 executáveis encontrados em pacotes como fileutils, shellutils,
108 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
109 em geral têm menos opções que os utilitários GNU, mas as opções
110 implementadas comportam-se de maneira similar aos equivalentes GNU.
111
112 %package static
113 Summary:        Static busybox
114 Summary(pl):    Statycznie skonsolidowany busybox
115 Group:          Applications
116
117 %description static
118 Static busybox.
119
120 %description static -l pl
121 Statycznie skonsolidowany busybox.
122
123 %package initrd
124 Summary:        Static busybox for initrd
125 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
126 Group:          Applications
127
128 %description initrd
129 Static busybox for initrd.
130
131 %description initrd -l pl
132 Statycznie skonsolidowany busybox dla initrd.
133
134 %prep
135 %setup -q -n %{name}-%{version}-%{pre}
136 %patch0 -p1
137 %patch1 -p1
138 #X %patch2 -p1 // UPDATE ME
139 %patch3 -p1
140 %patch4 -p1
141 #%patch5 -p1 // not needed
142 %patch6 -p1
143 %patch8 -p1
144 %patch9 -p1
145 %patch10 -p1
146 %patch11 -p1
147
148 %build
149 install %{SOURCE1} .config
150
151 %if %{with initrd}
152 install %{SOURCE2} .config
153 %{__make} oldconfig
154 %{__make} \
155         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
156         LDFLAGS="%{rpmldflags} -static" \
157 %if %{with dietlibc}
158         LIBRARIES="-lrpc" \
159         CC="diet gcc"
160 %else
161 %if %{with glibc}
162         CC="%{__cc}"
163 %else
164         CC="%{_target_cpu}-uclibc-gcc"
165 %endif
166 %endif
167
168 mv -f busybox busybox.initrd
169 %{__make} clean
170 install %{SOURCE1} .config
171 %endif
172
173 %if %{with altconfig}
174 install %{SOURCE3} .config
175 %endif
176
177 %if %{with static}
178 %{__make} oldconfig
179 %{__make}  \
180         CFLAGS_EXTRA="%{rpmcflags}" \
181         LDFLAGS="%{rpmldflags} -static" \
182         CC="%{__cc}"
183 mv -f busybox busybox.static
184 %{__make} clean
185 %endif
186
187 %{__make} oldconfig
188 %{__make} \
189         CFLAGS_EXTRA="%{rpmcflags}" \
190         LDFLAGS="%{rpmldflags}" \
191         CC="%{__cc}"
192
193 %install
194 rm -rf $RPM_BUILD_ROOT
195 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
196
197 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
198 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
199
200 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
201 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
202 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
203
204 # install links to busybox binary, when linkfl is defined
205 %if %{with linkfl}
206 make install \
207         PREFIX=$RPM_BUILD_ROOT
208 %else
209 install busybox $RPM_BUILD_ROOT%{_bindir}
210 %endif
211
212 %clean
213 rm -rf $RPM_BUILD_ROOT
214
215 %files
216 %defattr(644,root,root,755)
217 %doc AUTHORS TODO Changelog README .config
218
219 %if %{with linkfl}
220 %attr(755,root,root) /bin/*
221 %attr(755,root,root) /sbin/*
222 %attr(755,root,root) %{_bindir}/*
223 %attr(755,root,root) %{_sbindir}/*
224 %else
225 %attr(755,root,root) %{_bindir}/busybox
226 %endif
227
228 %{_libdir}/busybox
229 %{_mandir}/man1/*
230
231 %if %{with static}
232 %files static
233 %defattr(644,root,root,755)
234 %attr(755,root,root) %{_bindir}/busybox.static
235 %endif
236
237 %if %{with initrd}
238 %files initrd
239 %defattr(644,root,root,755)
240 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
241 %endif
This page took 0.04334 seconds and 4 git commands to generate.