]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- base package is dynamically linked and has pl summary/description
[packages/busybox.git] / busybox.spec
1 Summary:        Set of common unix utils for embeded systems
2 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
3 Name:           busybox
4 Version:        0.51
5 Release:        10
6 License:        GPL
7 Group:          Applications
8 Group(de):      Applikationen
9 Group(pl):      Aplikacje
10 Source0:        ftp://ftp.lineo.com/pub/busybox/%{name}-%{version}.tar.gz
11 Source1:        %{name}-config.h
12 Patch0:         %{name}-logconsole.patch
13 Patch1:         %{name}-tee.patch
14 Patch2:         %{name}-sh-name.patch
15 Patch3:         %{name}-printf-gettext.patch
16 Patch4:         %{name}-loadfont.patch
17 Patch5:         %{name}-cread.patch
18 URL:            http://busybox.lineo.com/
19 %{?BOOT:BuildRequires:  uClibc-devel-BOOT >= 20010521-3}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 BusyBox combines tiny versions of many common UNIX utilities into a
24 single small executable. It provides minimalist replacements for most
25 of the utilities you usually find in fileutils, shellutils, findutils,
26 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
27 POSIX environment for any small or embedded system. The utilities in
28 BusyBox generally have fewer options than their full-featured GNU
29 cousins; however, the options that are included provide the expected
30 functionality and behave very much like their GNU counterparts.
31
32 BusyBox has been written with size-optimization and limited resources
33 in mind. It is also extremely modular so you can easily include or
34 exclude commands (or features) at compile time. This makes it easy to
35 customize your embedded systems. To create a working system, just add
36 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
37 ae).
38
39 %description -l pl
40 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
41 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
42 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
43 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
44 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
45 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
46 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
47 (np. elvis-tiny albo ae).
48
49 %package BOOT
50 Summary:        busybox for PLD bootdisk
51 Group:          Applications
52 Group(de):      Applikationen
53 Group(pl):      Aplikacje
54
55 %description BOOT
56 busybox for PLD bootdisk.
57
58 %prep
59 %setup -q
60 %patch0
61 %patch1
62 %patch2 -p1
63 %patch3 -p1
64 %patch4 -p1
65 %patch5 -p1
66
67 %build
68 cp -f %{SOURCE1} Config.h
69 # BOOT
70 %if %{?BOOT:1}%{!?BOOT:0}
71 %{__make} \
72         CFLAGS_EXTRA="-m386 -I%{_libdir}/bootdisk%{_includedir}" \
73         LDFLAGS="-nostdlib -s" \
74         LIBRARIES="%{_libdir}/bootdisk%{_libdir}/crt0.o %{_libdir}/bootdisk%{_libdir}/libc.a -lgcc"
75 mv -f busybox busybox-BOOT
76 %endif
77
78 # TODO make main package dynamically linked
79 %{__make} \
80         CFLAGS_EXTRA="%{rpmcflags}" \
81         LDFLAGS="%{rpmldflags}"
82         
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
86
87 %if %{?BOOT:1}%{!?BOOT:0}
88 install -d $RPM_BUILD_ROOT%{_libdir}/bootdisk/bin
89
90 install busybox-BOOT $RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/
91
92 for i in `cat busybox.links`; do
93         ln -sfn busybox "$RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/`basename $i`"
94 done
95 install busybox.links $RPM_BUILD_ROOT%{_libdir}/bootdisk%{_libdir}/busybox
96 # change sh to lash (see sh_name patch)
97 mv -f $RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/{sh,lash}
98 %endif
99
100 install busybox $RPM_BUILD_ROOT%{_bindir}
101 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
102 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
103 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
104
105 gzip -9nf AUTHORS TODO Changelog README
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %files
111 %defattr(644,root,root,755)
112 %doc *.gz
113 %attr(755,root,root) %{_bindir}/*
114 %{_libdir}/busybox
115 %{_mandir}/man1/*
116
117 %if %{?BOOT:1}%{!?BOOT:0}
118 %files BOOT
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_libdir}/bootdisk/bin/*
121 %{_libdir}/bootdisk%{_libdir}/*
122 %endif
This page took 0.132982 seconds and 4 git commands to generate.