]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- added fixes patch
[packages/busybox.git] / busybox.spec
1 #
2 # TODO:
3 #       - sparc64 modules support in sparc(32) version
4 #       - make internal commands work even if busybox is not in /bin/busybox
5
6 #
7 # Conditional build:
8 # alternative busybox config file (replaces default one) you should
9 # define cfgfile macro, i.e.
10 #
11 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
12 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
13 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
14 # Options below are useful, when you want fileutils and grep providing.
15 # For example, ash package requires fileutils and grep.
16 %bcond_with     fileutl_prov    # adds fileutils providing
17 %bcond_with     grep_prov       # adds grep providing
18 # Option below is useful, when busybox is built with shell support.
19 %bcond_with     sh_prov         # adds /bin/sh providing
20 # WARNING! Shell, filetuils and grep providing may depend on config file!
21 # Fileutils, grep and shell provided with busybox have not such
22 # functionality as their GNU countenders.
23 #
24 %bcond_without  static          # don't build static version
25 %bcond_without  initrd          # don't build initrd version
26 %bcond_with     dietlibc        # build dietlibc-based initrd version
27 %bcond_with     glibc           # build glibc-based initrd version
28 #
29 %ifnarch %{ix86} ppc
30 %define with_glibc 1
31 %endif
32 %ifarch ppc
33 %undefine       with_dietlibc
34 %endif
35 Summary:        Set of common unix utils for embeded systems
36 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
37 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
38 Name:           busybox
39 Version:        1.2.0
40 Release:        1
41 License:        GPL
42 Group:          Applications
43 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
44 # Source0-md5:  0a3e5d47adc4debda22726295f40a6f2
45 Source1:        %{name}.config
46 Source2:        %{name}-initrd.config
47 %{?with_altconfig:Source3:      %{cfgfile}}
48 Patch0:         %{name}-fixes.patch
49 Patch1:         %{name}-logconsole.patch
50 Patch2:         %{name}-printf-gettext.patch
51 Patch3:         %{name}-loadfont.patch
52 Patch4:         %{name}-ash_exec.patch
53 Patch5:         %{name}-kernel_headers.patch
54 Patch6:         %{name}-insmod-morearchs.patch
55 Patch7:         %{name}-dhcp.patch
56 Patch8:         %{name}-fix_64_archs.patch
57 URL:            http://www.busybox.net/
58 BuildRequires:  gcc >= 3.2
59 %{?with_static:BuildRequires:   glibc-static}
60 %if %{with initrd}
61         %if %{with dietlibc}
62 BuildRequires:  dietlibc-static
63         %else
64                 %if %{with glibc}
65 BuildRequires:  glibc-static
66                 %else
67 %ifarch ppc
68 BuildRequires:  uClibc-static >= 2:0.9.29
69 %else
70 BuildRequires:  uClibc-static >= 2:0.9.21
71 %endif
72                 %endif
73         %endif
74 %endif
75 %{?with_fileutl_prov:Provides:  fileutils}
76 %{?with_grep_prov:Provides:     grep}
77 %{?with_sh_prov:Provides:       /bin/sh}
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80
81 %define         _bindir         /bin
82 %define         _initrd_bindir  /bin
83
84 %description
85 BusyBox combines tiny versions of many common UNIX utilities into a
86 single small executable. It provides minimalist replacements for most
87 of the utilities you usually find in fileutils, shellutils, findutils,
88 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
89 POSIX environment for any small or embedded system. The utilities in
90 BusyBox generally have fewer options than their full-featured GNU
91 cousins; however, the options that are included provide the expected
92 functionality and behave very much like their GNU counterparts.
93
94 BusyBox has been written with size-optimization and limited resources
95 in mind. It is also extremely modular so you can easily include or
96 exclude commands (or features) at compile time. This makes it easy to
97 customize your embedded systems. To create a working system, just add
98 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
99 ae).
100
101 %description -l pl
102 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
103 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
104 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
105 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
106 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
107 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
108 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
109 (np. elvis-tiny albo ae).
110
111 %description -l pt_BR
112 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
113 executável, fornecendo substitutos minimalistas para muitos dos
114 executáveis encontrados em pacotes como fileutils, shellutils,
115 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
116 em geral têm menos opções que os utilitários GNU, mas as opções
117 implementadas comportam-se de maneira similar aos equivalentes GNU.
118
119 %package static
120 Summary:        Static busybox
121 Summary(pl):    Statycznie skonsolidowany busybox
122 Group:          Applications
123
124 %description static
125 Static busybox.
126
127 %description static -l pl
128 Statycznie skonsolidowany busybox.
129
130 %package initrd
131 Summary:        Static busybox for initrd
132 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
133 Group:          Applications
134 Conflicts:      geninitrd < 3075
135
136 %description initrd
137 Static busybox for initrd.
138
139 %description initrd -l pl
140 Statycznie skonsolidowany busybox dla initrd.
141
142 %prep
143 %setup -q
144 %patch0 -p0
145 %patch1 -p1
146 %patch2 -p1
147 %patch3 -p1
148 %patch4 -p1
149 %patch5 -p1
150 %patch6 -p1
151 %patch7 -p1
152 %patch8 -p1
153
154 %build
155 install %{SOURCE1} .config
156
157 %if %{with initrd}
158 install %{SOURCE2} .config
159 %{__make} oldconfig
160 %{__make} \
161         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
162         LDFLAGS="%{rpmldflags} -static" \
163 %if %{with dietlibc}
164         LIBRARIES="-lrpc" \
165         CC="diet gcc"
166 %else
167 %if %{with glibc}
168         CC="%{__cc}"
169 %else
170         CC="%{_target_cpu}-uclibc-gcc"
171 %endif
172 %endif
173
174 mv -f busybox busybox.initrd
175 %{__make} clean
176 install %{SOURCE1} .config
177 %endif
178
179 %if %{with altconfig}
180 install %{SOURCE3} .config
181 %endif
182
183 %if %{with static}
184 %{__make} oldconfig
185 %{__make} \
186         CFLAGS_EXTRA="%{rpmcflags}" \
187         LDFLAGS="%{rpmldflags} -static" \
188         CC="%{__cc}"
189 mv -f busybox busybox.static
190 %{__make} clean
191 %endif
192
193 %{__make} oldconfig
194 %{__make} \
195         CFLAGS_EXTRA="%{rpmcflags}" \
196         LDFLAGS="%{rpmldflags}" \
197         CC="%{__cc}"
198
199 %install
200 rm -rf $RPM_BUILD_ROOT
201 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
202
203 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
204 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
205
206 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
207 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
208 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
209
210 # install links to busybox binary, when linkfl is defined
211 %if %{with linkfl}
212 %{__make} install \
213         PREFIX=$RPM_BUILD_ROOT
214 %else
215 install busybox $RPM_BUILD_ROOT%{_bindir}
216 %endif
217
218 %clean
219 rm -rf $RPM_BUILD_ROOT
220
221 %files
222 %defattr(644,root,root,755)
223 %doc AUTHORS README .config
224
225 %if %{with linkfl}
226 %attr(755,root,root) /bin/*
227 %attr(755,root,root) /sbin/*
228 %attr(755,root,root) %{_bindir}/*
229 %attr(755,root,root) %{_sbindir}/*
230 %else
231 %attr(755,root,root) %{_bindir}/busybox
232 %endif
233
234 %{_libdir}/busybox
235 %{_mandir}/man1/*
236
237 %if %{with static}
238 %files static
239 %defattr(644,root,root,755)
240 %attr(755,root,root) %{_bindir}/busybox.static
241 %endif
242
243 %if %{with initrd}
244 %files initrd
245 %defattr(644,root,root,755)
246 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
247 %endif
This page took 0.05972 seconds and 4 git commands to generate.