]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- added LFS and ftpput patches
[packages/busybox.git] / busybox.spec
1 #
2 # TODO:
3 #       - sparc64 modules support in sparc(32) version
4 #       - make internal commands work even if busybox is not in /bin/busybox
5
6 #
7 # Conditional build:
8 # alternative busybox config file (replaces default one) you should
9 # define cfgfile macro, i.e.
10 #
11 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
12 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
13 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
14 # Options below are useful, when you want fileutils and grep providing.
15 # For example, ash package requires fileutils and grep.
16 %bcond_with     fileutl_prov    # adds fileutils providing
17 %bcond_with     grep_prov       # adds grep providing
18 # Option below is useful, when busybox is built with shell support.
19 %bcond_with     sh_prov         # adds /bin/sh providing
20 # WARNING! Shell, filetuils and grep providing may depend on config file!
21 # Fileutils, grep and shell provided with busybox have not such
22 # functionality as their GNU countenders.
23 #
24 %bcond_without  static          # don't build static version
25 %bcond_without  initrd          # don't build initrd version
26 %bcond_with     dietlibc        # build dietlibc-based initrd version
27 %bcond_with     glibc           # build glibc-based initrd version
28 #
29 %ifnarch %{ix86}
30 %define with_glibc 1
31 %endif
32 Summary:        Set of common unix utils for embeded systems
33 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
34 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
35 Name:           busybox
36 Version:        1.00
37 Release:        2
38 License:        GPL
39 Group:          Applications
40 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
41 # Source0-md5:  5c7ea9b5d3b3677dfcdcec38b281a756
42 Source1:        %{name}.config
43 Source2:        %{name}-initrd.config
44 %{?with_altconfig:Source3:      %{cfgfile}}
45 Patch0:         %{name}-logconsole.patch
46 Patch1:         %{name}-printf-gettext.patch
47 Patch2:         %{name}-loadfont.patch
48 Patch3:         %{name}-pivot_root.patch
49 Patch4:         %{name}-raid_start.patch
50 Patch5:         %{name}-force-dietlibc.patch
51 Patch6:         %{name}-ash_exec.patch
52 Patch7:         %{name}-kernel_headers.patch
53 Patch8:         %{name}-insmod-morearchs.patch
54 Patch9:         %{name}-dhcp.patch
55 Patch10:        %{name}-switchroot.patch
56 Patch11:        %{name}-fix_64_archs.patch
57 Patch12:        %{name}-LFS.patch
58 Patch13:        %{name}-ftpput.patch
59 URL:            http://www.busybox.net/
60 BuildRequires:  gcc >= 3.2
61 %{?with_static:BuildRequires:   glibc-static}
62 %if %{with initrd}
63         %if %{with dietlibc}
64 BuildRequires:  dietlibc-static
65         %else
66                 %if %{with glibc}
67 BuildRequires:  glibc-static
68                 %else
69 BuildRequires:  uClibc-static >= 0.9.21
70                 %endif
71         %endif
72 %endif
73 %{?with_fileutl_prov:Provides:  fileutils}
74 %{?with_grep_prov:Provides:     grep}
75 %{?with_sh_prov:Provides:       /bin/sh}
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78
79 %define         _bindir         /bin
80 %define         _initrd_bindir  /bin
81
82 %description
83 BusyBox combines tiny versions of many common UNIX utilities into a
84 single small executable. It provides minimalist replacements for most
85 of the utilities you usually find in fileutils, shellutils, findutils,
86 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
87 POSIX environment for any small or embedded system. The utilities in
88 BusyBox generally have fewer options than their full-featured GNU
89 cousins; however, the options that are included provide the expected
90 functionality and behave very much like their GNU counterparts.
91
92 BusyBox has been written with size-optimization and limited resources
93 in mind. It is also extremely modular so you can easily include or
94 exclude commands (or features) at compile time. This makes it easy to
95 customize your embedded systems. To create a working system, just add
96 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
97 ae).
98
99 %description -l pl
100 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
101 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
102 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
103 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
104 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
105 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
106 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
107 (np. elvis-tiny albo ae).
108
109 %description -l pt_BR
110 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
111 executável, fornecendo substitutos minimalistas para muitos dos
112 executáveis encontrados em pacotes como fileutils, shellutils,
113 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
114 em geral têm menos opções que os utilitários GNU, mas as opções
115 implementadas comportam-se de maneira similar aos equivalentes GNU.
116
117 %package static
118 Summary:        Static busybox
119 Summary(pl):    Statycznie skonsolidowany busybox
120 Group:          Applications
121
122 %description static
123 Static busybox.
124
125 %description static -l pl
126 Statycznie skonsolidowany busybox.
127
128 %package initrd
129 Summary:        Static busybox for initrd
130 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
131 Group:          Applications
132 Conflicts:      geninitrd < 3075
133
134 %description initrd
135 Static busybox for initrd.
136
137 %description initrd -l pl
138 Statycznie skonsolidowany busybox dla initrd.
139
140 %prep
141 %setup -q
142 %patch0 -p1
143 %patch1 -p1
144 %patch2 -p1
145 %patch3 -p1
146 %patch4 -p1
147 %patch5 -p1
148 %patch6 -p1
149 %patch7 -p1
150 %patch8 -p1
151 %patch9 -p1
152 %patch10 -p1
153 %patch11 -p1
154 %patch12 -p1
155 %patch13 -p1
156
157 %build
158 install %{SOURCE1} .config
159
160 %if %{with initrd}
161 install %{SOURCE2} .config
162 %{__make} oldconfig
163 %{__make} \
164         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
165         LDFLAGS="%{rpmldflags} -static" \
166 %if %{with dietlibc}
167         LIBRARIES="-lrpc" \
168         CC="diet gcc"
169 %else
170 %if %{with glibc}
171         CC="%{__cc}"
172 %else
173         CC="%{_target_cpu}-uclibc-gcc"
174 %endif
175 %endif
176
177 mv -f busybox busybox.initrd
178 %{__make} clean
179 install %{SOURCE1} .config
180 %endif
181
182 %if %{with altconfig}
183 install %{SOURCE3} .config
184 %endif
185
186 %if %{with static}
187 %{__make} oldconfig
188 %{__make} \
189         CFLAGS_EXTRA="%{rpmcflags}" \
190         LDFLAGS="%{rpmldflags} -static" \
191         CC="%{__cc}"
192 mv -f busybox busybox.static
193 %{__make} clean
194 %endif
195
196 %{__make} oldconfig
197 %{__make} \
198         CFLAGS_EXTRA="%{rpmcflags}" \
199         LDFLAGS="%{rpmldflags}" \
200         CC="%{__cc}"
201
202 %install
203 rm -rf $RPM_BUILD_ROOT
204 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
205
206 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
207 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
208
209 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
210 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
211 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
212
213 # install links to busybox binary, when linkfl is defined
214 %if %{with linkfl}
215 %{__make} install \
216         PREFIX=$RPM_BUILD_ROOT
217 %else
218 install busybox $RPM_BUILD_ROOT%{_bindir}
219 %endif
220
221 %clean
222 rm -rf $RPM_BUILD_ROOT
223
224 %files
225 %defattr(644,root,root,755)
226 %doc AUTHORS Changelog README .config
227
228 %if %{with linkfl}
229 %attr(755,root,root) /bin/*
230 %attr(755,root,root) /sbin/*
231 %attr(755,root,root) %{_bindir}/*
232 %attr(755,root,root) %{_sbindir}/*
233 %else
234 %attr(755,root,root) %{_bindir}/busybox
235 %endif
236
237 %{_libdir}/busybox
238 %{_mandir}/man1/*
239
240 %if %{with static}
241 %files static
242 %defattr(644,root,root,755)
243 %attr(755,root,root) %{_bindir}/busybox.static
244 %endif
245
246 %if %{with initrd}
247 %files initrd
248 %defattr(644,root,root,755)
249 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
250 %endif
This page took 0.074048 seconds and 4 git commands to generate.