]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- uClibc static version works on ppc, but not yet released uClibc is
[packages/busybox.git] / busybox.spec
1 #
2 # TODO:
3 #       - sparc64 modules support in sparc(32) version
4 #       - make internal commands work even if busybox is not in /bin/busybox
5
6 #
7 # Conditional build:
8 # alternative busybox config file (replaces default one) you should
9 # define cfgfile macro, i.e.
10 #
11 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
12 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
13 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
14 # Options below are useful, when you want fileutils and grep providing.
15 # For example, ash package requires fileutils and grep.
16 %bcond_with     fileutl_prov    # adds fileutils providing
17 %bcond_with     grep_prov       # adds grep providing
18 # Option below is useful, when busybox is built with shell support.
19 %bcond_with     sh_prov         # adds /bin/sh providing
20 # WARNING! Shell, filetuils and grep providing may depend on config file!
21 # Fileutils, grep and shell provided with busybox have not such
22 # functionality as their GNU countenders.
23 #
24 %bcond_without  static          # don't build static version
25 %bcond_without  initrd          # don't build initrd version
26 %bcond_with     dietlibc        # build dietlibc-based initrd version
27 %bcond_with     glibc           # build glibc-based initrd version
28 #
29 %ifnarch %{ix86} ppc
30 %define with_glibc 1
31 %endif
32 %ifarch ppc
33 %undefine       with_dietlibc
34 %endif
35 Summary:        Set of common unix utils for embeded systems
36 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
37 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
38 Name:           busybox
39 Version:        1.01
40 Release:        1
41 License:        GPL
42 Group:          Applications
43 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
44 # Source0-md5:  f250842dae2854a38470ed16a46bba66
45 Source1:        %{name}.config
46 Source2:        %{name}-initrd.config
47 %{?with_altconfig:Source3:      %{cfgfile}}
48 Patch0:         %{name}-logconsole.patch
49 Patch1:         %{name}-printf-gettext.patch
50 Patch2:         %{name}-loadfont.patch
51 Patch3:         %{name}-pivot_root.patch
52 Patch4:         %{name}-raid_start.patch
53 Patch5:         %{name}-force-dietlibc.patch
54 Patch6:         %{name}-ash_exec.patch
55 Patch7:         %{name}-kernel_headers.patch
56 Patch8:         %{name}-insmod-morearchs.patch
57 Patch9:         %{name}-dhcp.patch
58 Patch10:        %{name}-switchroot.patch
59 Patch11:        %{name}-fix_64_archs.patch
60 Patch12:        %{name}-LFS.patch
61 Patch13:        %{name}-ftpput.patch
62 #http://www.zelow.no/floppyfw/download/Development/Patches/busybox-snapshot/busybox-lzmacat.diff
63 Patch14:        %{name}-lzmacat.diff
64 URL:            http://www.busybox.net/
65 BuildRequires:  gcc >= 3.2
66 %{?with_static:BuildRequires:   glibc-static}
67 %if %{with initrd}
68         %if %{with dietlibc}
69 BuildRequires:  dietlibc-static
70         %else
71                 %if %{with glibc}
72 BuildRequires:  glibc-static
73                 %else
74 %ifarch ppc
75 BuildRequires:  uClibc-static > 0.9.28
76 %else
77 BuildRequires:  uClibc-static >= 0.9.21
78 %endif
79                 %endif
80         %endif
81 %endif
82 %{?with_fileutl_prov:Provides:  fileutils}
83 %{?with_grep_prov:Provides:     grep}
84 %{?with_sh_prov:Provides:       /bin/sh}
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87
88 %define         _bindir         /bin
89 %define         _initrd_bindir  /bin
90
91 %description
92 BusyBox combines tiny versions of many common UNIX utilities into a
93 single small executable. It provides minimalist replacements for most
94 of the utilities you usually find in fileutils, shellutils, findutils,
95 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
96 POSIX environment for any small or embedded system. The utilities in
97 BusyBox generally have fewer options than their full-featured GNU
98 cousins; however, the options that are included provide the expected
99 functionality and behave very much like their GNU counterparts.
100
101 BusyBox has been written with size-optimization and limited resources
102 in mind. It is also extremely modular so you can easily include or
103 exclude commands (or features) at compile time. This makes it easy to
104 customize your embedded systems. To create a working system, just add
105 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
106 ae).
107
108 %description -l pl
109 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
110 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
111 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
112 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
113 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
114 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
115 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
116 (np. elvis-tiny albo ae).
117
118 %description -l pt_BR
119 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
120 executável, fornecendo substitutos minimalistas para muitos dos
121 executáveis encontrados em pacotes como fileutils, shellutils,
122 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
123 em geral têm menos opções que os utilitários GNU, mas as opções
124 implementadas comportam-se de maneira similar aos equivalentes GNU.
125
126 %package static
127 Summary:        Static busybox
128 Summary(pl):    Statycznie skonsolidowany busybox
129 Group:          Applications
130
131 %description static
132 Static busybox.
133
134 %description static -l pl
135 Statycznie skonsolidowany busybox.
136
137 %package initrd
138 Summary:        Static busybox for initrd
139 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
140 Group:          Applications
141 Conflicts:      geninitrd < 3075
142
143 %description initrd
144 Static busybox for initrd.
145
146 %description initrd -l pl
147 Statycznie skonsolidowany busybox dla initrd.
148
149 %prep
150 %setup -q
151 %patch0 -p1
152 %patch1 -p1
153 %patch2 -p1
154 %patch3 -p1
155 %patch4 -p1
156 %patch5 -p1
157 %patch6 -p1
158 %patch7 -p1
159 %patch8 -p1
160 %patch9 -p1
161 %patch10 -p1
162 %patch11 -p1
163 %patch12 -p1
164 %patch13 -p1
165 %patch14 -p1
166
167 %build
168 install %{SOURCE1} .config
169
170 %if %{with initrd}
171 install %{SOURCE2} .config
172 %{__make} oldconfig
173 %{__make} \
174         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
175         LDFLAGS="%{rpmldflags} -static" \
176 %if %{with dietlibc}
177         LIBRARIES="-lrpc" \
178         CC="diet gcc"
179 %else
180 %if %{with glibc}
181         CC="%{__cc}"
182 %else
183         CC="%{_target_cpu}-uclibc-gcc"
184 %endif
185 %endif
186
187 mv -f busybox busybox.initrd
188 %{__make} clean
189 install %{SOURCE1} .config
190 %endif
191
192 %if %{with altconfig}
193 install %{SOURCE3} .config
194 %endif
195
196 %if %{with static}
197 %{__make} oldconfig
198 %{__make} \
199         CFLAGS_EXTRA="%{rpmcflags}" \
200         LDFLAGS="%{rpmldflags} -static" \
201         CC="%{__cc}"
202 mv -f busybox busybox.static
203 %{__make} clean
204 %endif
205
206 %{__make} oldconfig
207 %{__make} \
208         CFLAGS_EXTRA="%{rpmcflags}" \
209         LDFLAGS="%{rpmldflags}" \
210         CC="%{__cc}"
211
212 %install
213 rm -rf $RPM_BUILD_ROOT
214 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
215
216 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
217 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
218
219 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
220 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
221 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
222
223 # install links to busybox binary, when linkfl is defined
224 %if %{with linkfl}
225 %{__make} install \
226         PREFIX=$RPM_BUILD_ROOT
227 %else
228 install busybox $RPM_BUILD_ROOT%{_bindir}
229 %endif
230
231 %clean
232 rm -rf $RPM_BUILD_ROOT
233
234 %files
235 %defattr(644,root,root,755)
236 %doc AUTHORS README .config
237
238 %if %{with linkfl}
239 %attr(755,root,root) /bin/*
240 %attr(755,root,root) /sbin/*
241 %attr(755,root,root) %{_bindir}/*
242 %attr(755,root,root) %{_sbindir}/*
243 %else
244 %attr(755,root,root) %{_bindir}/busybox
245 %endif
246
247 %{_libdir}/busybox
248 %{_mandir}/man1/*
249
250 %if %{with static}
251 %files static
252 %defattr(644,root,root,755)
253 %attr(755,root,root) %{_bindir}/busybox.static
254 %endif
255
256 %if %{with initrd}
257 %files initrd
258 %defattr(644,root,root,755)
259 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
260 %endif
This page took 0.046652 seconds and 4 git commands to generate.