]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- remove -config.patches (not used)
[packages/busybox.git] / busybox.spec
1
2 # alternative busybox config file (replaces default one) you should
3 # define cfgfile macro, i.e.
4 #
5 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
6 %bcond_with altconfig
7
8 %bcond_with linkfl # creates links to busybox binary and puts them into file list
9
10 # Options below are useful, when you want fileutils and grep providing.
11 # For example, ash package requires fileutils and grep.
12 %bcond_with fileutl_prov # adds fileutils providing
13 %bcond_with grep_prov    # adds grep providing
14
15 # Option below is useful, when busybox is built with shell support.
16 %bcond_with sh_prov      # adds /bin/sh providing
17
18 # WARNING! Shell, filetuils and grep providing may depend on config file!
19 # Fileutils, grep and shell provided with busybox have not such
20 # functionality as their GNU countenders.
21
22 %bcond_without static  # don't build static version
23 %bcond_without initrd  # don't build initrd version
24
25 %bcond_with dietlibc
26
27 %define pre     pre2
28 Summary:        Set of common unix utils for embeded systems
29 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
30 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
31 Name:           busybox
32 Version:        1.00
33 Release:        0.%{pre}.6
34 License:        GPL
35 Group:          Applications
36 Source0:        http://www.busybox.net/downloads/%{name}-%{version}-pre2.tar.bz2
37 # Source0-md5:  06e433389a8b34ce1031a144ba5677d1
38 Source1:        %{name}.config
39 Source2:        %{name}-initrd.config
40 %{?with_altconfig:Source3:      %{cfgfile}}
41 Patch0:         %{name}-logconsole.patch
42 Patch1:         %{name}-tee.patch
43 Patch3:         %{name}-printf-gettext.patch
44 Patch4:         %{name}-loadfont.patch
45 Patch5:         %{name}-pivot_root.patch
46 Patch6:         %{name}-malloc.patch
47 Patch7:         %{name}-raid_start.patch
48 Patch8:         %{name}-insmod_ng.patch
49 Patch9:         %{name}-force-dietlibc.patch
50 Patch10:        %{name}-insmod-gpl.patch
51 URL:            http://www.busybox.net/
52 %{?with_fileutl_prov:Provides:  fileutils}
53 %{?with_grep_prov:Provides:     grep}
54 %{?with_sh_prov:Provides:       /bin/sh}
55 %{?with_static:BuildRequires:   glibc-static}
56 %{?with_initrd:BuildRequires:   %{?with_dietlibc:dietlibc}%{?!with_dietlibc:uClibc}-static}
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %define         _initrd_bindir  /bin
60
61 %description
62 BusyBox combines tiny versions of many common UNIX utilities into a
63 single small executable. It provides minimalist replacements for most
64 of the utilities you usually find in fileutils, shellutils, findutils,
65 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
66 POSIX environment for any small or embedded system. The utilities in
67 BusyBox generally have fewer options than their full-featured GNU
68 cousins; however, the options that are included provide the expected
69 functionality and behave very much like their GNU counterparts.
70
71 BusyBox has been written with size-optimization and limited resources
72 in mind. It is also extremely modular so you can easily include or
73 exclude commands (or features) at compile time. This makes it easy to
74 customize your embedded systems. To create a working system, just add
75 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
76 ae).
77
78 %description -l pl
79 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
80 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
81 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
82 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
83 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
84 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
85 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
86 (np. elvis-tiny albo ae).
87
88 %description -l pt_BR
89 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
90 executável, fornecendo substitutos minimalistas para muitos dos
91 executáveis encontrados em pacotes como fileutils, shellutils,
92 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
93 em geral têm menos opções que os utilitários GNU, mas as opções
94 implementadas comportam-se de maneira similar aos equivalentes GNU.
95
96 %package static
97 Summary:        Static busybox
98 Summary(pl):    Statycznie linkowany busybox
99 Group:          Applications
100
101 %description static
102 Static busybox.
103
104 %description static -l pl
105 Statycznie linkowany busybox.
106
107 %package initrd
108 Summary:        Static busybox for initrd
109 Summary(pl):    Statycznie linkowany busybox dla initrd
110 Group:          Applications
111
112 %description initrd
113 Static busybox for initrd.
114
115 %description initrd -l pl
116 Statycznie linkowany busybox dla initrd.
117
118 %prep
119 %setup -q -n %{name}-%{version}-%{pre}
120 %patch0 -p1
121 %patch1 -p1
122 #X %patch3 -p1 // UPDATE ME
123 %patch4 -p1
124 %patch5 -p1
125 #%patch6 -p1 // not needed
126 %patch7 -p1
127 %patch8 -p1
128 %patch9 -p1
129 %patch10 -p1
130
131 %build
132 install %{SOURCE1} .config
133
134 %if %{with altconfig}
135 install %{SOURCE3} .config
136 %endif
137
138 %if %{with initrd}
139 install %{SOURCE2} .config
140 %{__make} oldconfig
141 %{__make} \
142         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
143         LDFLAGS="%{rpmldflags} -static" \
144 %if %{with dietlibc}
145         LIBRARIES="-lrpc" \
146         CC="diet gcc"
147 %else
148         CC="%{_target_cpu}-uclibc-gcc"
149 %endif
150 mv -f busybox busybox.initrd
151 %{__make} clean
152 install %{SOURCE1} .config
153 %endif
154
155 %if %{with static}
156 %{__make} oldconfig
157 %{__make}  \
158         CFLAGS_EXTRA="%{rpmcflags}" \
159         LDFLAGS="%{rpmldflags} -static" \
160         CC="%{__cc}"
161 mv -f busybox busybox.static
162 %{__make} clean
163 %endif
164
165 %{__make} oldconfig
166 %{__make} \
167         CFLAGS_EXTRA="%{rpmcflags}" \
168         LDFLAGS="%{rpmldflags}" \
169         CC="%{__cc}"
170
171 %install
172 rm -rf $RPM_BUILD_ROOT
173 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
174
175 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
176 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
177
178 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
179 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
180 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
181
182 # install links to busybox binary, when linkfl is defined
183 %if %{with linkfl}
184 make install PREFIX=$RPM_BUILD_ROOT
185 %else
186 install busybox $RPM_BUILD_ROOT%{_bindir}
187 %endif
188
189 %clean
190 rm -rf $RPM_BUILD_ROOT
191
192 %files
193 %defattr(644,root,root,755)
194 %doc AUTHORS TODO Changelog README .config
195
196 %if %{with linkfl}
197 %attr(755,root,root) /bin/*
198 %attr(755,root,root) /sbin/*
199 %attr(755,root,root) %{_bindir}/*
200 %attr(755,root,root) %{_sbindir}/*
201 %else
202 %attr(755,root,root) %{_bindir}/busybox
203 %endif
204
205 %{_libdir}/busybox
206 %{_mandir}/man1/*
207
208 %if %{with static}
209 %files static
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{_bindir}/busybox.static
212 %endif
213
214 %if %{with initrd}
215 %files initrd
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
218 %endif
This page took 0.04642 seconds and 4 git commands to generate.