]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- added printf-gettext batch by /me
[packages/busybox.git] / busybox.spec
1 Summary:        Set of common unix utils for embeded systems
2 Name:           busybox
3 Version:        0.51
4 Release:        5
5 License:        GPL
6 Group:          Applications
7 Group(de):      Applikationen
8 Group(pl):      Aplikacje
9 Source0:        ftp://ftp.lineo.com/pub/busybox/%{name}-%{version}.tar.gz
10 Source1:        %{name}-config.h
11 Patch0:         %{name}-logconsole.patch
12 Patch1:         %{name}-tee.patch
13 Patch2:         %{name}-sh-name.patch
14 Patch3:         %{name}-printf-gettext.patch
15 URL:            http://busybox.lineo.com/
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17 BuildRequires:  uClibc-devel-BOOT >= 20010521-3
18
19 %description
20 BusyBox combines tiny versions of many common UNIX utilities into a
21 single small executable. It provides minimalist replacements for most
22 of the utilities you usually find in fileutils, shellutils, findutils,
23 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
24 POSIX environment for any small or embedded system. The utilities in
25 BusyBox generally have fewer options than their full-featured GNU
26 cousins; however, the options that are included provide the expected
27 functionality and behave very much like their GNU counterparts.
28
29 BusyBox has been written with size-optimization and limited resources
30 in mind. It is also extremely modular so you can easily include or
31 exclude commands (or features) at compile time. This makes it easy to
32 customize your embedded systems. To create a working system, just add
33 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
34 ae).
35
36 %package BOOT
37 Summary:        busybox for PLD bootdisk
38 Group:          Applications
39 Group(de):      Applikationen
40 Group(pl):      Aplikacje
41
42 %description BOOT
43 busybox for PLD bootdisk.
44
45 %prep
46 %setup -q
47 %patch0
48 %patch1
49 %patch2 -p1
50 %patch3 -p1
51
52 %build
53 # BOOT
54 cp %{SOURCE1} Config.h
55 %{__make} \
56         CFLAGS_EXTRA="-m386 -I%{_libdir}/bootdisk%{_includedir}" \
57         LDFLAGS="-nostdlib -s" \
58         LIBRARIES="%{_libdir}/bootdisk%{_libdir}/crt0.o %{_libdir}/bootdisk%{_libdir}/libc.a -lgcc"
59
60 # TODO make main package dynamically linked
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 %{__install} -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
65 %{__install} -d $RPM_BUILD_ROOT%{_libdir}/bootdisk/{bin,%{_libdir}/busybox}
66
67 %{__install} busybox $RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/
68
69 for i in `cat busybox.links`; do
70         ln -sfn busybox "$RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/`basename $i`"
71 done
72 %{__install} busybox.links $RPM_BUILD_ROOT%{_libdir}/bootdisk%{_libdir}/busybox
73 # change sh to lash (see sh_name patch)
74 mv -f $RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/{sh,lash}
75
76 %{__install} busybox $RPM_BUILD_ROOT%{_bindir}
77 %{__install} busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
78 %{__install} docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
79 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
80
81 gzip -9nf AUTHORS TODO Changelog README
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc *.gz
89 %attr(755,root,root) %{_bindir}/*
90 %{_libdir}/busybox
91 %{_mandir}/man1/*
92
93 %files BOOT
94 %defattr(644,root,root,755)
95 %attr(755,root,root) %{_libdir}/bootdisk/bin/*
96 %{_libdir}/bootdisk%{_libdir}/*
This page took 0.032332 seconds and 4 git commands to generate.