]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- updated to 1.2.0
[packages/busybox.git] / busybox.spec
1 #
2 # TODO:
3 #       - sparc64 modules support in sparc(32) version
4 #       - make internal commands work even if busybox is not in /bin/busybox
5
6 #
7 # Conditional build:
8 # alternative busybox config file (replaces default one) you should
9 # define cfgfile macro, i.e.
10 #
11 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
12 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
13 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
14 # Options below are useful, when you want fileutils and grep providing.
15 # For example, ash package requires fileutils and grep.
16 %bcond_with     fileutl_prov    # adds fileutils providing
17 %bcond_with     grep_prov       # adds grep providing
18 # Option below is useful, when busybox is built with shell support.
19 %bcond_with     sh_prov         # adds /bin/sh providing
20 # WARNING! Shell, filetuils and grep providing may depend on config file!
21 # Fileutils, grep and shell provided with busybox have not such
22 # functionality as their GNU countenders.
23 #
24 %bcond_without  static          # don't build static version
25 %bcond_without  initrd          # don't build initrd version
26 %bcond_with     dietlibc        # build dietlibc-based initrd version
27 %bcond_with     glibc           # build glibc-based initrd version
28 #
29 %ifnarch %{ix86} ppc
30 %define with_glibc 1
31 %endif
32 %ifarch ppc
33 %undefine       with_dietlibc
34 %endif
35 Summary:        Set of common unix utils for embeded systems
36 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
37 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
38 Name:           busybox
39 Version:        1.2.0
40 Release:        1
41 License:        GPL
42 Group:          Applications
43 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
44 # Source0-md5:  0a3e5d47adc4debda22726295f40a6f2
45 Source1:        %{name}.config
46 Source2:        %{name}-initrd.config
47 %{?with_altconfig:Source3:      %{cfgfile}}
48 Patch0:         %{name}-logconsole.patch
49 Patch1:         %{name}-printf-gettext.patch
50 Patch2:         %{name}-loadfont.patch
51 Patch4:         %{name}-ash_exec.patch
52 Patch5:         %{name}-kernel_headers.patch
53 Patch6:         %{name}-insmod-morearchs.patch
54 Patch7:         %{name}-dhcp.patch
55 Patch8:         %{name}-fix_64_archs.patch
56 URL:            http://www.busybox.net/
57 BuildRequires:  gcc >= 3.2
58 %{?with_static:BuildRequires:   glibc-static}
59 %if %{with initrd}
60         %if %{with dietlibc}
61 BuildRequires:  dietlibc-static
62         %else
63                 %if %{with glibc}
64 BuildRequires:  glibc-static
65                 %else
66 %ifarch ppc
67 BuildRequires:  uClibc-static >= 2:0.9.29
68 %else
69 BuildRequires:  uClibc-static >= 2:0.9.21
70 %endif
71                 %endif
72         %endif
73 %endif
74 %{?with_fileutl_prov:Provides:  fileutils}
75 %{?with_grep_prov:Provides:     grep}
76 %{?with_sh_prov:Provides:       /bin/sh}
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79
80 %define         _bindir         /bin
81 %define         _initrd_bindir  /bin
82
83 %description
84 BusyBox combines tiny versions of many common UNIX utilities into a
85 single small executable. It provides minimalist replacements for most
86 of the utilities you usually find in fileutils, shellutils, findutils,
87 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
88 POSIX environment for any small or embedded system. The utilities in
89 BusyBox generally have fewer options than their full-featured GNU
90 cousins; however, the options that are included provide the expected
91 functionality and behave very much like their GNU counterparts.
92
93 BusyBox has been written with size-optimization and limited resources
94 in mind. It is also extremely modular so you can easily include or
95 exclude commands (or features) at compile time. This makes it easy to
96 customize your embedded systems. To create a working system, just add
97 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
98 ae).
99
100 %description -l pl
101 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
102 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
103 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
104 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
105 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
106 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
107 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
108 (np. elvis-tiny albo ae).
109
110 %description -l pt_BR
111 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
112 executável, fornecendo substitutos minimalistas para muitos dos
113 executáveis encontrados em pacotes como fileutils, shellutils,
114 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
115 em geral têm menos opções que os utilitários GNU, mas as opções
116 implementadas comportam-se de maneira similar aos equivalentes GNU.
117
118 %package static
119 Summary:        Static busybox
120 Summary(pl):    Statycznie skonsolidowany busybox
121 Group:          Applications
122
123 %description static
124 Static busybox.
125
126 %description static -l pl
127 Statycznie skonsolidowany busybox.
128
129 %package initrd
130 Summary:        Static busybox for initrd
131 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
132 Group:          Applications
133 Conflicts:      geninitrd < 3075
134
135 %description initrd
136 Static busybox for initrd.
137
138 %description initrd -l pl
139 Statycznie skonsolidowany busybox dla initrd.
140
141 %prep
142 %setup -q
143 %patch0 -p1
144 %patch1 -p1
145 %patch2 -p1
146 %patch4 -p1
147 %patch5 -p1
148 %patch6 -p1
149 %patch7 -p1
150 %patch8 -p1
151
152 %build
153 install %{SOURCE1} .config
154
155 %if %{with initrd}
156 install %{SOURCE2} .config
157 %{__make} oldconfig
158 %{__make} \
159         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
160         LDFLAGS="%{rpmldflags} -static" \
161 %if %{with dietlibc}
162         LIBRARIES="-lrpc" \
163         CC="diet gcc"
164 %else
165 %if %{with glibc}
166         CC="%{__cc}"
167 %else
168         CC="%{_target_cpu}-uclibc-gcc"
169 %endif
170 %endif
171
172 mv -f busybox busybox.initrd
173 %{__make} clean
174 install %{SOURCE1} .config
175 %endif
176
177 %if %{with altconfig}
178 install %{SOURCE3} .config
179 %endif
180
181 %if %{with static}
182 %{__make} oldconfig
183 %{__make} \
184         CFLAGS_EXTRA="%{rpmcflags}" \
185         LDFLAGS="%{rpmldflags} -static" \
186         CC="%{__cc}"
187 mv -f busybox busybox.static
188 %{__make} clean
189 %endif
190
191 %{__make} oldconfig
192 %{__make} \
193         CFLAGS_EXTRA="%{rpmcflags}" \
194         LDFLAGS="%{rpmldflags}" \
195         CC="%{__cc}"
196
197 %install
198 rm -rf $RPM_BUILD_ROOT
199 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
200
201 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
202 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
203
204 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
205 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
206 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
207
208 # install links to busybox binary, when linkfl is defined
209 %if %{with linkfl}
210 %{__make} install \
211         PREFIX=$RPM_BUILD_ROOT
212 %else
213 install busybox $RPM_BUILD_ROOT%{_bindir}
214 %endif
215
216 %clean
217 rm -rf $RPM_BUILD_ROOT
218
219 %files
220 %defattr(644,root,root,755)
221 %doc AUTHORS README .config
222
223 %if %{with linkfl}
224 %attr(755,root,root) /bin/*
225 %attr(755,root,root) /sbin/*
226 %attr(755,root,root) %{_bindir}/*
227 %attr(755,root,root) %{_sbindir}/*
228 %else
229 %attr(755,root,root) %{_bindir}/busybox
230 %endif
231
232 %{_libdir}/busybox
233 %{_mandir}/man1/*
234
235 %if %{with static}
236 %files static
237 %defattr(644,root,root,755)
238 %attr(755,root,root) %{_bindir}/busybox.static
239 %endif
240
241 %if %{with initrd}
242 %files initrd
243 %defattr(644,root,root,755)
244 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
245 %endif
This page took 0.040001 seconds and 4 git commands to generate.