]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- add busybox-readahead.patch (s/readahead/read_ahead/)
[packages/busybox.git] / busybox.spec
1 #
2 # Conditional build:
3 # alternative busybox config file (replaces default one) you should
4 # define cfgfile macro, i.e.
5 #
6 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
7 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
8 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
9 # Options below are useful, when you want fileutils and grep providing.
10 # For example, ash package requires fileutils and grep.
11 %bcond_with     fileutl_prov    # adds fileutils providing
12 %bcond_with     grep_prov       # adds grep providing
13 # Option below is useful, when busybox is built with shell support.
14 %bcond_with     sh_prov         # adds /bin/sh providing
15 # WARNING! Shell, filetuils and grep providing may depend on config file!
16 # Fileutils, grep and shell provided with busybox have not such
17 # functionality as their GNU countenders.
18 #
19 %bcond_without  static          # don't build static version
20 %bcond_without  initrd          # don't build initrd version
21 %bcond_with     dietlibc        # build dietlibc-based initrd version
22 %bcond_with     glibc           # build glibc-based initrd version
23 #
24 %ifnarch %{ix86}
25 %define with_glibc 1
26 %endif
27 Summary:        Set of common unix utils for embeded systems
28 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
29 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
30 Name:           busybox
31 Version:        1.00
32 %define pre     pre10
33 Release:        0.%{pre}.1
34 License:        GPL
35 Group:          Applications
36 Source0:        http://www.busybox.net/downloads/%{name}-%{version}-%{pre}.tar.bz2
37 # Source0-md5:  e64c855f4b9e5e8c0645422c34499753
38 Source1:        %{name}.config
39 Source2:        %{name}-initrd.config
40 %{?with_altconfig:Source3:      %{cfgfile}}
41 Patch0:         %{name}-logconsole.patch
42 Patch1:         %{name}-print_ascii.patch
43 Patch2:         %{name}-printf-gettext.patch
44 Patch3:         %{name}-loadfont.patch
45 Patch4:         %{name}-pivot_root.patch
46 Patch5:         %{name}-malloc.patch
47 Patch6:         %{name}-raid_start.patch
48 Patch8:         %{name}-force-dietlibc.patch
49 Patch9:         %{name}-ash_exec.patch
50 Patch10:        %{name}-amd64.patch
51 Patch11:        %{name}-kernel_headers.patch
52 Patch12:        %{name}-insmod-morearchs.patch
53 Patch13:        %{name}-readahead.patch
54 URL:            http://www.busybox.net/
55 BuildRequires:  gcc >= 3.2
56 %{?with_static:BuildRequires:   glibc-static}
57 %if %{with initrd}
58   %if %{with dietlibc}
59 BuildRequires:  dietlibc-static
60   %else
61     %if %{with glibc}
62 BuildRequires:  glibc-static
63     %else
64 BuildRequires:  uClibc-static >= 0.9.21
65     %endif
66   %endif
67 %endif
68 %{?with_fileutl_prov:Provides:  fileutils}
69 %{?with_grep_prov:Provides:     grep}
70 %{?with_sh_prov:Provides:       /bin/sh}
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 %define         _initrd_bindir  /bin
74
75 %description
76 BusyBox combines tiny versions of many common UNIX utilities into a
77 single small executable. It provides minimalist replacements for most
78 of the utilities you usually find in fileutils, shellutils, findutils,
79 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
80 POSIX environment for any small or embedded system. The utilities in
81 BusyBox generally have fewer options than their full-featured GNU
82 cousins; however, the options that are included provide the expected
83 functionality and behave very much like their GNU counterparts.
84
85 BusyBox has been written with size-optimization and limited resources
86 in mind. It is also extremely modular so you can easily include or
87 exclude commands (or features) at compile time. This makes it easy to
88 customize your embedded systems. To create a working system, just add
89 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
90 ae).
91
92 %description -l pl
93 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
94 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
95 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
96 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
97 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
98 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
99 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
100 (np. elvis-tiny albo ae).
101
102 %description -l pt_BR
103 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
104 executável, fornecendo substitutos minimalistas para muitos dos
105 executáveis encontrados em pacotes como fileutils, shellutils,
106 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
107 em geral têm menos opções que os utilitários GNU, mas as opções
108 implementadas comportam-se de maneira similar aos equivalentes GNU.
109
110 %package static
111 Summary:        Static busybox
112 Summary(pl):    Statycznie skonsolidowany busybox
113 Group:          Applications
114
115 %description static
116 Static busybox.
117
118 %description static -l pl
119 Statycznie skonsolidowany busybox.
120
121 %package initrd
122 Summary:        Static busybox for initrd
123 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
124 Group:          Applications
125 Conflicts:      geninitrd < 3075
126
127 %description initrd
128 Static busybox for initrd.
129
130 %description initrd -l pl
131 Statycznie skonsolidowany busybox dla initrd.
132
133 %prep
134 %setup -q -n %{name}-%{version}-%{pre}
135 %patch0 -p1
136 #X %patch2 -p1 // UPDATE ME
137 %patch3 -p1
138 %patch4 -p1
139 #%patch5 -p1 // not needed
140 %patch6 -p1
141 %patch8 -p1
142 %patch9 -p1
143 #%patch10 -p1
144 %patch11 -p1
145 %patch13 -p1
146
147 %build
148 install %{SOURCE1} .config
149
150 %if %{with initrd}
151 install %{SOURCE2} .config
152 %{__make} oldconfig
153 %{__make} \
154         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
155         LDFLAGS="%{rpmldflags} -static" \
156 %if %{with dietlibc}
157         LIBRARIES="-lrpc" \
158         CC="diet gcc"
159 %else
160 %if %{with glibc}
161         CC="%{__cc}"
162 %else
163         CC="%{_target_cpu}-uclibc-gcc"
164 %endif
165 %endif
166
167 mv -f busybox busybox.initrd
168 %{__make} clean
169 install %{SOURCE1} .config
170 %endif
171
172 %if %{with altconfig}
173 install %{SOURCE3} .config
174 %endif
175
176 %if %{with static}
177 %{__make} oldconfig
178 %{__make}  \
179         CFLAGS_EXTRA="%{rpmcflags}" \
180         LDFLAGS="%{rpmldflags} -static" \
181         CC="%{__cc}"
182 mv -f busybox busybox.static
183 %{__make} clean
184 %endif
185
186 %{__make} oldconfig
187 %{__make} \
188         CFLAGS_EXTRA="%{rpmcflags}" \
189         LDFLAGS="%{rpmldflags}" \
190         CC="%{__cc}"
191
192 %install
193 rm -rf $RPM_BUILD_ROOT
194 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
195
196 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
197 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
198
199 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
200 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
201 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
202
203 # install links to busybox binary, when linkfl is defined
204 %if %{with linkfl}
205 %{__make} install \
206         PREFIX=$RPM_BUILD_ROOT
207 %else
208 install busybox $RPM_BUILD_ROOT%{_bindir}
209 %endif
210
211 %clean
212 rm -rf $RPM_BUILD_ROOT
213
214 %files
215 %defattr(644,root,root,755)
216 %doc AUTHORS Changelog README .config
217
218 %if %{with linkfl}
219 %attr(755,root,root) /bin/*
220 %attr(755,root,root) /sbin/*
221 %attr(755,root,root) %{_bindir}/*
222 %attr(755,root,root) %{_sbindir}/*
223 %else
224 %attr(755,root,root) %{_bindir}/busybox
225 %endif
226
227 %{_libdir}/busybox
228 %{_mandir}/man1/*
229
230 %if %{with static}
231 %files static
232 %defattr(644,root,root,755)
233 %attr(755,root,root) %{_bindir}/busybox.static
234 %endif
235
236 %if %{with initrd}
237 %files initrd
238 %defattr(644,root,root,755)
239 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
240 %endif
This page took 0.056359 seconds and 4 git commands to generate.