]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- 1.0.0pre8
[packages/busybox.git] / busybox.spec
1 #
2 # Conditional build:
3 # alternative busybox config file (replaces default one) you should
4 # define cfgfile macro, i.e.
5 #
6 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
7 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
8 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
9 # Options below are useful, when you want fileutils and grep providing.
10 # For example, ash package requires fileutils and grep.
11 %bcond_with     fileutl_prov    # adds fileutils providing
12 %bcond_with     grep_prov       # adds grep providing
13 # Option below is useful, when busybox is built with shell support.
14 %bcond_with     sh_prov         # adds /bin/sh providing
15 # WARNING! Shell, filetuils and grep providing may depend on config file!
16 # Fileutils, grep and shell provided with busybox have not such
17 # functionality as their GNU countenders.
18 #
19 %bcond_without  static          # don't build static version
20 %bcond_without  initrd          # don't build initrd version
21 %bcond_with     dietlibc        # build dietlibc-based initrd version
22 %bcond_with     glibc           # build glibc-based initrd version
23 #
24 %ifnarch %{ix86}
25 %define with_glibc 1
26 %endif
27 Summary:        Set of common unix utils for embeded systems
28 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
29 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
30 Name:           busybox
31 Version:        1.00
32 %define pre     pre8
33 Release:        0.%{pre}.1
34 License:        GPL
35 Group:          Applications
36 Source0:        http://www.busybox.net/downloads/%{name}-%{version}-%{pre}.tar.bz2
37 # Source0-md5:  13afe6912c89eb2709b0049e45d2d139
38 Source1:        %{name}.config
39 Source2:        %{name}-initrd.config
40 %{?with_altconfig:Source3:      %{cfgfile}}
41 Patch0:         %{name}-logconsole.patch
42 Patch1:         %{name}-print_ascii.patch
43 Patch2:         %{name}-printf-gettext.patch
44 Patch3:         %{name}-loadfont.patch
45 Patch4:         %{name}-pivot_root.patch
46 Patch5:         %{name}-malloc.patch
47 Patch6:         %{name}-raid_start.patch
48 Patch8:         %{name}-force-dietlibc.patch
49 Patch9:         %{name}-ash_exec.patch
50 Patch10:        %{name}-amd64.patch
51 Patch11:        %{name}-kernel_headers.patch
52 Patch12:        %{name}-insmod-morearchs.patch
53 URL:            http://www.busybox.net/
54 %{?with_static:BuildRequires:   glibc-static}
55 %if %{with initrd}
56   %if %{with dietlibc}
57 BuildRequires:  dietlibc-static
58   %else
59     %if %{with glibc}
60 BuildRequires:  glibc-static
61     %else
62 BuildRequires:  uClibc-static >= 0.9.21
63     %endif
64   %endif
65 %endif
66 %{?with_fileutl_prov:Provides:  fileutils}
67 %{?with_grep_prov:Provides:     grep}
68 %{?with_sh_prov:Provides:       /bin/sh}
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %define         _initrd_bindir  /bin
72
73 %description
74 BusyBox combines tiny versions of many common UNIX utilities into a
75 single small executable. It provides minimalist replacements for most
76 of the utilities you usually find in fileutils, shellutils, findutils,
77 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
78 POSIX environment for any small or embedded system. The utilities in
79 BusyBox generally have fewer options than their full-featured GNU
80 cousins; however, the options that are included provide the expected
81 functionality and behave very much like their GNU counterparts.
82
83 BusyBox has been written with size-optimization and limited resources
84 in mind. It is also extremely modular so you can easily include or
85 exclude commands (or features) at compile time. This makes it easy to
86 customize your embedded systems. To create a working system, just add
87 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
88 ae).
89
90 %description -l pl
91 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
92 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
93 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
94 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
95 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
96 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
97 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
98 (np. elvis-tiny albo ae).
99
100 %description -l pt_BR
101 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
102 executável, fornecendo substitutos minimalistas para muitos dos
103 executáveis encontrados em pacotes como fileutils, shellutils,
104 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
105 em geral têm menos opções que os utilitários GNU, mas as opções
106 implementadas comportam-se de maneira similar aos equivalentes GNU.
107
108 %package static
109 Summary:        Static busybox
110 Summary(pl):    Statycznie skonsolidowany busybox
111 Group:          Applications
112
113 %description static
114 Static busybox.
115
116 %description static -l pl
117 Statycznie skonsolidowany busybox.
118
119 %package initrd
120 Summary:        Static busybox for initrd
121 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
122 Group:          Applications
123 Conflicts:      geninitrd < 3075
124
125 %description initrd
126 Static busybox for initrd.
127
128 %description initrd -l pl
129 Statycznie skonsolidowany busybox dla initrd.
130
131 %prep
132 %setup -q -n %{name}-%{version}-%{pre}
133 %patch0 -p1
134 %patch1 -p1
135 #X %patch2 -p1 // UPDATE ME
136 %patch3 -p1
137 %patch4 -p1
138 #%patch5 -p1 // not needed
139 %patch6 -p1
140 %patch8 -p1
141 %patch9 -p1
142 %patch10 -p1
143 %patch11 -p1
144 %patch12 -p1
145
146 %build
147 install %{SOURCE1} .config
148
149 %if %{with initrd}
150 install %{SOURCE2} .config
151 %{__make} oldconfig
152 %{__make} \
153         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
154         LDFLAGS="%{rpmldflags} -static" \
155 %if %{with dietlibc}
156         LIBRARIES="-lrpc" \
157         CC="diet gcc"
158 %else
159 %if %{with glibc}
160         CC="%{__cc}"
161 %else
162         CC="%{_target_cpu}-uclibc-gcc"
163 %endif
164 %endif
165
166 mv -f busybox busybox.initrd
167 %{__make} clean
168 install %{SOURCE1} .config
169 %endif
170
171 %if %{with altconfig}
172 install %{SOURCE3} .config
173 %endif
174
175 %if %{with static}
176 %{__make} oldconfig
177 %{__make}  \
178         CFLAGS_EXTRA="%{rpmcflags}" \
179         LDFLAGS="%{rpmldflags} -static" \
180         CC="%{__cc}"
181 mv -f busybox busybox.static
182 %{__make} clean
183 %endif
184
185 %{__make} oldconfig
186 %{__make} \
187         CFLAGS_EXTRA="%{rpmcflags}" \
188         LDFLAGS="%{rpmldflags}" \
189         CC="%{__cc}"
190
191 %install
192 rm -rf $RPM_BUILD_ROOT
193 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
194
195 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
196 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
197
198 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
199 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
200 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
201
202 # install links to busybox binary, when linkfl is defined
203 %if %{with linkfl}
204 %{__make} install \
205         PREFIX=$RPM_BUILD_ROOT
206 %else
207 install busybox $RPM_BUILD_ROOT%{_bindir}
208 %endif
209
210 %clean
211 rm -rf $RPM_BUILD_ROOT
212
213 %files
214 %defattr(644,root,root,755)
215 %doc AUTHORS TODO Changelog README .config
216
217 %if %{with linkfl}
218 %attr(755,root,root) /bin/*
219 %attr(755,root,root) /sbin/*
220 %attr(755,root,root) %{_bindir}/*
221 %attr(755,root,root) %{_sbindir}/*
222 %else
223 %attr(755,root,root) %{_bindir}/busybox
224 %endif
225
226 %{_libdir}/busybox
227 %{_mandir}/man1/*
228
229 %if %{with static}
230 %files static
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{_bindir}/busybox.static
233 %endif
234
235 %if %{with initrd}
236 %files initrd
237 %defattr(644,root,root,755)
238 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
239 %endif
This page took 0.050236 seconds and 4 git commands to generate.