]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- updated to final 1.00
[packages/busybox.git] / busybox.spec
1 #
2 # TODO:
3 #       - sparc64 modules support in sparc(32) version
4 #       - make internal commands work even if busybox is not in /bin/busybox
5
6 #
7 # Conditional build:
8 # alternative busybox config file (replaces default one) you should
9 # define cfgfile macro, i.e.
10 #
11 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
12 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
13 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
14 # Options below are useful, when you want fileutils and grep providing.
15 # For example, ash package requires fileutils and grep.
16 %bcond_with     fileutl_prov    # adds fileutils providing
17 %bcond_with     grep_prov       # adds grep providing
18 # Option below is useful, when busybox is built with shell support.
19 %bcond_with     sh_prov         # adds /bin/sh providing
20 # WARNING! Shell, filetuils and grep providing may depend on config file!
21 # Fileutils, grep and shell provided with busybox have not such
22 # functionality as their GNU countenders.
23 #
24 %bcond_without  static          # don't build static version
25 %bcond_without  initrd          # don't build initrd version
26 %bcond_with     dietlibc        # build dietlibc-based initrd version
27 %bcond_with     glibc           # build glibc-based initrd version
28 #
29 %ifnarch %{ix86}
30 %define with_glibc 1
31 %endif
32 Summary:        Set of common unix utils for embeded systems
33 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
34 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
35 Name:           busybox
36 Version:        1.00
37 Release:        2
38 License:        GPL
39 Group:          Applications
40 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
41 # Source0-md5:  5c7ea9b5d3b3677dfcdcec38b281a756
42 Source1:        %{name}.config
43 Source2:        %{name}-initrd.config
44 %{?with_altconfig:Source3:      %{cfgfile}}
45 Patch0:         %{name}-logconsole.patch
46 Patch1:         %{name}-printf-gettext.patch
47 Patch2:         %{name}-loadfont.patch
48 Patch3:         %{name}-pivot_root.patch
49 Patch4:         %{name}-raid_start.patch
50 Patch5:         %{name}-force-dietlibc.patch
51 Patch6:         %{name}-ash_exec.patch
52 Patch7:         %{name}-kernel_headers.patch
53 Patch8:         %{name}-insmod-morearchs.patch
54 Patch9:         %{name}-dhcp.patch
55 Patch10:        %{name}-switchroot.patch
56 Patch11:        %{name}-fix_64_archs.patch
57 URL:            http://www.busybox.net/
58 BuildRequires:  gcc >= 3.2
59 %{?with_static:BuildRequires:   glibc-static}
60 %if %{with initrd}
61         %if %{with dietlibc}
62 BuildRequires:  dietlibc-static
63         %else
64                 %if %{with glibc}
65 BuildRequires:  glibc-static
66                 %else
67 BuildRequires:  uClibc-static >= 0.9.21
68                 %endif
69         %endif
70 %endif
71 %{?with_fileutl_prov:Provides:  fileutils}
72 %{?with_grep_prov:Provides:     grep}
73 %{?with_sh_prov:Provides:       /bin/sh}
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76
77 %define         _bindir         /bin
78 %define         _initrd_bindir  /bin
79
80 %description
81 BusyBox combines tiny versions of many common UNIX utilities into a
82 single small executable. It provides minimalist replacements for most
83 of the utilities you usually find in fileutils, shellutils, findutils,
84 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
85 POSIX environment for any small or embedded system. The utilities in
86 BusyBox generally have fewer options than their full-featured GNU
87 cousins; however, the options that are included provide the expected
88 functionality and behave very much like their GNU counterparts.
89
90 BusyBox has been written with size-optimization and limited resources
91 in mind. It is also extremely modular so you can easily include or
92 exclude commands (or features) at compile time. This makes it easy to
93 customize your embedded systems. To create a working system, just add
94 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
95 ae).
96
97 %description -l pl
98 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
99 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
100 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
101 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
102 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
103 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
104 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
105 (np. elvis-tiny albo ae).
106
107 %description -l pt_BR
108 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
109 executável, fornecendo substitutos minimalistas para muitos dos
110 executáveis encontrados em pacotes como fileutils, shellutils,
111 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
112 em geral têm menos opções que os utilitários GNU, mas as opções
113 implementadas comportam-se de maneira similar aos equivalentes GNU.
114
115 %package static
116 Summary:        Static busybox
117 Summary(pl):    Statycznie skonsolidowany busybox
118 Group:          Applications
119
120 %description static
121 Static busybox.
122
123 %description static -l pl
124 Statycznie skonsolidowany busybox.
125
126 %package initrd
127 Summary:        Static busybox for initrd
128 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
129 Group:          Applications
130 Conflicts:      geninitrd < 3075
131
132 %description initrd
133 Static busybox for initrd.
134
135 %description initrd -l pl
136 Statycznie skonsolidowany busybox dla initrd.
137
138 %prep
139 %setup -q
140 %patch0 -p1
141 %patch1 -p1
142 %patch2 -p1
143 %patch3 -p1
144 %patch4 -p1
145 %patch5 -p1
146 %patch6 -p1
147 %patch7 -p1
148 %patch8 -p1
149 %patch9 -p1
150 %patch10 -p1
151 %patch11 -p1
152
153 %build
154 install %{SOURCE1} .config
155
156 %if %{with initrd}
157 install %{SOURCE2} .config
158 %{__make} oldconfig
159 %{__make} \
160         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
161         LDFLAGS="%{rpmldflags} -static" \
162 %if %{with dietlibc}
163         LIBRARIES="-lrpc" \
164         CC="diet gcc"
165 %else
166 %if %{with glibc}
167         CC="%{__cc}"
168 %else
169         CC="%{_target_cpu}-uclibc-gcc"
170 %endif
171 %endif
172
173 mv -f busybox busybox.initrd
174 %{__make} clean
175 install %{SOURCE1} .config
176 %endif
177
178 %if %{with altconfig}
179 install %{SOURCE3} .config
180 %endif
181
182 %if %{with static}
183 %{__make} oldconfig
184 %{__make} \
185         CFLAGS_EXTRA="%{rpmcflags}" \
186         LDFLAGS="%{rpmldflags} -static" \
187         CC="%{__cc}"
188 mv -f busybox busybox.static
189 %{__make} clean
190 %endif
191
192 %{__make} oldconfig
193 %{__make} \
194         CFLAGS_EXTRA="%{rpmcflags}" \
195         LDFLAGS="%{rpmldflags}" \
196         CC="%{__cc}"
197
198 %install
199 rm -rf $RPM_BUILD_ROOT
200 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
201
202 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
203 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
204
205 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
206 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
207 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
208
209 # install links to busybox binary, when linkfl is defined
210 %if %{with linkfl}
211 %{__make} install \
212         PREFIX=$RPM_BUILD_ROOT
213 %else
214 install busybox $RPM_BUILD_ROOT%{_bindir}
215 %endif
216
217 %clean
218 rm -rf $RPM_BUILD_ROOT
219
220 %files
221 %defattr(644,root,root,755)
222 %doc AUTHORS Changelog README .config
223
224 %if %{with linkfl}
225 %attr(755,root,root) /bin/*
226 %attr(755,root,root) /sbin/*
227 %attr(755,root,root) %{_bindir}/*
228 %attr(755,root,root) %{_sbindir}/*
229 %else
230 %attr(755,root,root) %{_bindir}/busybox
231 %endif
232
233 %{_libdir}/busybox
234 %{_mandir}/man1/*
235
236 %if %{with static}
237 %files static
238 %defattr(644,root,root,755)
239 %attr(755,root,root) %{_bindir}/busybox.static
240 %endif
241
242 %if %{with initrd}
243 %files initrd
244 %defattr(644,root,root,755)
245 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
246 %endif
This page took 0.158366 seconds and 4 git commands to generate.