]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- disable static busybox on x32, doesn;t link with glibc and no uClibc on this arch yet
[packages/busybox.git] / busybox.spec
1 # TODO:
2 # - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3 #   if it still serves a purpose
4 # - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5 # - make internal commands work even if busybox is not in /bin/busybox (initrd)
6 #   or when /proc is not mounted (static / normal)
7 #
8 # Conditional build:
9 # alternative busybox config file (replaces default one) you should
10 # define cfgfile macro, i.e.
11 #
12 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
13 #
14 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
15 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
16 %bcond_without  dynamic         # don't build dynamic (base) version
17 %bcond_without  static          # don't build static version
18 %bcond_without  initrd          # don't build initrd version
19 %bcond_with     dietlibc        # build dietlibc-based initrd and static versions
20 %bcond_with     glibc           # build glibc-based initrd and static versions
21 %bcond_without  verbose         # verbose build
22 # Options below are useful, when you want fileutils and grep providing.
23 # For example, ash package requires fileutils and grep.
24 %bcond_with     fileutl_prov    # adds fileutils providing
25 %bcond_with     grep_prov       # adds grep providing
26 # Option below is useful, when busybox is built with shell support.
27 %bcond_with     sh_prov         # adds /bin/sh providing
28 # WARNING! Shell, fileutils and grep providing may depend on config file!
29 # Fileutils, grep and shell provided with busybox have not such
30 # functionality as their GNU countenders.
31 #
32 %ifnarch %{ix86} %{x8664} ppc
33 %define         with_glibc      1
34 %endif
35 %ifarch x32
36 # until uClibc builds on x32
37 %undefine       with_static
38 %endif
39 Summary:        Set of common Unix utilities for embeded systems
40 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
41 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
42 Name:           busybox
43 # stable line only
44 Version:        1.22.1
45 Release:        6
46 License:        GPL v2
47 Group:          Applications
48 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
49 # Source0-md5:  337d1a15ab1cb1d4ed423168b1eb7d7e
50 Source1:        %{name}.config
51 Source2:        %{name}-initrd.config
52 %{?with_altconfig:Source3:      %{cfgfile}}
53 Patch100:       http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-ash.patch
54 # Patch100-md5: 538d8cddbdfc449239b25a40bc8d1575
55 Patch101:       http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-date.patch
56 # Patch101-md5: bc381f9ceb3824141c968f5bc4353943
57 Patch102:       http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-iplink.patch
58 # Patch102-md5: 24686ec2750a8703feb57fc9c6aaed1d
59 Patch103:       http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-nc.patch
60 # Patch103-md5: 69eecaae5f812d08655dfdf34b60503f
61 Patch104:       http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-lzop.patch
62 # Patch104-md5: 14fb3bf7ffaba153b3cad385677b18c3
63 Patch105:       http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-zcat-no-ext.patch
64 # Patch105-md5: 158c8c4c73db6d920bdd7d4b9b65b2a5
65 Patch0:         x32.patch
66 Patch1:         %{name}-logconsole.patch
67 Patch2:         %{name}-printf-gettext.patch
68 Patch3:         %{name}-loadfont.patch
69 Patch4:         %{name}-kernel_headers.patch
70 Patch5:         %{name}-insmod-morearchs.patch
71 Patch6:         %{name}-dhcp.patch
72 Patch7:         %{name}-fix_64_archs.patch
73 Patch9:         %{name}-ash-export-PATH.patch
74 URL:            http://www.busybox.net/
75 BuildRequires:  gcc >= 3.2
76 BuildRequires:  perl-tools-pod
77 BuildRequires:  rpmbuild(macros) >= 1.652
78 %if %{with initrd} || %{with static}
79         %if %{with dietlibc}
80 BuildRequires:  dietlibc-static
81         %else
82                 %if %{with glibc}
83 BuildRequires:  glibc-static
84                 %else
85 %if "%{_target_base_arch}" != "%{_host_base_arch}"
86 BuildRequires:  cross%{_target_base_arch}-uClibc-static
87 %else
88         %ifarch ppc %{x8664}
89 BuildRequires:  uClibc-static >= 3:0.9.30.1
90         %else
91 BuildRequires:  uClibc-static >= 3:0.9.30.1
92         %endif
93 %endif
94                 %endif
95         %endif
96 %endif
97 %{?with_sh_prov:Provides:       /bin/sh}
98 %{?with_fileutl_prov:Provides:  fileutils}
99 %{?with_grep_prov:Provides:     grep}
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %define         _bindir         /bin
103
104 %if "%{_target_base_arch}" != "%{_host_base_arch}"
105         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
106 %else
107         %define CrossOpts %{nil}
108 %endif
109
110 %define         filterout_ld    -Wl,-z,(combreloc|relro)
111
112 %description
113 BusyBox combines tiny versions of many common UNIX utilities into a
114 single small executable. It provides minimalist replacements for most
115 of the utilities you usually find in fileutils, shellutils, findutils,
116 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
117 POSIX environment for any small or embedded system. The utilities in
118 BusyBox generally have fewer options than their full-featured GNU
119 cousins; however, the options that are included provide the expected
120 functionality and behave very much like their GNU counterparts.
121
122 BusyBox has been written with size-optimization and limited resources
123 in mind. It is also extremely modular so you can easily include or
124 exclude commands (or features) at compile time. This makes it easy to
125 customize your embedded systems. To create a working system, just add
126 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
127 ae).
128
129 %description -l pl.UTF-8
130 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
131 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
132 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
133 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
134 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
135 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
136 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
137 (np. elvis-tiny albo ae).
138
139 %description -l pt_BR.UTF-8
140 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
141 executável, fornecendo substitutos minimalistas para muitos dos
142 executáveis encontrados em pacotes como fileutils, shellutils,
143 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
144 em geral têm menos opções que os utilitários GNU, mas as opções
145 implementadas comportam-se de maneira similar aos equivalentes GNU.
146
147 %package static
148 Summary:        Static busybox
149 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
150 Group:          Applications
151
152 %description static
153 Static busybox.
154
155 %description static -l pl.UTF-8
156 Statycznie skonsolidowany busybox.
157
158 %package initrd
159 Summary:        Static busybox for initrd
160 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
161 Group:          Base
162 Conflicts:      geninitrd < 10000.20
163
164 %description initrd
165 Static busybox for initrd.
166
167 %description initrd -l pl.UTF-8
168 Statycznie skonsolidowany busybox dla initrd.
169
170 %prep
171 %setup -q
172 %patch100 -p1
173 %patch101 -p1
174 %patch102 -p1
175 %patch103 -p1
176 %patch0 -p1
177 %patch1 -p1
178 %patch2 -p1
179 #%patch3 -p1
180 %patch4 -p1
181 %patch5 -p1
182 %patch6 -p1
183 %patch7 -p1
184 %patch9 -p1
185
186 %build
187 install -d built
188 %if %{with initrd}
189 install %{SOURCE2} .config
190 %{__make} oldconfig
191 %{__make} \
192         %{?with_verbose:V=1} \
193         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
194         LDFLAGS="%{rpmldflags} -static" \
195 %if %{with dietlibc}
196         LIBRARIES="-lrpc" \
197         CC="diet %{__cc}"
198 %else
199 %if %{with glibc}
200         %{CrossOpts} \
201         CC="%{__cc}"
202 %else
203         %if "%{_target_base_arch}" != "%{_host_base_arch}"
204         CROSS="%{_target_cpu}-uclibc-" \
205         %endif
206         CC="%{_target_cpu}-uclibc-gcc"
207 %endif
208 %endif
209
210 mv -f busybox built/busybox.initrd
211 %{__make} clean
212 %endif
213
214 %if %{with altconfig}
215 install %{SOURCE3} .config
216 %else
217 install %{SOURCE1} .config
218 %endif
219
220 %if %{with static}
221 %{__make} oldconfig
222 %{__make} \
223         %{?with_verbose:V=1} \
224         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
225         LDFLAGS="%{rpmldflags} -static" \
226 %if %{with dietlibc}
227         LIBRARIES="-lrpc" \
228         CC="diet %{__cc}"
229 %else
230 %if %{with glibc}
231         %{CrossOpts} \
232         CC="%{__cc}"
233 %else
234         %if "%{_target_base_arch}" != "%{_host_base_arch}"
235         CROSS="%{_target_cpu}-uclibc-" \
236         %endif
237         CC="%{_target_cpu}-uclibc-gcc"
238 %endif
239 %endif
240
241 mv -f busybox built/busybox.static
242 %{__make} clean
243 %endif
244
245 %if %{with dynamic}
246 %{__make} oldconfig
247 %{__make} \
248         %{?with_verbose:V=1} \
249         %{CrossOpts} \
250         CFLAGS_EXTRA="%{rpmcflags}" \
251         LDFLAGS="%{rpmldflags}" \
252         CC="%{__cc}"
253 %{__make} busybox.links docs/busybox.1
254 %endif
255
256 %install
257 rm -rf $RPM_BUILD_ROOT
258
259 %if %{with static}
260 install -d $RPM_BUILD_ROOT%{_bindir}
261 install built/busybox.static $RPM_BUILD_ROOT%{_bindir}
262 %endif
263
264 %if %{with initrd}
265 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
266 install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
267 %endif
268
269 %if %{with dynamic}
270 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
271 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
272 install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
273
274 # install links to busybox binary, when linkfl is defined
275 %if %{with linkfl}
276 %{__make} install \
277         PREFIX=$RPM_BUILD_ROOT
278 %else
279 install busybox $RPM_BUILD_ROOT%{_bindir}
280 %endif
281 %endif
282
283 %clean
284 rm -rf $RPM_BUILD_ROOT
285
286 %if %{with dynamic}
287 %files
288 %defattr(644,root,root,755)
289 %doc AUTHORS README .config
290
291 %if %{with linkfl}
292 %attr(755,root,root) /bin/*
293 %attr(755,root,root) /sbin/*
294 %attr(755,root,root) %{_bindir}/*
295 %attr(755,root,root) %{_sbindir}/*
296 %else
297 %attr(755,root,root) %{_bindir}/busybox
298 %endif
299
300 %{_libdir}/busybox
301 %{_mandir}/man1/busybox.1*
302 %endif
303
304 %if %{with static}
305 %files static
306 %defattr(644,root,root,755)
307 %attr(755,root,root) %{_bindir}/busybox.static
308 %endif
309
310 %if %{with initrd}
311 %files initrd
312 %defattr(644,root,root,755)
313 %attr(755,root,root) %{_libdir}/initrd/busybox
314 %endif
This page took 0.053528 seconds and 4 git commands to generate.