]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- added insmod_ng patch with 2.5 kernel support
[packages/busybox.git] / busybox.spec
1
2 # alternative busybox config file (replaces default one) you should 
3 # define cfgfile macro, i.e.
4 #
5 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
6 %bcond_with altconfig
7
8 %bcond_with linkfl # creates links to busybox binary and puts them into file list
9
10 # Options below are useful, when you want fileutils and grep providing.
11 # For example, ash package requires fileutils and grep.
12 %bcond_with fileutl_prov # adds fileutils providing
13 %bcond_with grep_prov    # adds grep providing
14
15 # Option below is useful, when busybox is built with shell support.
16 %bcond_with sh_prov      # adds /bin/sh providing
17
18 # WARNING! Shell, filetuils and grep providing may depend on config file!
19 # Fileutils, grep and shell provided with busybox have not such
20 # functionality as their GNU countenders.
21
22 %bcond_without static  # don't build static version
23 %bcond_without initrd  # don't build initrd version
24
25 Summary:        Set of common unix utils for embeded systems
26 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
27 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
28 Name:           busybox
29 Version:        0.60.5
30 Release:        2
31 License:        GPL
32 Group:          Applications
33 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
34 # Source0-md5:  79d244d5adbb048f1aa0d90ee9e187e4
35 %{?with_altconfig:Source1:      %{cfgfile}}
36 Patch0:         %{name}-logconsole.patch
37 Patch1:         %{name}-tee.patch
38 Patch3:         %{name}-printf-gettext.patch
39 Patch4:         %{name}-loadfont.patch
40 Patch5:         %{name}-pivot_root.patch
41 Patch6:         %{name}-malloc.patch
42 Patch7:         %{name}-raid_start.patch
43 Patch8:         %{name}-insmod_ng.patch
44 Patch100:       %{name}-config.patch
45 Patch101:       %{name}-initrd-config.patch
46 URL:            http://www.busybox.net/
47 %{?with_fileutl_prov:Provides:  fileutils}
48 %{?with_grep_prov:Provides:     grep}
49 %{?with_sh_prov:Provides:       /bin/sh}
50 %{?with_static:BuildRequires:   glibc-static}
51 %{?with_initrd:BuildRequires:   dietlibc-static}
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 BusyBox combines tiny versions of many common UNIX utilities into a
56 single small executable. It provides minimalist replacements for most
57 of the utilities you usually find in fileutils, shellutils, findutils,
58 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
59 POSIX environment for any small or embedded system. The utilities in
60 BusyBox generally have fewer options than their full-featured GNU
61 cousins; however, the options that are included provide the expected
62 functionality and behave very much like their GNU counterparts.
63
64 BusyBox has been written with size-optimization and limited resources
65 in mind. It is also extremely modular so you can easily include or
66 exclude commands (or features) at compile time. This makes it easy to
67 customize your embedded systems. To create a working system, just add
68 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
69 ae).
70
71 %description -l pl
72 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
73 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
74 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
75 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
76 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
77 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
78 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
79 (np. elvis-tiny albo ae).
80
81 %description -l pt_BR
82 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
83 executável, fornecendo substitutos minimalistas para muitos dos
84 executáveis encontrados em pacotes como fileutils, shellutils,
85 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
86 em geral têm menos opções que os utilitários GNU, mas as opções
87 implementadas comportam-se de maneira similar aos equivalentes GNU.
88
89 %package static
90 Summary:        Static busybox
91 Summary(pl):    Statycznie linkowany busybox
92 Group:          Applications
93
94 %description static
95 Static busybox.
96
97 %description static -l pl
98 Statycznie linkowany busybox.
99
100 %package initrd
101 Summary:        Static busybox for initrd
102 Summary(pl):    Statycznie linkowany busybox dla initrd
103 Group:          Applications
104
105 %description initrd
106 Static busybox for initrd.
107
108 %description initrd -l pl
109 Statycznie linkowany busybox dla initrd.
110
111 %prep
112 %setup -q
113 %patch0 -p1
114 %patch1 -p1
115 %patch3 -p1
116 %patch4 -p1
117 %patch5 -p1
118 #%patch6 -p1
119 %patch7 -p1
120 %patch8 -p1
121 cp -f Config.h Config-initrd.h
122 %patch100 -p0
123 %patch101 -p0
124
125 %build
126 %if %{with altconfig}
127 cp -f %{SOURCE1} Config.h
128 %endif
129
130 %if %{with initrd}
131 cp -f Config.h Config.h-no-initrd
132 cp -f Config-initrd.h Config.h
133 %{__make} \
134         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
135         LDFLAGS="%{rpmldflags} -static" \
136         LIBRARIES="-lrpc" \
137         CC="diet gcc"
138 mv -f busybox busybox.initrd
139 %{__make} clean
140 cp -f Config.h-no-initrd Config.h
141 %endif
142
143 %if %{with static}
144 %{__make} \
145         CFLAGS_EXTRA="%{rpmcflags}" \
146         LDFLAGS="%{rpmldflags} -static" \
147         CC="%{__cc}"
148 mv -f busybox busybox.static
149 %{__make} clean
150 %endif
151
152 %{__make} \
153         CFLAGS_EXTRA="%{rpmcflags}" \
154         LDFLAGS="%{rpmldflags}" \
155         CC="%{__cc}"
156
157 %install
158 rm -rf $RPM_BUILD_ROOT
159 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
160
161 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
162 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_bindir}}
163
164 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
165 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
166 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
167
168 # install links to busybox binary, when linkfl is defined
169 %if %{with linkfl}
170 make install PREFIX=$RPM_BUILD_ROOT
171 %else
172 install busybox $RPM_BUILD_ROOT%{_bindir}
173 %endif
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %files
179 %defattr(644,root,root,755)
180 %doc AUTHORS TODO Changelog README Config.h
181
182 %if %{with linkfl}
183 %attr(755,root,root) /bin/*
184 %attr(755,root,root) /sbin/*
185 %attr(755,root,root) %{_bindir}/*
186 %attr(755,root,root) %{_sbindir}/*
187 %else
188 %attr(755,root,root) %{_bindir}/busybox
189 %endif
190
191 %{_libdir}/busybox
192 %{_mandir}/man1/*
193
194 %if %{with static}
195 %files static
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_bindir}/busybox.static
198 %endif
199
200 %if %{with initrd}
201 %files initrd
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_bindir}/busybox.initrd
204 %endif
This page took 0.043174 seconds and 4 git commands to generate.