]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- patch ash_exec: don't bailout when there's only /bin/sh, not /bin/busybox
[packages/busybox.git] / busybox.spec
1
2 # alternative busybox config file (replaces default one) you should
3 # define cfgfile macro, i.e.
4 #
5 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
6 %bcond_with altconfig
7
8 %bcond_with linkfl # creates links to busybox binary and puts them into file list
9
10 # Options below are useful, when you want fileutils and grep providing.
11 # For example, ash package requires fileutils and grep.
12 %bcond_with fileutl_prov # adds fileutils providing
13 %bcond_with grep_prov    # adds grep providing
14
15 # Option below is useful, when busybox is built with shell support.
16 %bcond_with sh_prov      # adds /bin/sh providing
17
18 # WARNING! Shell, filetuils and grep providing may depend on config file!
19 # Fileutils, grep and shell provided with busybox have not such
20 # functionality as their GNU countenders.
21
22 %bcond_without static  # don't build static version
23 %bcond_without initrd  # don't build initrd version
24
25 %bcond_with dietlibc
26
27 %define pre     pre2
28 Summary:        Set of common unix utils for embeded systems
29 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
30 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
31 Name:           busybox
32 Version:        1.00
33 Release:        0.%{pre}.7
34 License:        GPL
35 Group:          Applications
36 Source0:        http://www.busybox.net/downloads/%{name}-%{version}-pre2.tar.bz2
37 # Source0-md5:  06e433389a8b34ce1031a144ba5677d1
38 Source1:        %{name}.config
39 Source2:        %{name}-initrd.config
40 %{?with_altconfig:Source3:      %{cfgfile}}
41 Patch0:         %{name}-logconsole.patch
42 Patch1:         %{name}-tee.patch
43 Patch3:         %{name}-printf-gettext.patch
44 Patch4:         %{name}-loadfont.patch
45 Patch5:         %{name}-pivot_root.patch
46 Patch6:         %{name}-malloc.patch
47 Patch7:         %{name}-raid_start.patch
48 Patch8:         %{name}-insmod_ng.patch
49 Patch9:         %{name}-force-dietlibc.patch
50 Patch10:        %{name}-insmod-gpl.patch
51 Patch11:        %{name}-ash_exec.patch
52 URL:            http://www.busybox.net/
53 %{?with_fileutl_prov:Provides:  fileutils}
54 %{?with_grep_prov:Provides:     grep}
55 %{?with_sh_prov:Provides:       /bin/sh}
56 %{?with_static:BuildRequires:   glibc-static}
57 %{?with_initrd:BuildRequires:   %{?with_dietlibc:dietlibc}%{?!with_dietlibc:uClibc}-static}
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %define         _initrd_bindir  /bin
61
62 %description
63 BusyBox combines tiny versions of many common UNIX utilities into a
64 single small executable. It provides minimalist replacements for most
65 of the utilities you usually find in fileutils, shellutils, findutils,
66 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
67 POSIX environment for any small or embedded system. The utilities in
68 BusyBox generally have fewer options than their full-featured GNU
69 cousins; however, the options that are included provide the expected
70 functionality and behave very much like their GNU counterparts.
71
72 BusyBox has been written with size-optimization and limited resources
73 in mind. It is also extremely modular so you can easily include or
74 exclude commands (or features) at compile time. This makes it easy to
75 customize your embedded systems. To create a working system, just add
76 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
77 ae).
78
79 %description -l pl
80 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
81 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
82 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
83 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
84 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
85 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
86 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
87 (np. elvis-tiny albo ae).
88
89 %description -l pt_BR
90 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
91 executável, fornecendo substitutos minimalistas para muitos dos
92 executáveis encontrados em pacotes como fileutils, shellutils,
93 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
94 em geral têm menos opções que os utilitários GNU, mas as opções
95 implementadas comportam-se de maneira similar aos equivalentes GNU.
96
97 %package static
98 Summary:        Static busybox
99 Summary(pl):    Statycznie linkowany busybox
100 Group:          Applications
101
102 %description static
103 Static busybox.
104
105 %description static -l pl
106 Statycznie linkowany busybox.
107
108 %package initrd
109 Summary:        Static busybox for initrd
110 Summary(pl):    Statycznie linkowany busybox dla initrd
111 Group:          Applications
112
113 %description initrd
114 Static busybox for initrd.
115
116 %description initrd -l pl
117 Statycznie linkowany busybox dla initrd.
118
119 %prep
120 %setup -q -n %{name}-%{version}-%{pre}
121 %patch0 -p1
122 %patch1 -p1
123 #X %patch3 -p1 // UPDATE ME
124 %patch4 -p1
125 %patch5 -p1
126 #%patch6 -p1 // not needed
127 %patch7 -p1
128 %patch8 -p1
129 %patch9 -p1
130 %patch10 -p1
131 %patch11 -p1
132
133 %build
134 install %{SOURCE1} .config
135
136 %if %{with altconfig}
137 install %{SOURCE3} .config
138 %endif
139
140 %if %{with initrd}
141 install %{SOURCE2} .config
142 %{__make} oldconfig
143 %{__make} \
144         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
145         LDFLAGS="%{rpmldflags} -static" \
146 %if %{with dietlibc}
147         LIBRARIES="-lrpc" \
148         CC="diet gcc"
149 %else
150         CC="%{_target_cpu}-uclibc-gcc"
151 %endif
152 mv -f busybox busybox.initrd
153 %{__make} clean
154 install %{SOURCE1} .config
155 %endif
156
157 %if %{with static}
158 %{__make} oldconfig
159 %{__make}  \
160         CFLAGS_EXTRA="%{rpmcflags}" \
161         LDFLAGS="%{rpmldflags} -static" \
162         CC="%{__cc}"
163 mv -f busybox busybox.static
164 %{__make} clean
165 %endif
166
167 %{__make} oldconfig
168 %{__make} \
169         CFLAGS_EXTRA="%{rpmcflags}" \
170         LDFLAGS="%{rpmldflags}" \
171         CC="%{__cc}"
172
173 %install
174 rm -rf $RPM_BUILD_ROOT
175 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
176
177 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
178 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
179
180 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
181 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
182 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
183
184 # install links to busybox binary, when linkfl is defined
185 %if %{with linkfl}
186 make install PREFIX=$RPM_BUILD_ROOT
187 %else
188 install busybox $RPM_BUILD_ROOT%{_bindir}
189 %endif
190
191 %clean
192 rm -rf $RPM_BUILD_ROOT
193
194 %files
195 %defattr(644,root,root,755)
196 %doc AUTHORS TODO Changelog README .config
197
198 %if %{with linkfl}
199 %attr(755,root,root) /bin/*
200 %attr(755,root,root) /sbin/*
201 %attr(755,root,root) %{_bindir}/*
202 %attr(755,root,root) %{_sbindir}/*
203 %else
204 %attr(755,root,root) %{_bindir}/busybox
205 %endif
206
207 %{_libdir}/busybox
208 %{_mandir}/man1/*
209
210 %if %{with static}
211 %files static
212 %defattr(644,root,root,755)
213 %attr(755,root,root) %{_bindir}/busybox.static
214 %endif
215
216 %if %{with initrd}
217 %files initrd
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
220 %endif
This page took 0.056054 seconds and 4 git commands to generate.