]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- switch to uClibc but leave dietlibc in bcond
[packages/busybox.git] / busybox.spec
1
2 # alternative busybox config file (replaces default one) you should 
3 # define cfgfile macro, i.e.
4 #
5 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
6 %bcond_with altconfig
7
8 %bcond_with linkfl # creates links to busybox binary and puts them into file list
9
10 # Options below are useful, when you want fileutils and grep providing.
11 # For example, ash package requires fileutils and grep.
12 %bcond_with fileutl_prov # adds fileutils providing
13 %bcond_with grep_prov    # adds grep providing
14
15 # Option below is useful, when busybox is built with shell support.
16 %bcond_with sh_prov      # adds /bin/sh providing
17
18 # WARNING! Shell, filetuils and grep providing may depend on config file!
19 # Fileutils, grep and shell provided with busybox have not such
20 # functionality as their GNU countenders.
21
22 %bcond_without static  # don't build static version
23 %bcond_without initrd  # don't build initrd version
24
25 %bcond_with dietlibc
26
27 %define pre     pre2
28 Summary:        Set of common unix utils for embeded systems
29 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
30 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
31 Name:           busybox
32 Version:        1.00
33 Release:        0.%{pre}.1
34 License:        GPL
35 Group:          Applications
36 Source0:        http://www.busybox.net/downloads/%{name}-%{version}-pre2.tar.bz2
37 # Source0-md5:  06e433389a8b34ce1031a144ba5677d1
38 Source1:        %{name}.config
39 Source2:        %{name}-initrd.config
40 %{?with_altconfig:Source3:      %{cfgfile}}
41 Patch0:         %{name}-logconsole.patch
42 Patch1:         %{name}-tee.patch
43 Patch3:         %{name}-printf-gettext.patch
44 Patch4:         %{name}-loadfont.patch
45 Patch5:         %{name}-pivot_root.patch
46 Patch6:         %{name}-malloc.patch
47 Patch7:         %{name}-raid_start.patch
48 Patch8:         %{name}-insmod_ng.patch
49 Patch100:       %{name}-config.patch
50 Patch101:       %{name}-initrd-config.patch
51 URL:            http://www.busybox.net/
52 %{?with_fileutl_prov:Provides:  fileutils}
53 %{?with_grep_prov:Provides:     grep}
54 %{?with_sh_prov:Provides:       /bin/sh}
55 %{?with_static:BuildRequires:   glibc-static}
56 %{?with_initrd:BuildRequires:   %{?with_dietlibc:dietlibc}%{?!with_dietlibc:uClibc}-static}
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 BusyBox combines tiny versions of many common UNIX utilities into a
61 single small executable. It provides minimalist replacements for most
62 of the utilities you usually find in fileutils, shellutils, findutils,
63 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
64 POSIX environment for any small or embedded system. The utilities in
65 BusyBox generally have fewer options than their full-featured GNU
66 cousins; however, the options that are included provide the expected
67 functionality and behave very much like their GNU counterparts.
68
69 BusyBox has been written with size-optimization and limited resources
70 in mind. It is also extremely modular so you can easily include or
71 exclude commands (or features) at compile time. This makes it easy to
72 customize your embedded systems. To create a working system, just add
73 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
74 ae).
75
76 %description -l pl
77 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
78 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
79 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
80 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
81 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
82 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
83 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
84 (np. elvis-tiny albo ae).
85
86 %description -l pt_BR
87 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
88 executável, fornecendo substitutos minimalistas para muitos dos
89 executáveis encontrados em pacotes como fileutils, shellutils,
90 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
91 em geral têm menos opções que os utilitários GNU, mas as opções
92 implementadas comportam-se de maneira similar aos equivalentes GNU.
93
94 %package static
95 Summary:        Static busybox
96 Summary(pl):    Statycznie linkowany busybox
97 Group:          Applications
98
99 %description static
100 Static busybox.
101
102 %description static -l pl
103 Statycznie linkowany busybox.
104
105 %package initrd
106 Summary:        Static busybox for initrd
107 Summary(pl):    Statycznie linkowany busybox dla initrd
108 Group:          Applications
109
110 %description initrd
111 Static busybox for initrd.
112
113 %description initrd -l pl
114 Statycznie linkowany busybox dla initrd.
115
116 %prep
117 %setup -q -n %{name}-%{version}-%{pre}
118 %patch0 -p1
119 %patch1 -p1
120 #X %patch3 -p1 // UPDATE ME
121 %patch4 -p1
122 %patch5 -p1
123 #%patch6 -p1 // not needed
124 %patch7 -p1
125 %patch8 -p1
126
127 %build
128 install %{SOURCE1} .config
129
130 %if %{with altconfig}
131 install %{SOURCE3} .config
132 %endif
133
134 %if %{with initrd}
135 install %{SOURCE2} .config
136 %{__make} oldconfig
137 %{__make} \
138         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
139         LDFLAGS="%{rpmldflags} -static" \
140 %if %{with dietlibc}
141         LIBRARIES="-lrpc" \
142         CC="diet gcc"
143 %else
144         CC="%{_target_cpu}-uclibc-gcc"
145 %endif
146 mv -f busybox busybox.initrd
147 %{__make} clean
148 install %{SOURCE1} .config
149 %endif
150
151 %if %{with static}
152 %{__make} oldconfig
153 %{__make}  \
154         CFLAGS_EXTRA="%{rpmcflags}" \
155         LDFLAGS="%{rpmldflags} -static" \
156         CC="%{__cc}"
157 mv -f busybox busybox.static
158 %{__make} clean
159 %endif
160
161 %{__make} oldconfig 
162 %{__make} \
163         CFLAGS_EXTRA="%{rpmcflags}" \
164         LDFLAGS="%{rpmldflags}" \
165         CC="%{__cc}"
166
167 %install
168 rm -rf $RPM_BUILD_ROOT
169 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
170
171 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
172 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_bindir}}
173
174 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
175 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
176 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
177
178 # install links to busybox binary, when linkfl is defined
179 %if %{with linkfl}
180 make install PREFIX=$RPM_BUILD_ROOT
181 %else
182 install busybox $RPM_BUILD_ROOT%{_bindir}
183 %endif
184
185 %clean
186 rm -rf $RPM_BUILD_ROOT
187
188 %files
189 %defattr(644,root,root,755)
190 %doc AUTHORS TODO Changelog README .config
191
192 %if %{with linkfl}
193 %attr(755,root,root) /bin/*
194 %attr(755,root,root) /sbin/*
195 %attr(755,root,root) %{_bindir}/*
196 %attr(755,root,root) %{_sbindir}/*
197 %else
198 %attr(755,root,root) %{_bindir}/busybox
199 %endif
200
201 %{_libdir}/busybox
202 %{_mandir}/man1/*
203
204 %if %{with static}
205 %files static
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{_bindir}/busybox.static
208 %endif
209
210 %if %{with initrd}
211 %files initrd
212 %defattr(644,root,root,755)
213 %attr(755,root,root) %{_bindir}/busybox.initrd
214 %endif
This page took 0.084307 seconds and 4 git commands to generate.