]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- initrd version includes chroot utility
[packages/busybox.git] / busybox.spec
1 #
2 # TODO: sparc64 modules support in sparc(32) version
3 #
4 # Conditional build:
5 # alternative busybox config file (replaces default one) you should
6 # define cfgfile macro, i.e.
7 #
8 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
9 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
10 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
11 # Options below are useful, when you want fileutils and grep providing.
12 # For example, ash package requires fileutils and grep.
13 %bcond_with     fileutl_prov    # adds fileutils providing
14 %bcond_with     grep_prov       # adds grep providing
15 # Option below is useful, when busybox is built with shell support.
16 %bcond_with     sh_prov         # adds /bin/sh providing
17 # WARNING! Shell, filetuils and grep providing may depend on config file!
18 # Fileutils, grep and shell provided with busybox have not such
19 # functionality as their GNU countenders.
20 #
21 %bcond_without  static          # don't build static version
22 %bcond_without  initrd          # don't build initrd version
23 %bcond_with     dietlibc        # build dietlibc-based initrd version
24 %bcond_with     glibc           # build glibc-based initrd version
25 #
26 %ifnarch %{ix86}
27 %define with_glibc 1
28 %endif
29 Summary:        Set of common unix utils for embeded systems
30 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
31 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
32 Name:           busybox
33 Version:        1.00
34 %define pre     pre10
35 Release:        0.%{pre}.2
36 License:        GPL
37 Group:          Applications
38 Source0:        http://www.busybox.net/downloads/%{name}-%{version}-%{pre}.tar.bz2
39 # Source0-md5:  e64c855f4b9e5e8c0645422c34499753
40 Source1:        %{name}.config
41 Source2:        %{name}-initrd.config
42 %{?with_altconfig:Source3:      %{cfgfile}}
43 Patch0:         %{name}-logconsole.patch
44 Patch1:         %{name}-printf-gettext.patch
45 Patch2:         %{name}-loadfont.patch
46 Patch3:         %{name}-pivot_root.patch
47 Patch4:         %{name}-raid_start.patch
48 Patch5:         %{name}-force-dietlibc.patch
49 Patch6:         %{name}-ash_exec.patch
50 Patch7:         %{name}-kernel_headers.patch
51 Patch8:         %{name}-insmod-morearchs.patch
52 Patch9:         %{name}-readahead.patch
53 URL:            http://www.busybox.net/
54 BuildRequires:  gcc >= 3.2
55 %{?with_static:BuildRequires:   glibc-static}
56 %if %{with initrd}
57   %if %{with dietlibc}
58 BuildRequires:  dietlibc-static
59   %else
60     %if %{with glibc}
61 BuildRequires:  glibc-static
62     %else
63 BuildRequires:  uClibc-static >= 0.9.21
64     %endif
65   %endif
66 %endif
67 %{?with_fileutl_prov:Provides:  fileutils}
68 %{?with_grep_prov:Provides:     grep}
69 %{?with_sh_prov:Provides:       /bin/sh}
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %define         _initrd_bindir  /bin
73
74 %description
75 BusyBox combines tiny versions of many common UNIX utilities into a
76 single small executable. It provides minimalist replacements for most
77 of the utilities you usually find in fileutils, shellutils, findutils,
78 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
79 POSIX environment for any small or embedded system. The utilities in
80 BusyBox generally have fewer options than their full-featured GNU
81 cousins; however, the options that are included provide the expected
82 functionality and behave very much like their GNU counterparts.
83
84 BusyBox has been written with size-optimization and limited resources
85 in mind. It is also extremely modular so you can easily include or
86 exclude commands (or features) at compile time. This makes it easy to
87 customize your embedded systems. To create a working system, just add
88 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
89 ae).
90
91 %description -l pl
92 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
93 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
94 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
95 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
96 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
97 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
98 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
99 (np. elvis-tiny albo ae).
100
101 %description -l pt_BR
102 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
103 executável, fornecendo substitutos minimalistas para muitos dos
104 executáveis encontrados em pacotes como fileutils, shellutils,
105 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
106 em geral têm menos opções que os utilitários GNU, mas as opções
107 implementadas comportam-se de maneira similar aos equivalentes GNU.
108
109 %package static
110 Summary:        Static busybox
111 Summary(pl):    Statycznie skonsolidowany busybox
112 Group:          Applications
113
114 %description static
115 Static busybox.
116
117 %description static -l pl
118 Statycznie skonsolidowany busybox.
119
120 %package initrd
121 Summary:        Static busybox for initrd
122 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
123 Group:          Applications
124 Conflicts:      geninitrd < 3075
125
126 %description initrd
127 Static busybox for initrd.
128
129 %description initrd -l pl
130 Statycznie skonsolidowany busybox dla initrd.
131
132 %prep
133 %setup -q -n %{name}-%{version}-%{pre}
134 %patch0 -p1
135 %patch1 -p1
136 %patch2 -p1
137 %patch3 -p1
138 %patch4 -p1
139 %patch5 -p1
140 %patch6 -p1
141 %patch7 -p1
142 %patch8 -p1
143 %patch9 -p1
144
145 %build
146 install %{SOURCE1} .config
147
148 %if %{with initrd}
149 install %{SOURCE2} .config
150 %{__make} oldconfig
151 %{__make} \
152         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
153         LDFLAGS="%{rpmldflags} -static" \
154 %if %{with dietlibc}
155         LIBRARIES="-lrpc" \
156         CC="diet gcc"
157 %else
158 %if %{with glibc}
159         CC="%{__cc}"
160 %else
161         CC="%{_target_cpu}-uclibc-gcc"
162 %endif
163 %endif
164
165 mv -f busybox busybox.initrd
166 %{__make} clean
167 install %{SOURCE1} .config
168 %endif
169
170 %if %{with altconfig}
171 install %{SOURCE3} .config
172 %endif
173
174 %if %{with static}
175 %{__make} oldconfig
176 %{__make}  \
177         CFLAGS_EXTRA="%{rpmcflags}" \
178         LDFLAGS="%{rpmldflags} -static" \
179         CC="%{__cc}"
180 mv -f busybox busybox.static
181 %{__make} clean
182 %endif
183
184 %{__make} oldconfig
185 %{__make} \
186         CFLAGS_EXTRA="%{rpmcflags}" \
187         LDFLAGS="%{rpmldflags}" \
188         CC="%{__cc}"
189
190 %install
191 rm -rf $RPM_BUILD_ROOT
192 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
193
194 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
195 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
196
197 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
198 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
199 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
200
201 # install links to busybox binary, when linkfl is defined
202 %if %{with linkfl}
203 %{__make} install \
204         PREFIX=$RPM_BUILD_ROOT
205 %else
206 install busybox $RPM_BUILD_ROOT%{_bindir}
207 %endif
208
209 %clean
210 rm -rf $RPM_BUILD_ROOT
211
212 %files
213 %defattr(644,root,root,755)
214 %doc AUTHORS Changelog README .config
215
216 %if %{with linkfl}
217 %attr(755,root,root) /bin/*
218 %attr(755,root,root) /sbin/*
219 %attr(755,root,root) %{_bindir}/*
220 %attr(755,root,root) %{_sbindir}/*
221 %else
222 %attr(755,root,root) %{_bindir}/busybox
223 %endif
224
225 %{_libdir}/busybox
226 %{_mandir}/man1/*
227
228 %if %{with static}
229 %files static
230 %defattr(644,root,root,755)
231 %attr(755,root,root) %{_bindir}/busybox.static
232 %endif
233
234 %if %{with initrd}
235 %files initrd
236 %defattr(644,root,root,755)
237 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
238 %endif
This page took 0.058234 seconds and 4 git commands to generate.