]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- it uses C99 syntax, BR: gcc 3
[packages/busybox.git] / busybox.spec
1 #
2 # Conditional build:
3 # alternative busybox config file (replaces default one) you should
4 # define cfgfile macro, i.e.
5 #
6 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
7 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
8 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
9 # Options below are useful, when you want fileutils and grep providing.
10 # For example, ash package requires fileutils and grep.
11 %bcond_with     fileutl_prov    # adds fileutils providing
12 %bcond_with     grep_prov       # adds grep providing
13 # Option below is useful, when busybox is built with shell support.
14 %bcond_with     sh_prov         # adds /bin/sh providing
15 # WARNING! Shell, filetuils and grep providing may depend on config file!
16 # Fileutils, grep and shell provided with busybox have not such
17 # functionality as their GNU countenders.
18 #
19 %bcond_without  static          # don't build static version
20 %bcond_without  initrd          # don't build initrd version
21 %bcond_with     dietlibc        # build dietlibc-based initrd version
22 %bcond_with     glibc           # build glibc-based initrd version
23 #
24 %ifnarch %{ix86}
25 %define with_glibc 1
26 %endif
27 Summary:        Set of common unix utils for embeded systems
28 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
29 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
30 Name:           busybox
31 Version:        1.00
32 %define pre     pre8
33 Release:        0.%{pre}.1
34 License:        GPL
35 Group:          Applications
36 Source0:        http://www.busybox.net/downloads/%{name}-%{version}-%{pre}.tar.bz2
37 # Source0-md5:  13afe6912c89eb2709b0049e45d2d139
38 Source1:        %{name}.config
39 Source2:        %{name}-initrd.config
40 %{?with_altconfig:Source3:      %{cfgfile}}
41 Patch0:         %{name}-logconsole.patch
42 Patch1:         %{name}-print_ascii.patch
43 Patch2:         %{name}-printf-gettext.patch
44 Patch3:         %{name}-loadfont.patch
45 Patch4:         %{name}-pivot_root.patch
46 Patch5:         %{name}-malloc.patch
47 Patch6:         %{name}-raid_start.patch
48 Patch8:         %{name}-force-dietlibc.patch
49 Patch9:         %{name}-ash_exec.patch
50 Patch10:        %{name}-amd64.patch
51 Patch11:        %{name}-kernel_headers.patch
52 Patch12:        %{name}-insmod-morearchs.patch
53 URL:            http://www.busybox.net/
54 BuildRequires:  gcc >= 3.2
55 %{?with_static:BuildRequires:   glibc-static}
56 %if %{with initrd}
57   %if %{with dietlibc}
58 BuildRequires:  dietlibc-static
59   %else
60     %if %{with glibc}
61 BuildRequires:  glibc-static
62     %else
63 BuildRequires:  uClibc-static >= 0.9.21
64     %endif
65   %endif
66 %endif
67 %{?with_fileutl_prov:Provides:  fileutils}
68 %{?with_grep_prov:Provides:     grep}
69 %{?with_sh_prov:Provides:       /bin/sh}
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %define         _initrd_bindir  /bin
73
74 %description
75 BusyBox combines tiny versions of many common UNIX utilities into a
76 single small executable. It provides minimalist replacements for most
77 of the utilities you usually find in fileutils, shellutils, findutils,
78 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
79 POSIX environment for any small or embedded system. The utilities in
80 BusyBox generally have fewer options than their full-featured GNU
81 cousins; however, the options that are included provide the expected
82 functionality and behave very much like their GNU counterparts.
83
84 BusyBox has been written with size-optimization and limited resources
85 in mind. It is also extremely modular so you can easily include or
86 exclude commands (or features) at compile time. This makes it easy to
87 customize your embedded systems. To create a working system, just add
88 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
89 ae).
90
91 %description -l pl
92 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
93 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
94 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
95 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
96 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
97 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
98 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
99 (np. elvis-tiny albo ae).
100
101 %description -l pt_BR
102 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
103 executável, fornecendo substitutos minimalistas para muitos dos
104 executáveis encontrados em pacotes como fileutils, shellutils,
105 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
106 em geral têm menos opções que os utilitários GNU, mas as opções
107 implementadas comportam-se de maneira similar aos equivalentes GNU.
108
109 %package static
110 Summary:        Static busybox
111 Summary(pl):    Statycznie skonsolidowany busybox
112 Group:          Applications
113
114 %description static
115 Static busybox.
116
117 %description static -l pl
118 Statycznie skonsolidowany busybox.
119
120 %package initrd
121 Summary:        Static busybox for initrd
122 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
123 Group:          Applications
124 Conflicts:      geninitrd < 3075
125
126 %description initrd
127 Static busybox for initrd.
128
129 %description initrd -l pl
130 Statycznie skonsolidowany busybox dla initrd.
131
132 %prep
133 %setup -q -n %{name}-%{version}-%{pre}
134 %patch0 -p1
135 %patch1 -p1
136 #X %patch2 -p1 // UPDATE ME
137 %patch3 -p1
138 %patch4 -p1
139 #%patch5 -p1 // not needed
140 %patch6 -p1
141 %patch8 -p1
142 %patch9 -p1
143 %patch10 -p1
144 %patch11 -p1
145 %patch12 -p1
146
147 %build
148 install %{SOURCE1} .config
149
150 %if %{with initrd}
151 install %{SOURCE2} .config
152 %{__make} oldconfig
153 %{__make} \
154         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
155         LDFLAGS="%{rpmldflags} -static" \
156 %if %{with dietlibc}
157         LIBRARIES="-lrpc" \
158         CC="diet gcc"
159 %else
160 %if %{with glibc}
161         CC="%{__cc}"
162 %else
163         CC="%{_target_cpu}-uclibc-gcc"
164 %endif
165 %endif
166
167 mv -f busybox busybox.initrd
168 %{__make} clean
169 install %{SOURCE1} .config
170 %endif
171
172 %if %{with altconfig}
173 install %{SOURCE3} .config
174 %endif
175
176 %if %{with static}
177 %{__make} oldconfig
178 %{__make}  \
179         CFLAGS_EXTRA="%{rpmcflags}" \
180         LDFLAGS="%{rpmldflags} -static" \
181         CC="%{__cc}"
182 mv -f busybox busybox.static
183 %{__make} clean
184 %endif
185
186 %{__make} oldconfig
187 %{__make} \
188         CFLAGS_EXTRA="%{rpmcflags}" \
189         LDFLAGS="%{rpmldflags}" \
190         CC="%{__cc}"
191
192 %install
193 rm -rf $RPM_BUILD_ROOT
194 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
195
196 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
197 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
198
199 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
200 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
201 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
202
203 # install links to busybox binary, when linkfl is defined
204 %if %{with linkfl}
205 %{__make} install \
206         PREFIX=$RPM_BUILD_ROOT
207 %else
208 install busybox $RPM_BUILD_ROOT%{_bindir}
209 %endif
210
211 %clean
212 rm -rf $RPM_BUILD_ROOT
213
214 %files
215 %defattr(644,root,root,755)
216 %doc AUTHORS TODO Changelog README .config
217
218 %if %{with linkfl}
219 %attr(755,root,root) /bin/*
220 %attr(755,root,root) /sbin/*
221 %attr(755,root,root) %{_bindir}/*
222 %attr(755,root,root) %{_sbindir}/*
223 %else
224 %attr(755,root,root) %{_bindir}/busybox
225 %endif
226
227 %{_libdir}/busybox
228 %{_mandir}/man1/*
229
230 %if %{with static}
231 %files static
232 %defattr(644,root,root,755)
233 %attr(755,root,root) %{_bindir}/busybox.static
234 %endif
235
236 %if %{with initrd}
237 %files initrd
238 %defattr(644,root,root,755)
239 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
240 %endif
This page took 0.051078 seconds and 4 git commands to generate.