]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- enable history editing; usefull in debuginitrd=sh
[packages/busybox.git] / busybox.spec
1 # TODO:
2 # - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3 #   if it still serves a purpose
4 # - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5 # - make internal commands work even if busybox is not in /bin/busybox (initrd)
6 #   or when /proc is not mounted (static / normal)
7 #
8 # Conditional build:
9 # alternative busybox config file (replaces default one) you should
10 # define cfgfile macro, i.e.
11 #
12 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
13 #
14 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
15 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
16 %bcond_without  static          # don't build static version
17 %bcond_without  initrd          # don't build initrd version
18 %bcond_with     dietlibc        # build dietlibc-based initrd and static versions
19 %bcond_with     glibc           # build glibc-based initrd and static versions
20 %bcond_with     verbose         # verbose build
21 # Options below are useful, when you want fileutils and grep providing.
22 # For example, ash package requires fileutils and grep.
23 %bcond_with     fileutl_prov    # adds fileutils providing
24 %bcond_with     grep_prov       # adds grep providing
25 # Option below is useful, when busybox is built with shell support.
26 %bcond_with     sh_prov         # adds /bin/sh providing
27 # WARNING! Shell, fileutils and grep providing may depend on config file!
28 # Fileutils, grep and shell provided with busybox have not such
29 # functionality as their GNU countenders.
30 #
31 %ifnarch %{ix86} %{x8664} ppc
32 %define with_glibc 1
33 %endif
34 Summary:        Set of common Unix utilities for embeded systems
35 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
36 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
37 Name:           busybox
38 # stable line only
39 Version:        1.18.3
40 Release:        1
41 License:        GPL
42 Group:          Applications
43 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
44 # Source0-md5:  660af4d44661d32b22025a66f4f78df2
45 Source1:        %{name}.config
46 Source2:        %{name}-initrd.config
47 %{?with_altconfig:Source3:      %{cfgfile}}
48 Patch1:         %{name}-logconsole.patch
49 Patch2:         %{name}-printf-gettext.patch
50 Patch3:         %{name}-loadfont.patch
51 Patch4:         %{name}-kernel_headers.patch
52 Patch5:         %{name}-insmod-morearchs.patch
53 Patch6:         %{name}-dhcp.patch
54 Patch7:         %{name}-fix_64_archs.patch
55 Patch9:         %{name}-ash-export-PATH.patch
56 URL:            http://www.busybox.net/
57 BuildRequires:  gcc >= 3.2
58 BuildRequires:  perl-tools-pod
59 BuildRequires:  rpmbuild(macros) >= 1.333
60 %if %{with initrd} || %{with static}
61         %if %{with dietlibc}
62 BuildRequires:  dietlibc-static
63         %else
64                 %if %{with glibc}
65 BuildRequires:  glibc-static
66                 %else
67 %if "%{_target_base_arch}" != "%{_arch}"
68 BuildRequires:  cross%{_target_base_arch}-uClibc-static
69 %else
70         %ifarch ppc %{x8664}
71 BuildRequires:  uClibc-static >= 3:0.9.30.1
72         %else
73 BuildRequires:  uClibc-static >= 3:0.9.30.1
74         %endif
75 %endif
76                 %endif
77         %endif
78 %endif
79 %{?with_sh_prov:Provides:       /bin/sh}
80 %{?with_fileutl_prov:Provides:  fileutils}
81 %{?with_grep_prov:Provides:     grep}
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %define         _bindir         /bin
85
86 %if "%{_target_base_arch}" != "%{_arch}"
87         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
88 %else
89         %define CrossOpts %{nil}
90 %endif
91
92 %define         filterout_ld    -Wl,-z,(combreloc|relro)
93
94 %description
95 BusyBox combines tiny versions of many common UNIX utilities into a
96 single small executable. It provides minimalist replacements for most
97 of the utilities you usually find in fileutils, shellutils, findutils,
98 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
99 POSIX environment for any small or embedded system. The utilities in
100 BusyBox generally have fewer options than their full-featured GNU
101 cousins; however, the options that are included provide the expected
102 functionality and behave very much like their GNU counterparts.
103
104 BusyBox has been written with size-optimization and limited resources
105 in mind. It is also extremely modular so you can easily include or
106 exclude commands (or features) at compile time. This makes it easy to
107 customize your embedded systems. To create a working system, just add
108 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
109 ae).
110
111 %description -l pl.UTF-8
112 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
113 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
114 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
115 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
116 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
117 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
118 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
119 (np. elvis-tiny albo ae).
120
121 %description -l pt_BR.UTF-8
122 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
123 executável, fornecendo substitutos minimalistas para muitos dos
124 executáveis encontrados em pacotes como fileutils, shellutils,
125 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
126 em geral têm menos opções que os utilitários GNU, mas as opções
127 implementadas comportam-se de maneira similar aos equivalentes GNU.
128
129 %package static
130 Summary:        Static busybox
131 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
132 Group:          Applications
133
134 %description static
135 Static busybox.
136
137 %description static -l pl.UTF-8
138 Statycznie skonsolidowany busybox.
139
140 %package initrd
141 Summary:        Static busybox for initrd
142 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
143 Group:          Base
144 Conflicts:      geninitrd < 10000.20
145
146 %description initrd
147 Static busybox for initrd.
148
149 %description initrd -l pl.UTF-8
150 Statycznie skonsolidowany busybox dla initrd.
151
152 %prep
153 %setup -q
154 %patch1 -p1
155 %patch2 -p1
156 #%patch3 -p1
157 %patch4 -p1
158 %patch5 -p1
159 %patch6 -p1
160 %patch7 -p1
161 %patch9 -p1
162
163 %build
164 install -d built
165 %if %{with initrd}
166 install %{SOURCE2} .config
167 %{__make} oldconfig
168 %{__make} \
169         %{?with_verbose:V=1} \
170         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
171         LDFLAGS="%{ld_rpmldflags} -static" \
172 %if %{with dietlibc}
173         LIBRARIES="-lrpc" \
174         CC="diet %{__cc}"
175 %else
176 %if %{with glibc}
177         %{CrossOpts} \
178         CC="%{__cc}"
179 %else
180         %if "%{_target_base_arch}" != "%{_arch}"
181         CROSS="%{_target_cpu}-uclibc-" \
182         %endif
183         CC="%{_target_cpu}-uclibc-gcc"
184 %endif
185 %endif
186
187 mv -f busybox built/busybox.initrd
188 %{__make} clean
189 %endif
190
191
192 %if %{with altconfig}
193 install %{SOURCE3} .config
194 %else
195 install %{SOURCE1} .config
196 %endif
197
198 %if %{with static}
199 %{__make} oldconfig
200 %{__make} \
201         %{?with_verbose:V=1} \
202         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
203         LDFLAGS="%{ld_rpmldflags} -static" \
204 %if %{with dietlibc}
205         LIBRARIES="-lrpc" \
206         CC="diet %{__cc}"
207 %else
208 %if %{with glibc}
209         %{CrossOpts} \
210         CC="%{__cc}"
211 %else
212         %if "%{_target_base_arch}" != "%{_arch}"
213         CROSS="%{_target_cpu}-uclibc-" \
214         %endif
215         CC="%{_target_cpu}-uclibc-gcc"
216 %endif
217 %endif
218
219 mv -f busybox built/busybox.static
220 %{__make} clean
221 %endif
222
223 %{__make} oldconfig
224 %{__make} \
225         %{?with_verbose:V=1} \
226         %{CrossOpts} \
227         CFLAGS_EXTRA="%{rpmcflags}" \
228         LDFLAGS="%{ld_rpmldflags}" \
229         CC="%{__cc}"
230 %{__make} busybox.links docs/busybox.1
231
232 %install
233 rm -rf $RPM_BUILD_ROOT
234 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
235
236 %{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
237 %if %{with initrd}
238 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
239 install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
240 %endif
241
242 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
243 install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
244
245 # install links to busybox binary, when linkfl is defined
246 %if %{with linkfl}
247 %{__make} install \
248         PREFIX=$RPM_BUILD_ROOT
249 %else
250 install busybox $RPM_BUILD_ROOT%{_bindir}
251 %endif
252
253 %clean
254 rm -rf $RPM_BUILD_ROOT
255
256 %files
257 %defattr(644,root,root,755)
258 %doc AUTHORS README .config
259
260 %if %{with linkfl}
261 %attr(755,root,root) %{_bindir}/*
262 %attr(755,root,root) /sbin/*
263 %attr(755,root,root) %{_bindir}/*
264 %attr(755,root,root) %{_sbindir}/*
265 %else
266 %attr(755,root,root) %{_bindir}/busybox
267 %endif
268
269 %{_libdir}/busybox
270 %{_mandir}/man1/*
271
272 %if %{with static}
273 %files static
274 %defattr(644,root,root,755)
275 %attr(755,root,root) %{_bindir}/busybox.static
276 %endif
277
278 %if %{with initrd}
279 %files initrd
280 %defattr(644,root,root,755)
281 %attr(755,root,root) %{_libdir}/initrd/busybox
282 %endif
This page took 0.0928600000000001 seconds and 4 git commands to generate.