]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- rel 2; P: busybox-implementation, so geninitrd can use one of two (busybox or busyb...
[packages/busybox.git] / busybox.spec
1 # TODO:
2 # - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3 #   if it still serves a purpose
4 # - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5 # - make internal commands work even if busybox is not in /bin/busybox (initrd)
6 #   or when /proc is not mounted (static / normal)
7 #
8 # Conditional build:
9 # alternative busybox config file (replaces default one) you should
10 # define cfgfile macro, i.e.
11 #
12 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
13 #
14 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
15 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
16 %bcond_without  dynamic         # don't build dynamic (base) version
17 %bcond_without  static          # don't build static version
18 %bcond_without  initrd          # don't build initrd version
19 %bcond_with     dietlibc        # build dietlibc-based initrd and static versions
20 %bcond_with     glibc           # build glibc-based initrd and static versions
21 %bcond_without  verbose         # verbose build
22 # Options below are useful, when you want fileutils and grep providing.
23 # For example, ash package requires fileutils and grep.
24 %bcond_with     fileutl_prov    # adds fileutils providing
25 %bcond_with     grep_prov       # adds grep providing
26 # Option below is useful, when busybox is built with shell support.
27 %bcond_with     sh_prov         # adds /bin/sh providing
28 # WARNING! Shell, fileutils and grep providing may depend on config file!
29 # Fileutils, grep and shell provided with busybox have not such
30 # functionality as their GNU countenders.
31 #
32 %ifnarch %{ix86} %{x8664} ppc
33 %define         with_glibc      1
34 %endif
35 %ifarch x32
36 # until uClibc builds on x32
37 %undefine       with_static
38 %endif
39 Summary:        Set of common Unix utilities for embeded systems
40 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
41 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
42 Name:           busybox
43 # stable line only
44 Version:        1.24.2
45 Release:        2
46 License:        GPL v2
47 Group:          Applications
48 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
49 # Source0-md5:  2eaae519cac1143bcf583636a745381f
50 Source1:        %{name}.config
51 Source2:        %{name}-initrd.config
52 %{?with_altconfig:Source3:      %{cfgfile}}
53 Patch100:       https://busybox.net/downloads/fixes-1.24.2/busybox-1.24.2-CVE-2016-2147.patch
54 # Patch100-md5: c45a85f5ced712743efbb683900f8c1d
55 Patch101:       https://busybox.net/downloads/fixes-1.24.2/busybox-1.24.2-CVE-2016-2148.patch
56 # Patch101-md5: 850a57ca2871e370b4916161a0320a3f
57 Patch102:       https://busybox.net/downloads/fixes-1.24.2/busybox-1.24.2-ash-recursive-heredocs.patch
58 # Patch102-md5: b59eb7536609db1ab5215de860d9e558
59 Patch0:         x32.patch
60 Patch1:         %{name}-logconsole.patch
61 Patch2:         %{name}-printf-gettext.patch
62 Patch3:         %{name}-loadfont.patch
63 Patch4:         %{name}-kernel_headers.patch
64 Patch5:         %{name}-insmod-morearchs.patch
65 Patch6:         %{name}-dhcp.patch
66 Patch7:         %{name}-fix_64_archs.patch
67 Patch9:         %{name}-ash-export-PATH.patch
68 URL:            http://www.busybox.net/
69 BuildRequires:  gcc >= 3.2
70 BuildRequires:  perl-tools-pod
71 BuildRequires:  rpmbuild(macros) >= 1.652
72 %if %{with initrd} || %{with static}
73         %if %{with dietlibc}
74 BuildRequires:  dietlibc-static
75         %else
76                 %if %{with glibc}
77 BuildRequires:  glibc-static
78                 %else
79 %if "%{_target_base_arch}" != "%{_host_base_arch}"
80 BuildRequires:  cross%{_target_base_arch}-uClibc-static
81 %else
82         %ifarch ppc %{x8664}
83 BuildRequires:  uClibc-static >= 3:0.9.30.1
84         %else
85 BuildRequires:  uClibc-static >= 3:0.9.30.1
86         %endif
87 %endif
88                 %endif
89         %endif
90 %endif
91 %{?with_sh_prov:Provides:       /bin/sh}
92 %{?with_fileutl_prov:Provides:  fileutils}
93 %{?with_grep_prov:Provides:     grep}
94 Provides:       busybox-implementation = %{version}-%{release}
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %define         _bindir         /bin
98
99 %if "%{_target_base_arch}" != "%{_host_base_arch}"
100         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
101 %else
102         %define CrossOpts %{nil}
103 %endif
104
105 %define         filterout_ld    -Wl,-z,(combreloc|relro)
106
107 %description
108 BusyBox combines tiny versions of many common UNIX utilities into a
109 single small executable. It provides minimalist replacements for most
110 of the utilities you usually find in fileutils, shellutils, findutils,
111 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
112 POSIX environment for any small or embedded system. The utilities in
113 BusyBox generally have fewer options than their full-featured GNU
114 cousins; however, the options that are included provide the expected
115 functionality and behave very much like their GNU counterparts.
116
117 BusyBox has been written with size-optimization and limited resources
118 in mind. It is also extremely modular so you can easily include or
119 exclude commands (or features) at compile time. This makes it easy to
120 customize your embedded systems. To create a working system, just add
121 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
122 ae).
123
124 %description -l pl.UTF-8
125 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
126 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
127 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
128 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
129 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
130 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
131 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
132 (np. elvis-tiny albo ae).
133
134 %description -l pt_BR.UTF-8
135 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
136 executável, fornecendo substitutos minimalistas para muitos dos
137 executáveis encontrados em pacotes como fileutils, shellutils,
138 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
139 em geral têm menos opções que os utilitários GNU, mas as opções
140 implementadas comportam-se de maneira similar aos equivalentes GNU.
141
142 %package static
143 Summary:        Static busybox
144 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
145 Group:          Applications
146
147 %description static
148 Static busybox.
149
150 %description static -l pl.UTF-8
151 Statycznie skonsolidowany busybox.
152
153 %package initrd
154 Summary:        Static busybox for initrd
155 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
156 Group:          Base
157 Conflicts:      geninitrd < 10000.20
158 Provides:       busybox-implementation = %{version}-%{release}
159
160 %description initrd
161 Static busybox for initrd.
162
163 %description initrd -l pl.UTF-8
164 Statycznie skonsolidowany busybox dla initrd.
165
166 %prep
167 %setup -q
168 %patch100 -p1
169 %patch101 -p1
170 %patch102 -p1
171
172 %patch0 -p1
173 %patch1 -p1
174 %patch2 -p1
175 #%patch3 -p1
176 %patch4 -p1
177 %patch5 -p1
178 %patch6 -p1
179 %patch7 -p1
180 %patch9 -p1
181
182 %build
183 install -d built
184 %if %{with initrd}
185 install %{SOURCE2} .config
186 %{__make} oldconfig
187 %{__make} \
188         %{?with_verbose:V=1} \
189         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
190         LDFLAGS="%{rpmldflags} -static" \
191 %if %{with dietlibc}
192         LIBRARIES="-lrpc" \
193         CC="diet %{__cc}"
194 %else
195 %if %{with glibc}
196         %{CrossOpts} \
197         CC="%{__cc}"
198 %else
199         %if "%{_target_base_arch}" != "%{_host_base_arch}"
200         CROSS="%{_target_cpu}-uclibc-" \
201         %endif
202         CC="%{_target_cpu}-uclibc-gcc"
203 %endif
204 %endif
205
206 mv -f busybox built/busybox.initrd
207 %{__make} clean
208 %endif
209
210 %if %{with altconfig}
211 install %{SOURCE3} .config
212 %else
213 install %{SOURCE1} .config
214 %endif
215
216 %if %{with static}
217 %{__make} oldconfig
218 %{__make} \
219         %{?with_verbose:V=1} \
220         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
221         LDFLAGS="%{rpmldflags} -static" \
222 %if %{with dietlibc}
223         LIBRARIES="-lrpc" \
224         CC="diet %{__cc}"
225 %else
226 %if %{with glibc}
227         %{CrossOpts} \
228         CC="%{__cc}"
229 %else
230         %if "%{_target_base_arch}" != "%{_host_base_arch}"
231         CROSS="%{_target_cpu}-uclibc-" \
232         %endif
233         CC="%{_target_cpu}-uclibc-gcc"
234 %endif
235 %endif
236
237 mv -f busybox built/busybox.static
238 %{__make} clean
239 %endif
240
241 %if %{with dynamic}
242 %{__make} oldconfig
243 %{__make} \
244         %{?with_verbose:V=1} \
245         %{CrossOpts} \
246         CFLAGS_EXTRA="%{rpmcflags}" \
247         LDFLAGS="%{rpmldflags}" \
248         CC="%{__cc}"
249 %{__make} busybox.links docs/busybox.1
250 %endif
251
252 %install
253 rm -rf $RPM_BUILD_ROOT
254
255 %if %{with static}
256 install -d $RPM_BUILD_ROOT%{_bindir}
257 install built/busybox.static $RPM_BUILD_ROOT%{_bindir}
258 %endif
259
260 %if %{with initrd}
261 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
262 install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
263 %endif
264
265 %if %{with dynamic}
266 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
267 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
268 install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
269
270 # install links to busybox binary, when linkfl is defined
271 %if %{with linkfl}
272 %{__make} install \
273         PREFIX=$RPM_BUILD_ROOT
274 %else
275 install busybox $RPM_BUILD_ROOT%{_bindir}
276 %endif
277 %endif
278
279 %clean
280 rm -rf $RPM_BUILD_ROOT
281
282 %if %{with dynamic}
283 %files
284 %defattr(644,root,root,755)
285 %doc AUTHORS README .config
286
287 %if %{with linkfl}
288 %attr(755,root,root) /bin/*
289 %attr(755,root,root) /sbin/*
290 %attr(755,root,root) %{_bindir}/*
291 %attr(755,root,root) %{_sbindir}/*
292 %else
293 %attr(755,root,root) %{_bindir}/busybox
294 %endif
295
296 %{_libdir}/busybox
297 %{_mandir}/man1/busybox.1*
298 %endif
299
300 %if %{with static}
301 %files static
302 %defattr(644,root,root,755)
303 %attr(755,root,root) %{_bindir}/busybox.static
304 %endif
305
306 %if %{with initrd}
307 %files initrd
308 %defattr(644,root,root,755)
309 %attr(755,root,root) %{_libdir}/initrd/busybox
310 %endif
This page took 0.069936 seconds and 4 git commands to generate.