]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- rel 6
[packages/busybox.git] / busybox.spec
1 Summary:        Set of common unix utils for embeded systems
2 Name:           busybox
3 Version:        0.51
4 Release:        6
5 License:        GPL
6 Group:          Applications
7 Group(de):      Applikationen
8 Group(pl):      Aplikacje
9 Source0:        ftp://ftp.lineo.com/pub/busybox/%{name}-%{version}.tar.gz
10 Source1:        %{name}-config.h
11 Patch0:         %{name}-logconsole.patch
12 Patch1:         %{name}-tee.patch
13 Patch2:         %{name}-sh-name.patch
14 Patch3:         %{name}-printf-gettext.patch
15 Patch4:         %{name}-loadfont.patch
16 URL:            http://busybox.lineo.com/
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18 BuildRequires:  uClibc-devel-BOOT >= 20010521-3
19
20 %description
21 BusyBox combines tiny versions of many common UNIX utilities into a
22 single small executable. It provides minimalist replacements for most
23 of the utilities you usually find in fileutils, shellutils, findutils,
24 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
25 POSIX environment for any small or embedded system. The utilities in
26 BusyBox generally have fewer options than their full-featured GNU
27 cousins; however, the options that are included provide the expected
28 functionality and behave very much like their GNU counterparts.
29
30 BusyBox has been written with size-optimization and limited resources
31 in mind. It is also extremely modular so you can easily include or
32 exclude commands (or features) at compile time. This makes it easy to
33 customize your embedded systems. To create a working system, just add
34 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
35 ae).
36
37 %package BOOT
38 Summary:        busybox for PLD bootdisk
39 Group:          Applications
40 Group(de):      Applikationen
41 Group(pl):      Aplikacje
42
43 %description BOOT
44 busybox for PLD bootdisk.
45
46 %prep
47 %setup -q
48 %patch0
49 %patch1
50 %patch2 -p1
51 %patch3 -p1
52 %patch4 -p1
53
54 %build
55 # BOOT
56 cp %{SOURCE1} Config.h
57 %{__make} \
58         CFLAGS_EXTRA="-m386 -I%{_libdir}/bootdisk%{_includedir}" \
59         LDFLAGS="-nostdlib -s" \
60         LIBRARIES="%{_libdir}/bootdisk%{_libdir}/crt0.o %{_libdir}/bootdisk%{_libdir}/libc.a -lgcc"
61
62 # TODO make main package dynamically linked
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 %{__install} -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
67 %{__install} -d $RPM_BUILD_ROOT%{_libdir}/bootdisk/{bin,%{_libdir}/busybox}
68
69 %{__install} busybox $RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/
70
71 for i in `cat busybox.links`; do
72         ln -sfn busybox "$RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/`basename $i`"
73 done
74 %{__install} busybox.links $RPM_BUILD_ROOT%{_libdir}/bootdisk%{_libdir}/busybox
75 # change sh to lash (see sh_name patch)
76 mv -f $RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/{sh,lash}
77
78 %{__install} busybox $RPM_BUILD_ROOT%{_bindir}
79 %{__install} busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
80 %{__install} docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
81 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
82
83 gzip -9nf AUTHORS TODO Changelog README
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc *.gz
91 %attr(755,root,root) %{_bindir}/*
92 %{_libdir}/busybox
93 %{_mandir}/man1/*
94
95 %files BOOT
96 %defattr(644,root,root,755)
97 %attr(755,root,root) %{_libdir}/bootdisk/bin/*
98 %{_libdir}/bootdisk%{_libdir}/*
This page took 0.045665 seconds and 4 git commands to generate.