]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- updated printf-gettext,insmod-morearchs patches
[packages/busybox.git] / busybox.spec
1 #
2 # Conditional build:
3 # alternative busybox config file (replaces default one) you should
4 # define cfgfile macro, i.e.
5 #
6 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
7 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
8 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
9 # Options below are useful, when you want fileutils and grep providing.
10 # For example, ash package requires fileutils and grep.
11 %bcond_with     fileutl_prov    # adds fileutils providing
12 %bcond_with     grep_prov       # adds grep providing
13 # Option below is useful, when busybox is built with shell support.
14 %bcond_with     sh_prov         # adds /bin/sh providing
15 # WARNING! Shell, filetuils and grep providing may depend on config file!
16 # Fileutils, grep and shell provided with busybox have not such
17 # functionality as their GNU countenders.
18 #
19 %bcond_without  static          # don't build static version
20 %bcond_without  initrd          # don't build initrd version
21 %bcond_with     dietlibc        # build dietlibc-based initrd version
22 %bcond_with     glibc           # build glibc-based initrd version
23 #
24 %ifnarch %{ix86}
25 %define with_glibc 1
26 %endif
27 Summary:        Set of common unix utils for embeded systems
28 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
29 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
30 Name:           busybox
31 Version:        1.00
32 %define pre     pre10
33 Release:        0.%{pre}.1
34 License:        GPL
35 Group:          Applications
36 Source0:        http://www.busybox.net/downloads/%{name}-%{version}-%{pre}.tar.bz2
37 # Source0-md5:  e64c855f4b9e5e8c0645422c34499753
38 Source1:        %{name}.config
39 Source2:        %{name}-initrd.config
40 %{?with_altconfig:Source3:      %{cfgfile}}
41 Patch0:         %{name}-logconsole.patch
42 Patch1:         %{name}-printf-gettext.patch
43 Patch2:         %{name}-loadfont.patch
44 Patch3:         %{name}-pivot_root.patch
45 Patch4:         %{name}-raid_start.patch
46 Patch5:         %{name}-force-dietlibc.patch
47 Patch6:         %{name}-ash_exec.patch
48 Patch7:         %{name}-kernel_headers.patch
49 Patch8:         %{name}-insmod-morearchs.patch
50 Patch9:         %{name}-readahead.patch
51 URL:            http://www.busybox.net/
52 BuildRequires:  gcc >= 3.2
53 %{?with_static:BuildRequires:   glibc-static}
54 %if %{with initrd}
55   %if %{with dietlibc}
56 BuildRequires:  dietlibc-static
57   %else
58     %if %{with glibc}
59 BuildRequires:  glibc-static
60     %else
61 BuildRequires:  uClibc-static >= 0.9.21
62     %endif
63   %endif
64 %endif
65 %{?with_fileutl_prov:Provides:  fileutils}
66 %{?with_grep_prov:Provides:     grep}
67 %{?with_sh_prov:Provides:       /bin/sh}
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %define         _initrd_bindir  /bin
71
72 %description
73 BusyBox combines tiny versions of many common UNIX utilities into a
74 single small executable. It provides minimalist replacements for most
75 of the utilities you usually find in fileutils, shellutils, findutils,
76 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
77 POSIX environment for any small or embedded system. The utilities in
78 BusyBox generally have fewer options than their full-featured GNU
79 cousins; however, the options that are included provide the expected
80 functionality and behave very much like their GNU counterparts.
81
82 BusyBox has been written with size-optimization and limited resources
83 in mind. It is also extremely modular so you can easily include or
84 exclude commands (or features) at compile time. This makes it easy to
85 customize your embedded systems. To create a working system, just add
86 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
87 ae).
88
89 %description -l pl
90 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
91 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
92 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
93 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
94 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
95 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
96 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
97 (np. elvis-tiny albo ae).
98
99 %description -l pt_BR
100 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
101 executável, fornecendo substitutos minimalistas para muitos dos
102 executáveis encontrados em pacotes como fileutils, shellutils,
103 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
104 em geral têm menos opções que os utilitários GNU, mas as opções
105 implementadas comportam-se de maneira similar aos equivalentes GNU.
106
107 %package static
108 Summary:        Static busybox
109 Summary(pl):    Statycznie skonsolidowany busybox
110 Group:          Applications
111
112 %description static
113 Static busybox.
114
115 %description static -l pl
116 Statycznie skonsolidowany busybox.
117
118 %package initrd
119 Summary:        Static busybox for initrd
120 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
121 Group:          Applications
122 Conflicts:      geninitrd < 3075
123
124 %description initrd
125 Static busybox for initrd.
126
127 %description initrd -l pl
128 Statycznie skonsolidowany busybox dla initrd.
129
130 %prep
131 %setup -q -n %{name}-%{version}-%{pre}
132 %patch0 -p1
133 %patch1 -p1
134 %patch2 -p1
135 %patch3 -p1
136 %patch4 -p1
137 %patch5 -p1
138 %patch6 -p1
139 %patch7 -p1
140 %patch8 -p1
141 %patch9 -p1
142
143 %build
144 install %{SOURCE1} .config
145
146 %if %{with initrd}
147 install %{SOURCE2} .config
148 %{__make} oldconfig
149 %{__make} \
150         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
151         LDFLAGS="%{rpmldflags} -static" \
152 %if %{with dietlibc}
153         LIBRARIES="-lrpc" \
154         CC="diet gcc"
155 %else
156 %if %{with glibc}
157         CC="%{__cc}"
158 %else
159         CC="%{_target_cpu}-uclibc-gcc"
160 %endif
161 %endif
162
163 mv -f busybox busybox.initrd
164 %{__make} clean
165 install %{SOURCE1} .config
166 %endif
167
168 %if %{with altconfig}
169 install %{SOURCE3} .config
170 %endif
171
172 %if %{with static}
173 %{__make} oldconfig
174 %{__make}  \
175         CFLAGS_EXTRA="%{rpmcflags}" \
176         LDFLAGS="%{rpmldflags} -static" \
177         CC="%{__cc}"
178 mv -f busybox busybox.static
179 %{__make} clean
180 %endif
181
182 %{__make} oldconfig
183 %{__make} \
184         CFLAGS_EXTRA="%{rpmcflags}" \
185         LDFLAGS="%{rpmldflags}" \
186         CC="%{__cc}"
187
188 %install
189 rm -rf $RPM_BUILD_ROOT
190 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
191
192 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
193 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
194
195 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
196 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
197 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
198
199 # install links to busybox binary, when linkfl is defined
200 %if %{with linkfl}
201 %{__make} install \
202         PREFIX=$RPM_BUILD_ROOT
203 %else
204 install busybox $RPM_BUILD_ROOT%{_bindir}
205 %endif
206
207 %clean
208 rm -rf $RPM_BUILD_ROOT
209
210 %files
211 %defattr(644,root,root,755)
212 %doc AUTHORS Changelog README .config
213
214 %if %{with linkfl}
215 %attr(755,root,root) /bin/*
216 %attr(755,root,root) /sbin/*
217 %attr(755,root,root) %{_bindir}/*
218 %attr(755,root,root) %{_sbindir}/*
219 %else
220 %attr(755,root,root) %{_bindir}/busybox
221 %endif
222
223 %{_libdir}/busybox
224 %{_mandir}/man1/*
225
226 %if %{with static}
227 %files static
228 %defattr(644,root,root,755)
229 %attr(755,root,root) %{_bindir}/busybox.static
230 %endif
231
232 %if %{with initrd}
233 %files initrd
234 %defattr(644,root,root,755)
235 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
236 %endif
This page took 0.123638 seconds and 4 git commands to generate.