]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- updated to 0.60.1 (modified patches)
[packages/busybox.git] / busybox.spec
1 Summary:        Set of common unix utils for embeded systems
2 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
3 Name:           busybox
4 Version:        0.60.1
5 Release:        12
6 License:        GPL
7 Group:          Applications
8 Group(de):      Applikationen
9 Group(pl):      Aplikacje
10 Source0:        ftp://ftp.lineo.com/pub/busybox/%{name}-%{version}.tar.gz
11 Source1:        %{name}-config.h
12 Patch0:         %{name}-logconsole.patch
13 Patch1:         %{name}-tee.patch
14 #Patch2:                %{name}-sh-name.patch
15 Patch3:         %{name}-printf-gettext.patch
16 Patch4:         %{name}-loadfont.patch
17 Patch5:         %{name}-cread.patch
18 Patch6:         %{name}-malloc.patch
19 URL:            http://busybox.lineo.com/
20 %{?BOOT:BuildRequires:  uClibc-devel-BOOT >= 20010521-3}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 BusyBox combines tiny versions of many common UNIX utilities into a
25 single small executable. It provides minimalist replacements for most
26 of the utilities you usually find in fileutils, shellutils, findutils,
27 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
28 POSIX environment for any small or embedded system. The utilities in
29 BusyBox generally have fewer options than their full-featured GNU
30 cousins; however, the options that are included provide the expected
31 functionality and behave very much like their GNU counterparts.
32
33 BusyBox has been written with size-optimization and limited resources
34 in mind. It is also extremely modular so you can easily include or
35 exclude commands (or features) at compile time. This makes it easy to
36 customize your embedded systems. To create a working system, just add
37 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
38 ae).
39
40 %description -l pl
41 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
42 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
43 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
44 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
45 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
46 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
47 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
48 (np. elvis-tiny albo ae).
49
50 %package BOOT
51 Summary:        busybox for PLD bootdisk
52 Group:          Applications
53 Group(de):      Applikationen
54 Group(pl):      Aplikacje
55
56 %description BOOT
57 busybox for PLD bootdisk.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62 %patch1 -p1
63 #%patch2 -p1
64 %patch3 -p1
65 %patch4 -p1
66 %patch5 -p1
67 %patch6 -p1
68
69 %build
70 cp -f %{SOURCE1} Config.h
71 # BOOT
72 %if %{?BOOT:1}%{!?BOOT:0}
73 %{__make} \
74         CFLAGS_EXTRA="-I%{_libdir}/bootdisk%{_includedir}" \
75         LDFLAGS="-nostdlib" \
76         LIBRARIES="%{_libdir}/bootdisk%{_libdir}/crt0.o %{_libdir}/bootdisk%{_libdir}/libc.a -lgcc"
77 mv -f busybox busybox-BOOT
78 %endif
79
80 %{__make} clean
81
82 # TODO make main package dynamically linked
83 %{__make} \
84         CFLAGS_EXTRA="%{rpmcflags}" \
85         LDFLAGS="%{rpmldflags}"
86         
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
90
91 %if %{?BOOT:1}%{!?BOOT:0}
92 install -d $RPM_BUILD_ROOT%{_libdir}/bootdisk/{bin,%{_libdir}}
93
94 install busybox-BOOT $RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/busybox
95
96 for i in `cat busybox.links`; do
97         ln -sfn busybox "$RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/`basename $i`"
98 done
99 install busybox.links $RPM_BUILD_ROOT%{_libdir}/bootdisk%{_libdir}/busybox
100 # change sh to lash (see sh_name patch)
101 mv -f $RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/{sh,lash}
102 %endif
103
104 install busybox $RPM_BUILD_ROOT%{_bindir}
105 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
106 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
107 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
108
109 gzip -9nf AUTHORS TODO Changelog README
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files
115 %defattr(644,root,root,755)
116 %doc *.gz
117 %attr(755,root,root) %{_bindir}/*
118 %{_libdir}/busybox
119 %{_mandir}/man1/*
120
121 %if %{?BOOT:1}%{!?BOOT:0}
122 %files BOOT
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_libdir}/bootdisk/bin/*
125 %{_libdir}/bootdisk%{_libdir}/*
126 %endif
This page took 0.051392 seconds and 4 git commands to generate.