]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
d2c08eb55449c9b6de16d49334a6451f15f4f02f
[packages/busybox.git] / busybox.spec
1 # TODO:
2 #       - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
3 #       - make internal commands work even if busybox is not in /bin/busybox (initrd)
4 #         or when /proc is not mounted (static / normal)
5 #
6 # Conditional build:
7 # alternative busybox config file (replaces default one) you should
8 # define cfgfile macro, i.e.
9 #
10 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
11 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
12 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
13 # Options below are useful, when you want fileutils and grep providing.
14 # For example, ash package requires fileutils and grep.
15 %bcond_with     fileutl_prov    # adds fileutils providing
16 %bcond_with     grep_prov       # adds grep providing
17 # Option below is useful, when busybox is built with shell support.
18 %bcond_with     sh_prov         # adds /bin/sh providing
19 # WARNING! Shell, fileutils and grep providing may depend on config file!
20 # Fileutils, grep and shell provided with busybox have not such
21 # functionality as their GNU countenders.
22 #
23 %bcond_without  static          # don't build static version
24 %bcond_without  initrd          # don't build initrd version
25 %bcond_with     dietlibc        # build dietlibc-based initrd version
26 %bcond_with     glibc           # build glibc-based initrd version
27 %bcond_with     verbose
28 #
29 %ifnarch %{ix86} %{x8664} ppc
30 %define with_glibc 1
31 %endif
32 Summary:        Set of common Unix utilities for embeded systems
33 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
34 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
35 Name:           busybox
36 # stable line only
37 Version:        1.12.4
38 Release:        2
39 License:        GPL
40 Group:          Applications
41 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
42 # Source0-md5:  5b8c427bf596732d6b6156672e6e093f
43 Source1:        %{name}.config
44 Source2:        %{name}-initrd.config
45 %{?with_altconfig:Source3:      %{cfgfile}}
46 Patch1:         %{name}-logconsole.patch
47 Patch2:         %{name}-printf-gettext.patch
48 Patch3:         %{name}-loadfont.patch
49 Patch4:         %{name}-ash_exec.patch
50 Patch5:         %{name}-kernel_headers.patch
51 Patch6:         %{name}-insmod-morearchs.patch
52 Patch7:         %{name}-dhcp.patch
53 Patch8:         %{name}-fix_64_archs.patch
54 Patch9:         %{name}-inotify.patch
55 URL:            http://www.busybox.net/
56 BuildRequires:  gcc >= 3.2
57 BuildRequires:  perl-tools-pod
58 BuildRequires:  rpmbuild(macros) >= 1.333
59 %{?with_static:BuildRequires:   glibc-static}
60 %if %{with initrd}
61         %if %{with dietlibc}
62 BuildRequires:  dietlibc-static
63         %else
64                 %if %{with glibc}
65 BuildRequires:  glibc-static
66                 %else
67 %if "%{_target_base_arch}" != "%{_arch}"
68 BuildRequires:  cross%{_target_base_arch}-uClibc-static
69 %else
70         %ifarch ppc %{x8664}
71 BuildRequires:  uClibc-static >= 2:0.9.29
72         %else
73 BuildRequires:  uClibc-static >= 2:0.9.21
74         %endif
75 %endif
76                 %endif
77         %endif
78 %endif
79 %{?with_fileutl_prov:Provides:  fileutils}
80 %{?with_grep_prov:Provides:     grep}
81 %{?with_sh_prov:Provides:       /bin/sh}
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %define         _bindir         /bin
85 %define         _initrd_bindir  /bin
86
87 %if "%{_target_base_arch}" != "%{_arch}"
88         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
89 %else
90         %define CrossOpts %{nil}
91 %endif
92
93 %define         filterout_ld    -Wl,-z,(combreloc|relro)
94
95 %description
96 BusyBox combines tiny versions of many common UNIX utilities into a
97 single small executable. It provides minimalist replacements for most
98 of the utilities you usually find in fileutils, shellutils, findutils,
99 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
100 POSIX environment for any small or embedded system. The utilities in
101 BusyBox generally have fewer options than their full-featured GNU
102 cousins; however, the options that are included provide the expected
103 functionality and behave very much like their GNU counterparts.
104
105 BusyBox has been written with size-optimization and limited resources
106 in mind. It is also extremely modular so you can easily include or
107 exclude commands (or features) at compile time. This makes it easy to
108 customize your embedded systems. To create a working system, just add
109 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
110 ae).
111
112 %description -l pl.UTF-8
113 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
114 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
115 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
116 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
117 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
118 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
119 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
120 (np. elvis-tiny albo ae).
121
122 %description -l pt_BR.UTF-8
123 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
124 executável, fornecendo substitutos minimalistas para muitos dos
125 executáveis encontrados em pacotes como fileutils, shellutils,
126 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
127 em geral têm menos opções que os utilitários GNU, mas as opções
128 implementadas comportam-se de maneira similar aos equivalentes GNU.
129
130 %package static
131 Summary:        Static busybox
132 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
133 Group:          Applications
134
135 %description static
136 Static busybox.
137
138 %description static -l pl.UTF-8
139 Statycznie skonsolidowany busybox.
140
141 %package initrd
142 Summary:        Static busybox for initrd
143 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
144 Group:          Applications
145 Conflicts:      geninitrd < 3075
146
147 %description initrd
148 Static busybox for initrd.
149
150 %description initrd -l pl.UTF-8
151 Statycznie skonsolidowany busybox dla initrd.
152
153 %prep
154 %setup -q
155 %patch1 -p1
156 %patch2 -p1
157 %patch3 -p1
158 %patch4 -p1
159 %patch5 -p1
160 %patch6 -p1
161 %patch7 -p1
162 %patch8 -p1
163 %patch9 -p1
164
165 %build
166 install -d built
167 %if %{with initrd}
168 install %{SOURCE2} .config
169 %{__make} oldconfig
170 %{__make} \
171         %{?with_verbose:V=1} \
172         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
173         LDFLAGS="%{ld_rpmldflags} -static" \
174 %if %{with dietlibc}
175         LIBRARIES="-lrpc" \
176         CC="diet gcc"
177 %else
178 %if %{with glibc}
179         %{CrossOpts} \
180         CC="%{__cc}"
181 %else
182     %if "%{_target_base_arch}" != "%{_arch}"
183         CROSS="%{_target_cpu}-uclibc-" \
184     %endif
185         CC="%{_target_cpu}-uclibc-gcc"
186 %endif
187 %endif
188
189 mv -f busybox built/busybox.initrd
190 %{__make} clean
191 %endif
192
193
194 %if %{with altconfig}
195 install %{SOURCE3} .config
196 %else
197 install %{SOURCE1} .config
198 %endif
199
200 %if %{with static}
201 %{__make} oldconfig
202 %{__make} \
203         %{?with_verbose:V=1} \
204         %{CrossOpts} \
205         CFLAGS_EXTRA="%{rpmcflags}" \
206         LDFLAGS="%{ld_rpmldflags} -static" \
207         CC="%{__cc}"
208 mv -f busybox built/busybox.static
209 %{__make} clean
210 %endif
211
212 %{__make} oldconfig
213 %{__make} \
214         %{?with_verbose:V=1} \
215         %{CrossOpts} \
216         CFLAGS_EXTRA="%{rpmcflags}" \
217         LDFLAGS="%{ld_rpmldflags}" \
218         CC="%{__cc}"
219 %{__make} busybox.links docs/BusyBox.1
220
221 %install
222 rm -rf $RPM_BUILD_ROOT
223 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
224
225 %{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
226 %{?with_initrd:install built/busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
227
228 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
229 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
230 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
231
232 # install links to busybox binary, when linkfl is defined
233 %if %{with linkfl}
234 %{__make} install \
235         PREFIX=$RPM_BUILD_ROOT
236 %else
237 install busybox $RPM_BUILD_ROOT%{_bindir}
238 %endif
239
240 %clean
241 rm -rf $RPM_BUILD_ROOT
242
243 %files
244 %defattr(644,root,root,755)
245 %doc AUTHORS README .config
246
247 %if %{with linkfl}
248 %attr(755,root,root) /bin/*
249 %attr(755,root,root) /sbin/*
250 %attr(755,root,root) %{_bindir}/*
251 %attr(755,root,root) %{_sbindir}/*
252 %else
253 %attr(755,root,root) %{_bindir}/busybox
254 %endif
255
256 %{_libdir}/busybox
257 %{_mandir}/man1/*
258
259 %if %{with static}
260 %files static
261 %defattr(644,root,root,755)
262 %attr(755,root,root) %{_bindir}/busybox.static
263 %endif
264
265 %if %{with initrd}
266 %files initrd
267 %defattr(644,root,root,755)
268 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
269 %endif
This page took 0.114623 seconds and 3 git commands to generate.