]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
af1071d8e620b59e3656777ac41ef31ec7179e57
[packages/busybox.git] / busybox.spec
1 #
2 # TODO:
3 #       - sparc64 modules support in sparc(32) version
4 #       - make internal commands work even if busybox is not in /bin/busybox
5
6 #
7 # Conditional build:
8 # alternative busybox config file (replaces default one) you should
9 # define cfgfile macro, i.e.
10 #
11 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
12 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
13 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
14 # Options below are useful, when you want fileutils and grep providing.
15 # For example, ash package requires fileutils and grep.
16 %bcond_with     fileutl_prov    # adds fileutils providing
17 %bcond_with     grep_prov       # adds grep providing
18 # Option below is useful, when busybox is built with shell support.
19 %bcond_with     sh_prov         # adds /bin/sh providing
20 # WARNING! Shell, filetuils and grep providing may depend on config file!
21 # Fileutils, grep and shell provided with busybox have not such
22 # functionality as their GNU countenders.
23 #
24 %bcond_without  static          # don't build static version
25 %bcond_without  initrd          # don't build initrd version
26 %bcond_with     dietlibc        # build dietlibc-based initrd version
27 %bcond_with     glibc           # build glibc-based initrd version
28 #
29 %ifnarch %{ix86}
30 %define with_glibc 1
31 %endif
32 Summary:        Set of common unix utils for embeded systems
33 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
34 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
35 Name:           busybox
36 Version:        1.00
37 %define pre     pre10
38 Release:        0.%{pre}.4
39 License:        GPL
40 Group:          Applications
41 Source0:        http://www.busybox.net/downloads/%{name}-%{version}-%{pre}.tar.bz2
42 # Source0-md5:  e64c855f4b9e5e8c0645422c34499753
43 Source1:        %{name}.config
44 Source2:        %{name}-initrd.config
45 %{?with_altconfig:Source3:      %{cfgfile}}
46 Patch0:         %{name}-logconsole.patch
47 Patch1:         %{name}-printf-gettext.patch
48 Patch2:         %{name}-loadfont.patch
49 Patch3:         %{name}-pivot_root.patch
50 Patch4:         %{name}-raid_start.patch
51 Patch5:         %{name}-force-dietlibc.patch
52 Patch6:         %{name}-ash_exec.patch
53 Patch7:         %{name}-kernel_headers.patch
54 Patch8:         %{name}-insmod-morearchs.patch
55 Patch9:         %{name}-readahead.patch
56 Patch10:        %{name}-dhcp.patch
57 URL:            http://www.busybox.net/
58 BuildRequires:  gcc >= 3.2
59 %{?with_static:BuildRequires:   glibc-static}
60 %if %{with initrd}
61   %if %{with dietlibc}
62 BuildRequires:  dietlibc-static
63   %else
64     %if %{with glibc}
65 BuildRequires:  glibc-static
66     %else
67 BuildRequires:  uClibc-static >= 0.9.21
68     %endif
69   %endif
70 %endif
71 %{?with_fileutl_prov:Provides:  fileutils}
72 %{?with_grep_prov:Provides:     grep}
73 %{?with_sh_prov:Provides:       /bin/sh}
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76
77 %define         _bindir         /bin
78 %define         _initrd_bindir  /bin
79
80 %description
81 BusyBox combines tiny versions of many common UNIX utilities into a
82 single small executable. It provides minimalist replacements for most
83 of the utilities you usually find in fileutils, shellutils, findutils,
84 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
85 POSIX environment for any small or embedded system. The utilities in
86 BusyBox generally have fewer options than their full-featured GNU
87 cousins; however, the options that are included provide the expected
88 functionality and behave very much like their GNU counterparts.
89
90 BusyBox has been written with size-optimization and limited resources
91 in mind. It is also extremely modular so you can easily include or
92 exclude commands (or features) at compile time. This makes it easy to
93 customize your embedded systems. To create a working system, just add
94 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
95 ae).
96
97 %description -l pl
98 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
99 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
100 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
101 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
102 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
103 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
104 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
105 (np. elvis-tiny albo ae).
106
107 %description -l pt_BR
108 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
109 executável, fornecendo substitutos minimalistas para muitos dos
110 executáveis encontrados em pacotes como fileutils, shellutils,
111 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
112 em geral têm menos opções que os utilitários GNU, mas as opções
113 implementadas comportam-se de maneira similar aos equivalentes GNU.
114
115 %package static
116 Summary:        Static busybox
117 Summary(pl):    Statycznie skonsolidowany busybox
118 Group:          Applications
119
120 %description static
121 Static busybox.
122
123 %description static -l pl
124 Statycznie skonsolidowany busybox.
125
126 %package initrd
127 Summary:        Static busybox for initrd
128 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
129 Group:          Applications
130 Conflicts:      geninitrd < 3075
131
132 %description initrd
133 Static busybox for initrd.
134
135 %description initrd -l pl
136 Statycznie skonsolidowany busybox dla initrd.
137
138 %prep
139 %setup -q -n %{name}-%{version}-%{pre}
140 %patch0 -p1
141 %patch1 -p1
142 %patch2 -p1
143 %patch3 -p1
144 %patch4 -p1
145 %patch5 -p1
146 %patch6 -p1
147 %patch7 -p1
148 %patch8 -p1
149 %patch9 -p1
150 %patch10 -p1
151
152 %build
153 install %{SOURCE1} .config
154
155 %if %{with initrd}
156 install %{SOURCE2} .config
157 %{__make} oldconfig
158 %{__make} \
159         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
160         LDFLAGS="%{rpmldflags} -static" \
161 %if %{with dietlibc}
162         LIBRARIES="-lrpc" \
163         CC="diet gcc"
164 %else
165 %if %{with glibc}
166         CC="%{__cc}"
167 %else
168         CC="%{_target_cpu}-uclibc-gcc"
169 %endif
170 %endif
171
172 mv -f busybox busybox.initrd
173 %{__make} clean
174 install %{SOURCE1} .config
175 %endif
176
177 %if %{with altconfig}
178 install %{SOURCE3} .config
179 %endif
180
181 %if %{with static}
182 %{__make} oldconfig
183 %{__make}  \
184         CFLAGS_EXTRA="%{rpmcflags}" \
185         LDFLAGS="%{rpmldflags} -static" \
186         CC="%{__cc}"
187 mv -f busybox busybox.static
188 %{__make} clean
189 %endif
190
191 %{__make} oldconfig
192 %{__make} \
193         CFLAGS_EXTRA="%{rpmcflags}" \
194         LDFLAGS="%{rpmldflags}" \
195         CC="%{__cc}"
196
197 %install
198 rm -rf $RPM_BUILD_ROOT
199 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
200
201 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
202 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
203
204 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
205 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
206 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
207
208 # install links to busybox binary, when linkfl is defined
209 %if %{with linkfl}
210 %{__make} install \
211         PREFIX=$RPM_BUILD_ROOT
212 %else
213 install busybox $RPM_BUILD_ROOT%{_bindir}
214 %endif
215
216 %clean
217 rm -rf $RPM_BUILD_ROOT
218
219 %files
220 %defattr(644,root,root,755)
221 %doc AUTHORS Changelog README .config
222
223 %if %{with linkfl}
224 %attr(755,root,root) /bin/*
225 %attr(755,root,root) /sbin/*
226 %attr(755,root,root) %{_bindir}/*
227 %attr(755,root,root) %{_sbindir}/*
228 %else
229 %attr(755,root,root) %{_bindir}/busybox
230 %endif
231
232 %{_libdir}/busybox
233 %{_mandir}/man1/*
234
235 %if %{with static}
236 %files static
237 %defattr(644,root,root,755)
238 %attr(755,root,root) %{_bindir}/busybox.static
239 %endif
240
241 %if %{with initrd}
242 %files initrd
243 %defattr(644,root,root,755)
244 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
245 %endif
This page took 0.055909 seconds and 3 git commands to generate.