]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- move busybox.initrd to /bin
[packages/busybox.git] / busybox.spec
1
2 # alternative busybox config file (replaces default one) you should 
3 # define cfgfile macro, i.e.
4 #
5 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
6 %bcond_with altconfig
7
8 %bcond_with linkfl # creates links to busybox binary and puts them into file list
9
10 # Options below are useful, when you want fileutils and grep providing.
11 # For example, ash package requires fileutils and grep.
12 %bcond_with fileutl_prov # adds fileutils providing
13 %bcond_with grep_prov    # adds grep providing
14
15 # Option below is useful, when busybox is built with shell support.
16 %bcond_with sh_prov      # adds /bin/sh providing
17
18 # WARNING! Shell, filetuils and grep providing may depend on config file!
19 # Fileutils, grep and shell provided with busybox have not such
20 # functionality as their GNU countenders.
21
22 %bcond_without static  # don't build static version
23 %bcond_without initrd  # don't build initrd version
24
25 %bcond_with dietlibc
26
27 %define pre     pre2
28 Summary:        Set of common unix utils for embeded systems
29 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
30 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
31 Name:           busybox
32 Version:        1.00
33 Release:        0.%{pre}.2
34 License:        GPL
35 Group:          Applications
36 Source0:        http://www.busybox.net/downloads/%{name}-%{version}-pre2.tar.bz2
37 # Source0-md5:  06e433389a8b34ce1031a144ba5677d1
38 Source1:        %{name}.config
39 Source2:        %{name}-initrd.config
40 %{?with_altconfig:Source3:      %{cfgfile}}
41 Patch0:         %{name}-logconsole.patch
42 Patch1:         %{name}-tee.patch
43 Patch3:         %{name}-printf-gettext.patch
44 Patch4:         %{name}-loadfont.patch
45 Patch5:         %{name}-pivot_root.patch
46 Patch6:         %{name}-malloc.patch
47 Patch7:         %{name}-raid_start.patch
48 Patch8:         %{name}-insmod_ng.patch
49 Patch100:       %{name}-config.patch
50 Patch101:       %{name}-initrd-config.patch
51 URL:            http://www.busybox.net/
52 %{?with_fileutl_prov:Provides:  fileutils}
53 %{?with_grep_prov:Provides:     grep}
54 %{?with_sh_prov:Provides:       /bin/sh}
55 %{?with_static:BuildRequires:   glibc-static}
56 %{?with_initrd:BuildRequires:   %{?with_dietlibc:dietlibc}%{?!with_dietlibc:uClibc}-static}
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %define         _initrd_bindir  /bin
60
61 %description
62 BusyBox combines tiny versions of many common UNIX utilities into a
63 single small executable. It provides minimalist replacements for most
64 of the utilities you usually find in fileutils, shellutils, findutils,
65 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
66 POSIX environment for any small or embedded system. The utilities in
67 BusyBox generally have fewer options than their full-featured GNU
68 cousins; however, the options that are included provide the expected
69 functionality and behave very much like their GNU counterparts.
70
71 BusyBox has been written with size-optimization and limited resources
72 in mind. It is also extremely modular so you can easily include or
73 exclude commands (or features) at compile time. This makes it easy to
74 customize your embedded systems. To create a working system, just add
75 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
76 ae).
77
78 %description -l pl
79 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
80 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
81 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
82 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
83 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
84 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
85 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
86 (np. elvis-tiny albo ae).
87
88 %description -l pt_BR
89 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
90 executável, fornecendo substitutos minimalistas para muitos dos
91 executáveis encontrados em pacotes como fileutils, shellutils,
92 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
93 em geral têm menos opções que os utilitários GNU, mas as opções
94 implementadas comportam-se de maneira similar aos equivalentes GNU.
95
96 %package static
97 Summary:        Static busybox
98 Summary(pl):    Statycznie linkowany busybox
99 Group:          Applications
100
101 %description static
102 Static busybox.
103
104 %description static -l pl
105 Statycznie linkowany busybox.
106
107 %package initrd
108 Summary:        Static busybox for initrd
109 Summary(pl):    Statycznie linkowany busybox dla initrd
110 Group:          Applications
111
112 %description initrd
113 Static busybox for initrd.
114
115 %description initrd -l pl
116 Statycznie linkowany busybox dla initrd.
117
118 %prep
119 %setup -q -n %{name}-%{version}-%{pre}
120 %patch0 -p1
121 %patch1 -p1
122 #X %patch3 -p1 // UPDATE ME
123 %patch4 -p1
124 %patch5 -p1
125 #%patch6 -p1 // not needed
126 %patch7 -p1
127 %patch8 -p1
128
129 %build
130 install %{SOURCE1} .config
131
132 %if %{with altconfig}
133 install %{SOURCE3} .config
134 %endif
135
136 %if %{with initrd}
137 install %{SOURCE2} .config
138 %{__make} oldconfig
139 %{__make} \
140         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
141         LDFLAGS="%{rpmldflags} -static" \
142 %if %{with dietlibc}
143         LIBRARIES="-lrpc" \
144         CC="diet gcc"
145 %else
146         CC="%{_target_cpu}-uclibc-gcc"
147 %endif
148 mv -f busybox busybox.initrd
149 %{__make} clean
150 install %{SOURCE1} .config
151 %endif
152
153 %if %{with static}
154 %{__make} oldconfig
155 %{__make}  \
156         CFLAGS_EXTRA="%{rpmcflags}" \
157         LDFLAGS="%{rpmldflags} -static" \
158         CC="%{__cc}"
159 mv -f busybox busybox.static
160 %{__make} clean
161 %endif
162
163 %{__make} oldconfig 
164 %{__make} \
165         CFLAGS_EXTRA="%{rpmcflags}" \
166         LDFLAGS="%{rpmldflags}" \
167         CC="%{__cc}"
168
169 %install
170 rm -rf $RPM_BUILD_ROOT
171 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
172
173 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
174 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}}
175
176 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
177 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
178 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
179
180 # install links to busybox binary, when linkfl is defined
181 %if %{with linkfl}
182 make install PREFIX=$RPM_BUILD_ROOT
183 %else
184 install busybox $RPM_BUILD_ROOT%{_bindir}
185 %endif
186
187 %clean
188 rm -rf $RPM_BUILD_ROOT
189
190 %files
191 %defattr(644,root,root,755)
192 %doc AUTHORS TODO Changelog README .config
193
194 %if %{with linkfl}
195 %attr(755,root,root) /bin/*
196 %attr(755,root,root) /sbin/*
197 %attr(755,root,root) %{_bindir}/*
198 %attr(755,root,root) %{_sbindir}/*
199 %else
200 %attr(755,root,root) %{_bindir}/busybox
201 %endif
202
203 %{_libdir}/busybox
204 %{_mandir}/man1/*
205
206 %if %{with static}
207 %files static
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_bindir}/busybox.static
210 %endif
211
212 %if %{with initrd}
213 %files initrd
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_initrd_bindir}/busybox.initrd
216 %endif
This page took 0.048636 seconds and 3 git commands to generate.