]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- disable ip and leave ifconfig/route
[packages/busybox.git] / busybox.spec
1
2 # alternative busybox config file (replaces default one) you should 
3 # define cfgfile macro, i.e.
4 #
5 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
6 %bcond_with altconfig
7
8 %bcond_with linkfl # creates links to busybox binary and puts them into file list
9
10 # Options below are useful, when you want fileutils and grep providing.
11 # For example, ash package requires fileutils and grep.
12 %bcond_with fileutl_prov # adds fileutils providing
13 %bcond_with grep_prov    # adds grep providing
14
15 # Option below is useful, when busybox is built with shell support.
16 %bcond_with sh_prov      # adds /bin/sh providing
17
18 # WARNING! Shell, filetuils and grep providing may depend on config file!
19 # Fileutils, grep and shell provided with busybox have not such
20 # functionality as their GNU countenders.
21
22 %bcond_without static  # don't build static version
23 %bcond_without initrd  # don't build initrd version
24
25 %define pre     pre2
26 Summary:        Set of common unix utils for embeded systems
27 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
28 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
29 Name:           busybox
30 Version:        1.00
31 Release:        0.%{pre}.1
32 License:        GPL
33 Group:          Applications
34 Source0:        http://www.busybox.net/downloads/%{name}-%{version}-pre2.tar.bz2
35 # Source0-md5:  06e433389a8b34ce1031a144ba5677d1
36 Source1:        %{name}.config
37 Source2:        %{name}-initrd.config
38 %{?with_altconfig:Source3:      %{cfgfile}}
39 Patch0:         %{name}-logconsole.patch
40 Patch1:         %{name}-tee.patch
41 Patch3:         %{name}-printf-gettext.patch
42 Patch4:         %{name}-loadfont.patch
43 Patch5:         %{name}-pivot_root.patch
44 Patch6:         %{name}-malloc.patch
45 Patch7:         %{name}-raid_start.patch
46 Patch8:         %{name}-insmod_ng.patch
47 Patch100:       %{name}-config.patch
48 Patch101:       %{name}-initrd-config.patch
49 URL:            http://www.busybox.net/
50 %{?with_fileutl_prov:Provides:  fileutils}
51 %{?with_grep_prov:Provides:     grep}
52 %{?with_sh_prov:Provides:       /bin/sh}
53 %{?with_static:BuildRequires:   glibc-static}
54 %{?with_initrd:BuildRequires:   dietlibc-static}
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 BusyBox combines tiny versions of many common UNIX utilities into a
59 single small executable. It provides minimalist replacements for most
60 of the utilities you usually find in fileutils, shellutils, findutils,
61 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
62 POSIX environment for any small or embedded system. The utilities in
63 BusyBox generally have fewer options than their full-featured GNU
64 cousins; however, the options that are included provide the expected
65 functionality and behave very much like their GNU counterparts.
66
67 BusyBox has been written with size-optimization and limited resources
68 in mind. It is also extremely modular so you can easily include or
69 exclude commands (or features) at compile time. This makes it easy to
70 customize your embedded systems. To create a working system, just add
71 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
72 ae).
73
74 %description -l pl
75 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
76 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
77 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
78 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
79 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
80 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
81 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
82 (np. elvis-tiny albo ae).
83
84 %description -l pt_BR
85 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
86 executável, fornecendo substitutos minimalistas para muitos dos
87 executáveis encontrados em pacotes como fileutils, shellutils,
88 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
89 em geral têm menos opções que os utilitários GNU, mas as opções
90 implementadas comportam-se de maneira similar aos equivalentes GNU.
91
92 %package static
93 Summary:        Static busybox
94 Summary(pl):    Statycznie linkowany busybox
95 Group:          Applications
96
97 %description static
98 Static busybox.
99
100 %description static -l pl
101 Statycznie linkowany busybox.
102
103 %package initrd
104 Summary:        Static busybox for initrd
105 Summary(pl):    Statycznie linkowany busybox dla initrd
106 Group:          Applications
107
108 %description initrd
109 Static busybox for initrd.
110
111 %description initrd -l pl
112 Statycznie linkowany busybox dla initrd.
113
114 %prep
115 %setup -q -n %{name}-%{version}-%{pre}
116 %patch0 -p1
117 %patch1 -p1
118 #X %patch3 -p1 // UPDATE ME
119 %patch4 -p1
120 %patch5 -p1
121 #%patch6 -p1 // not needed
122 %patch7 -p1
123 %patch8 -p1
124
125 %build
126 install %{SOURCE1} .config
127
128 %if %{with altconfig}
129 install %{SOURCE3} .config
130 %endif
131
132 %if %{with initrd}
133 install %{SOURCE2} .config
134 %{__make} oldconfig
135 %{__make} \
136         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
137         LDFLAGS="%{rpmldflags} -static" \
138         LIBRARIES="-lrpc" \
139         CC="diet gcc"
140 mv -f busybox busybox.initrd
141 %{__make} clean
142 install %{SOURCE1} .config
143 %endif
144
145 %if %{with static}
146 %{__make} oldconfig
147 %{__make}  \
148         CFLAGS_EXTRA="%{rpmcflags}" \
149         LDFLAGS="%{rpmldflags} -static" \
150         CC="%{__cc}"
151 mv -f busybox busybox.static
152 %{__make} clean
153 %endif
154
155 %{__make} oldconfig 
156 %{__make} \
157         CFLAGS_EXTRA="%{rpmcflags}" \
158         LDFLAGS="%{rpmldflags}" \
159         CC="%{__cc}"
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
164
165 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
166 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_bindir}}
167
168 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
169 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
170 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
171
172 # install links to busybox binary, when linkfl is defined
173 %if %{with linkfl}
174 make install PREFIX=$RPM_BUILD_ROOT
175 %else
176 install busybox $RPM_BUILD_ROOT%{_bindir}
177 %endif
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %files
183 %defattr(644,root,root,755)
184 %doc AUTHORS TODO Changelog README .config
185
186 %if %{with linkfl}
187 %attr(755,root,root) /bin/*
188 %attr(755,root,root) /sbin/*
189 %attr(755,root,root) %{_bindir}/*
190 %attr(755,root,root) %{_sbindir}/*
191 %else
192 %attr(755,root,root) %{_bindir}/busybox
193 %endif
194
195 %{_libdir}/busybox
196 %{_mandir}/man1/*
197
198 %if %{with static}
199 %files static
200 %defattr(644,root,root,755)
201 %attr(755,root,root) %{_bindir}/busybox.static
202 %endif
203
204 %if %{with initrd}
205 %files initrd
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{_bindir}/busybox.initrd
208 %endif
This page took 0.090795 seconds and 3 git commands to generate.