]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
653b72a893a605070a17da252220e22319816c5c
[packages/busybox.git] / busybox.spec
1
2 # alternative busybox config file (replaces default one) you should
3 # define cfgfile macro, i.e.
4 #
5 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
6 %bcond_with altconfig
7
8 %bcond_with linkfl # creates links to busybox binary and puts them into file list
9
10 # Options below are useful, when you want fileutils and grep providing.
11 # For example, ash package requires fileutils and grep.
12 %bcond_with fileutl_prov # adds fileutils providing
13 %bcond_with grep_prov    # adds grep providing
14
15 # Option below is useful, when busybox is built with shell support.
16 %bcond_with sh_prov      # adds /bin/sh providing
17
18 # WARNING! Shell, filetuils and grep providing may depend on config file!
19 # Fileutils, grep and shell provided with busybox have not such
20 # functionality as their GNU countenders.
21
22 %bcond_without static  # don't build static version
23 %bcond_without initrd  # don't build initrd version
24
25 %bcond_with dietlibc
26 %bcond_with glibc
27
28 %ifnarch %{ix86}
29 %define with_glibc 1
30 %endif
31
32 %define pre     pre4
33 Summary:        Set of common unix utils for embeded systems
34 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
35 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
36 Name:           busybox
37 Version:        1.00
38 Release:        0.%{pre}.1
39 License:        GPL
40 Group:          Applications
41 Source0:        http://www.busybox.net/downloads/%{name}-%{version}-pre4.tar.bz2
42 # Source0-md5:  e423335994b5cd2d078dad3492768d51
43 Source1:        %{name}.config
44 Source2:        %{name}-initrd.config
45 %{?with_altconfig:Source3:      %{cfgfile}}
46 Patch0:         %{name}-logconsole.patch
47 Patch1:         %{name}-print_ascii.patch
48 Patch2:         %{name}-printf-gettext.patch
49 Patch3:         %{name}-loadfont.patch
50 Patch4:         %{name}-pivot_root.patch
51 Patch5:         %{name}-malloc.patch
52 Patch6:         %{name}-raid_start.patch
53 Patch7:         %{name}-insmod_ng.patch
54 Patch8:         %{name}-force-dietlibc.patch
55 Patch9:         %{name}-ash_exec.patch
56 URL:            http://www.busybox.net/
57 %{?with_fileutl_prov:Provides:  fileutils}
58 %{?with_grep_prov:Provides:     grep}
59 %{?with_sh_prov:Provides:       /bin/sh}
60 %{?with_static:BuildRequires:   glibc-static}
61 %if %{with initrd}
62   %if %{with dietlibc}
63 BuildRequires:  dietlibc-static
64   %else
65     %if %{with glibc}
66 BuildRequires:  glibc-static
67     %else
68 BuildRequires:  uClibc-static >= 0.9.21
69     %endif
70   %endif
71 %endif
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         _initrd_bindir  /bin
75
76 %description
77 BusyBox combines tiny versions of many common UNIX utilities into a
78 single small executable. It provides minimalist replacements for most
79 of the utilities you usually find in fileutils, shellutils, findutils,
80 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
81 POSIX environment for any small or embedded system. The utilities in
82 BusyBox generally have fewer options than their full-featured GNU
83 cousins; however, the options that are included provide the expected
84 functionality and behave very much like their GNU counterparts.
85
86 BusyBox has been written with size-optimization and limited resources
87 in mind. It is also extremely modular so you can easily include or
88 exclude commands (or features) at compile time. This makes it easy to
89 customize your embedded systems. To create a working system, just add
90 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
91 ae).
92
93 %description -l pl
94 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
95 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
96 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
97 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
98 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
99 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
100 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
101 (np. elvis-tiny albo ae).
102
103 %description -l pt_BR
104 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
105 executável, fornecendo substitutos minimalistas para muitos dos
106 executáveis encontrados em pacotes como fileutils, shellutils,
107 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
108 em geral têm menos opções que os utilitários GNU, mas as opções
109 implementadas comportam-se de maneira similar aos equivalentes GNU.
110
111 %package static
112 Summary:        Static busybox
113 Summary(pl):    Statycznie skonsolidowany busybox
114 Group:          Applications
115
116 %description static
117 Static busybox.
118
119 %description static -l pl
120 Statycznie skonsolidowany busybox.
121
122 %package initrd
123 Summary:        Static busybox for initrd
124 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
125 Group:          Applications
126
127 %description initrd
128 Static busybox for initrd.
129
130 %description initrd -l pl
131 Statycznie skonsolidowany busybox dla initrd.
132
133 %prep
134 %setup -q -n %{name}-%{version}-%{pre}
135 %patch0 -p1
136 %patch1 -p1
137 #X %patch2 -p1 // UPDATE ME
138 %patch3 -p1
139 %patch4 -p1
140 #%patch5 -p1 // not needed
141 %patch6 -p1
142 %patch7 -p1
143 %patch8 -p1
144 %patch9 -p1
145
146 %build
147 install %{SOURCE1} .config
148
149 %if %{with initrd}
150 install %{SOURCE2} .config
151 %{__make} oldconfig
152 %{__make} \
153         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
154         LDFLAGS="%{rpmldflags} -static" \
155 %if %{with dietlibc}
156         LIBRARIES="-lrpc" \
157         CC="diet gcc"
158 %else
159 %if %{with glibc}
160         CC="%{__cc}"
161 %else
162         CC="%{_target_cpu}-uclibc-gcc"
163 %endif
164 %endif
165
166 mv -f busybox busybox.initrd
167 %{__make} clean
168 install %{SOURCE1} .config
169 %endif
170
171 %if %{with altconfig}
172 install %{SOURCE3} .config
173 %endif
174
175 %if %{with static}
176 %{__make} oldconfig
177 %{__make}  \
178         CFLAGS_EXTRA="%{rpmcflags}" \
179         LDFLAGS="%{rpmldflags} -static" \
180         CC="%{__cc}"
181 mv -f busybox busybox.static
182 %{__make} clean
183 %endif
184
185 %{__make} oldconfig
186 %{__make} \
187         CFLAGS_EXTRA="%{rpmcflags}" \
188         LDFLAGS="%{rpmldflags}" \
189         CC="%{__cc}"
190
191 %install
192 rm -rf $RPM_BUILD_ROOT
193 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
194
195 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
196 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
197
198 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
199 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
200 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
201
202 # install links to busybox binary, when linkfl is defined
203 %if %{with linkfl}
204 make install \
205         PREFIX=$RPM_BUILD_ROOT
206 %else
207 install busybox $RPM_BUILD_ROOT%{_bindir}
208 %endif
209
210 %clean
211 rm -rf $RPM_BUILD_ROOT
212
213 %files
214 %defattr(644,root,root,755)
215 %doc AUTHORS TODO Changelog README .config
216
217 %if %{with linkfl}
218 %attr(755,root,root) /bin/*
219 %attr(755,root,root) /sbin/*
220 %attr(755,root,root) %{_bindir}/*
221 %attr(755,root,root) %{_sbindir}/*
222 %else
223 %attr(755,root,root) %{_bindir}/busybox
224 %endif
225
226 %{_libdir}/busybox
227 %{_mandir}/man1/*
228
229 %if %{with static}
230 %files static
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{_bindir}/busybox.static
233 %endif
234
235 %if %{with initrd}
236 %files initrd
237 %defattr(644,root,root,755)
238 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
239 %endif
This page took 0.077354 seconds and 3 git commands to generate.