]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
37817703057e3d1274b763dc213886c423b16bf2
[packages/busybox.git] / busybox.spec
1 # TODO:
2 #       - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
3 #       - make internal commands work even if busybox is not in /bin/busybox (initrd)
4 #         or when /proc is not mounted (static / normal)
5 #
6 # Conditional build:
7 # alternative busybox config file (replaces default one) you should
8 # define cfgfile macro, i.e.
9 #
10 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
11 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
12 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
13 %bcond_without  static          # don't build static version
14 %bcond_without  initrd          # don't build initrd version
15 %bcond_with     dietlibc        # build dietlibc-based initrd and static versions
16 %bcond_with     glibc           # build glibc-based initrd and static versions
17 %bcond_with     verbose         # verbose build
18 #
19 # Options below are useful, when you want fileutils and grep providing.
20 # For example, ash package requires fileutils and grep.
21 %bcond_with     fileutl_prov    # adds fileutils providing
22 %bcond_with     grep_prov       # adds grep providing
23 # Option below is useful, when busybox is built with shell support.
24 %bcond_with     sh_prov         # adds /bin/sh providing
25 # WARNING! Shell, fileutils and grep providing may depend on config file!
26 # Fileutils, grep and shell provided with busybox have not such
27 # functionality as their GNU countenders.
28 #
29 %ifnarch %{ix86} %{x8664} ppc
30 %define with_glibc 1
31 %endif
32 Summary:        Set of common Unix utilities for embeded systems
33 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
34 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
35 Name:           busybox
36 # stable line only
37 Version:        1.13.3
38 Release:        1
39 License:        GPL
40 Group:          Applications
41 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
42 # Source0-md5:  0cde6d2790e790837d6d7e82faae3ca1
43 Source1:        %{name}.config
44 Source2:        %{name}-initrd.config
45 %{?with_altconfig:Source3:      %{cfgfile}}
46 Patch1:         %{name}-logconsole.patch
47 Patch2:         %{name}-printf-gettext.patch
48 Patch3:         %{name}-loadfont.patch
49 Patch4:         %{name}-kernel_headers.patch
50 Patch5:         %{name}-insmod-morearchs.patch
51 Patch6:         %{name}-dhcp.patch
52 Patch7:         %{name}-fix_64_archs.patch
53 Patch9:         %{name}-ash-export-PATH.patch
54 URL:            http://www.busybox.net/
55 BuildRequires:  gcc >= 3.2
56 BuildRequires:  perl-tools-pod
57 BuildRequires:  rpmbuild(macros) >= 1.333
58 %if %{with initrd} || %{with static}
59         %if %{with dietlibc}
60 BuildRequires:  dietlibc-static
61         %else
62                 %if %{with glibc}
63 BuildRequires:  glibc-static
64                 %else
65 %if "%{_target_base_arch}" != "%{_arch}"
66 BuildRequires:  cross%{_target_base_arch}-uClibc-static
67 %else
68         %ifarch ppc %{x8664}
69 BuildRequires:  uClibc-static >= 3:0.9.30.1
70         %else
71 BuildRequires:  uClibc-static >= 3:0.9.30.1
72         %endif
73 %endif
74                 %endif
75         %endif
76 %endif
77 %{?with_fileutl_prov:Provides:  fileutils}
78 %{?with_grep_prov:Provides:     grep}
79 %{?with_sh_prov:Provides:       /bin/sh}
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %define         _bindir         /bin
83 %define         _initrd_bindir  /bin
84
85 %if "%{_target_base_arch}" != "%{_arch}"
86         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
87 %else
88         %define CrossOpts %{nil}
89 %endif
90
91 %define         filterout_ld    -Wl,-z,(combreloc|relro)
92
93 %description
94 BusyBox combines tiny versions of many common UNIX utilities into a
95 single small executable. It provides minimalist replacements for most
96 of the utilities you usually find in fileutils, shellutils, findutils,
97 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
98 POSIX environment for any small or embedded system. The utilities in
99 BusyBox generally have fewer options than their full-featured GNU
100 cousins; however, the options that are included provide the expected
101 functionality and behave very much like their GNU counterparts.
102
103 BusyBox has been written with size-optimization and limited resources
104 in mind. It is also extremely modular so you can easily include or
105 exclude commands (or features) at compile time. This makes it easy to
106 customize your embedded systems. To create a working system, just add
107 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
108 ae).
109
110 %description -l pl.UTF-8
111 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
112 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
113 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
114 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
115 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
116 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
117 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
118 (np. elvis-tiny albo ae).
119
120 %description -l pt_BR.UTF-8
121 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
122 executável, fornecendo substitutos minimalistas para muitos dos
123 executáveis encontrados em pacotes como fileutils, shellutils,
124 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
125 em geral têm menos opções que os utilitários GNU, mas as opções
126 implementadas comportam-se de maneira similar aos equivalentes GNU.
127
128 %package static
129 Summary:        Static busybox
130 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
131 Group:          Applications
132
133 %description static
134 Static busybox.
135
136 %description static -l pl.UTF-8
137 Statycznie skonsolidowany busybox.
138
139 %package initrd
140 Summary:        Static busybox for initrd
141 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
142 Group:          Applications
143 Conflicts:      geninitrd < 3075
144
145 %description initrd
146 Static busybox for initrd.
147
148 %description initrd -l pl.UTF-8
149 Statycznie skonsolidowany busybox dla initrd.
150
151 %prep
152 %setup -q
153 %patch1 -p1
154 %patch2 -p1
155 %patch3 -p1
156 %patch4 -p1
157 %patch5 -p1
158 %patch6 -p1
159 %patch7 -p1
160 %patch9 -p1
161
162 %build
163 install -d built
164 %if %{with initrd}
165 install %{SOURCE2} .config
166 %{__make} oldconfig
167 %{__make} \
168         %{?with_verbose:V=1} \
169         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
170         LDFLAGS="%{ld_rpmldflags} -static" \
171 %if %{with dietlibc}
172         LIBRARIES="-lrpc" \
173         CC="diet gcc"
174 %else
175 %if %{with glibc}
176         %{CrossOpts} \
177         CC="%{__cc}"
178 %else
179     %if "%{_target_base_arch}" != "%{_arch}"
180         CROSS="%{_target_cpu}-uclibc-" \
181     %endif
182         CC="%{_target_cpu}-uclibc-gcc"
183 %endif
184 %endif
185
186 mv -f busybox built/busybox.initrd
187 %{__make} clean
188 %endif
189
190
191 %if %{with altconfig}
192 install %{SOURCE3} .config
193 %else
194 install %{SOURCE1} .config
195 %endif
196
197 %if %{with static}
198 %{__make} oldconfig
199 %{__make} \
200         %{?with_verbose:V=1} \
201         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
202         LDFLAGS="%{ld_rpmldflags} -static" \
203 %if %{with dietlibc}
204         LIBRARIES="-lrpc" \
205         CC="diet gcc"
206 %else
207 %if %{with glibc}
208         %{CrossOpts} \
209         CC="%{__cc}"
210 %else
211     %if "%{_target_base_arch}" != "%{_arch}"
212         CROSS="%{_target_cpu}-uclibc-" \
213     %endif
214         CC="%{_target_cpu}-uclibc-gcc"
215 %endif
216 %endif
217
218 mv -f busybox built/busybox.static
219 %{__make} clean
220 %endif
221
222 %{__make} oldconfig
223 %{__make} \
224         %{?with_verbose:V=1} \
225         %{CrossOpts} \
226         CFLAGS_EXTRA="%{rpmcflags}" \
227         LDFLAGS="%{ld_rpmldflags}" \
228         CC="%{__cc}"
229 %{__make} busybox.links docs/BusyBox.1
230
231 %install
232 rm -rf $RPM_BUILD_ROOT
233 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
234
235 %{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
236 %{?with_initrd:install built/busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
237
238 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
239 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
240 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
241
242 # install links to busybox binary, when linkfl is defined
243 %if %{with linkfl}
244 %{__make} install \
245         PREFIX=$RPM_BUILD_ROOT
246 %else
247 install busybox $RPM_BUILD_ROOT%{_bindir}
248 %endif
249
250 %clean
251 rm -rf $RPM_BUILD_ROOT
252
253 %files
254 %defattr(644,root,root,755)
255 %doc AUTHORS README .config
256
257 %if %{with linkfl}
258 %attr(755,root,root) /bin/*
259 %attr(755,root,root) /sbin/*
260 %attr(755,root,root) %{_bindir}/*
261 %attr(755,root,root) %{_sbindir}/*
262 %else
263 %attr(755,root,root) %{_bindir}/busybox
264 %endif
265
266 %{_libdir}/busybox
267 %{_mandir}/man1/*
268
269 %if %{with static}
270 %files static
271 %defattr(644,root,root,755)
272 %attr(755,root,root) %{_bindir}/busybox.static
273 %endif
274
275 %if %{with initrd}
276 %files initrd
277 %defattr(644,root,root,755)
278 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
279 %endif
This page took 0.270556 seconds and 3 git commands to generate.