]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
19a4ca98d2793b448a2f48eab5539875ca627a29
[packages/busybox.git] / busybox.spec
1 # TODO:
2 #       - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
3 #       - make internal commands work even if busybox is not in /bin/busybox (initrd)
4 #         or when /proc is not mounted (static / normal)
5 #
6 # Conditional build:
7 # alternative busybox config file (replaces default one) you should
8 # define cfgfile macro, i.e.
9 #
10 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
11 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
12 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
13 %bcond_without  static          # don't build static version
14 %bcond_without  initrd          # don't build initrd version
15 %bcond_with     dietlibc        # build dietlibc-based initrd and static versions
16 %bcond_with     glibc           # build glibc-based initrd and static versions
17 %bcond_with     verbose         # verbose build
18 #
19 # Options below are useful, when you want fileutils and grep providing.
20 # For example, ash package requires fileutils and grep.
21 %bcond_with     fileutl_prov    # adds fileutils providing
22 %bcond_with     grep_prov       # adds grep providing
23 # Option below is useful, when busybox is built with shell support.
24 %bcond_with     sh_prov         # adds /bin/sh providing
25 # WARNING! Shell, fileutils and grep providing may depend on config file!
26 # Fileutils, grep and shell provided with busybox have not such
27 # functionality as their GNU countenders.
28 #
29 %ifnarch %{ix86} %{x8664} ppc
30 %define with_glibc 1
31 %endif
32 Summary:        Set of common Unix utilities for embeded systems
33 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
34 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
35 Name:           busybox
36 # stable line only
37 Version:        1.14.2
38 Release:        1
39 License:        GPL
40 Group:          Applications
41 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
42 # Source0-md5:  c13b09b4125688d5fca5c95a79bf814a
43 Source1:        %{name}.config
44 Source2:        %{name}-initrd.config
45 %{?with_altconfig:Source3:      %{cfgfile}}
46 Patch100:       http://busybox.net/downloads/fixes-1.14.2/busybox-1.14.2-ls.patch
47 Patch1:         %{name}-logconsole.patch
48 Patch2:         %{name}-printf-gettext.patch
49 Patch3:         %{name}-loadfont.patch
50 Patch4:         %{name}-kernel_headers.patch
51 Patch5:         %{name}-insmod-morearchs.patch
52 Patch6:         %{name}-dhcp.patch
53 Patch7:         %{name}-fix_64_archs.patch
54 Patch9:         %{name}-ash-export-PATH.patch
55 URL:            http://www.busybox.net/
56 BuildRequires:  gcc >= 3.2
57 BuildRequires:  perl-tools-pod
58 BuildRequires:  rpmbuild(macros) >= 1.333
59 %if %{with initrd} || %{with static}
60         %if %{with dietlibc}
61 BuildRequires:  dietlibc-static
62         %else
63                 %if %{with glibc}
64 BuildRequires:  glibc-static
65                 %else
66 %if "%{_target_base_arch}" != "%{_arch}"
67 BuildRequires:  cross%{_target_base_arch}-uClibc-static
68 %else
69         %ifarch ppc %{x8664}
70 BuildRequires:  uClibc-static >= 3:0.9.30.1
71         %else
72 BuildRequires:  uClibc-static >= 3:0.9.30.1
73         %endif
74 %endif
75                 %endif
76         %endif
77 %endif
78 %{?with_fileutl_prov:Provides:  fileutils}
79 %{?with_grep_prov:Provides:     grep}
80 %{?with_sh_prov:Provides:       /bin/sh}
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %define         _bindir         /bin
84
85 %if "%{_target_base_arch}" != "%{_arch}"
86         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
87 %else
88         %define CrossOpts %{nil}
89 %endif
90
91 %define         filterout_ld    -Wl,-z,(combreloc|relro)
92
93 %description
94 BusyBox combines tiny versions of many common UNIX utilities into a
95 single small executable. It provides minimalist replacements for most
96 of the utilities you usually find in fileutils, shellutils, findutils,
97 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
98 POSIX environment for any small or embedded system. The utilities in
99 BusyBox generally have fewer options than their full-featured GNU
100 cousins; however, the options that are included provide the expected
101 functionality and behave very much like their GNU counterparts.
102
103 BusyBox has been written with size-optimization and limited resources
104 in mind. It is also extremely modular so you can easily include or
105 exclude commands (or features) at compile time. This makes it easy to
106 customize your embedded systems. To create a working system, just add
107 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
108 ae).
109
110 %description -l pl.UTF-8
111 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
112 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
113 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
114 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
115 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
116 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
117 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
118 (np. elvis-tiny albo ae).
119
120 %description -l pt_BR.UTF-8
121 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
122 executável, fornecendo substitutos minimalistas para muitos dos
123 executáveis encontrados em pacotes como fileutils, shellutils,
124 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
125 em geral têm menos opções que os utilitários GNU, mas as opções
126 implementadas comportam-se de maneira similar aos equivalentes GNU.
127
128 %package static
129 Summary:        Static busybox
130 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
131 Group:          Applications
132
133 %description static
134 Static busybox.
135
136 %description static -l pl.UTF-8
137 Statycznie skonsolidowany busybox.
138
139 %package initrd
140 Summary:        Static busybox for initrd
141 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
142 Group:          Applications
143 Conflicts:      geninitrd < 10000.10
144
145 %description initrd
146 Static busybox for initrd.
147
148 %description initrd -l pl.UTF-8
149 Statycznie skonsolidowany busybox dla initrd.
150
151 %prep
152 %setup -q
153 %patch100 -p1
154 %patch1 -p1
155 %patch2 -p1
156 %patch3 -p1
157 %patch4 -p1
158 %patch5 -p1
159 %patch6 -p1
160 %patch7 -p1
161 %patch9 -p1
162
163 %build
164 install -d built
165 %if %{with initrd}
166 install %{SOURCE2} .config
167 %{__make} oldconfig
168 %{__make} \
169         %{?with_verbose:V=1} \
170         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
171         LDFLAGS="%{ld_rpmldflags} -static" \
172 %if %{with dietlibc}
173         LIBRARIES="-lrpc" \
174         CC="diet %{__cc}"
175 %else
176 %if %{with glibc}
177         %{CrossOpts} \
178         CC="%{__cc}"
179 %else
180     %if "%{_target_base_arch}" != "%{_arch}"
181         CROSS="%{_target_cpu}-uclibc-" \
182     %endif
183         CC="%{_target_cpu}-uclibc-gcc"
184 %endif
185 %endif
186
187 mv -f busybox built/busybox.initrd
188 %{__make} clean
189 %endif
190
191
192 %if %{with altconfig}
193 install %{SOURCE3} .config
194 %else
195 install %{SOURCE1} .config
196 %endif
197
198 %if %{with static}
199 %{__make} oldconfig
200 %{__make} \
201         %{?with_verbose:V=1} \
202         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
203         LDFLAGS="%{ld_rpmldflags} -static" \
204 %if %{with dietlibc}
205         LIBRARIES="-lrpc" \
206         CC="diet %{__cc}"
207 %else
208 %if %{with glibc}
209         %{CrossOpts} \
210         CC="%{__cc}"
211 %else
212     %if "%{_target_base_arch}" != "%{_arch}"
213         CROSS="%{_target_cpu}-uclibc-" \
214     %endif
215         CC="%{_target_cpu}-uclibc-gcc"
216 %endif
217 %endif
218
219 mv -f busybox built/busybox.static
220 %{__make} clean
221 %endif
222
223 %{__make} oldconfig
224 %{__make} \
225         %{?with_verbose:V=1} \
226         %{CrossOpts} \
227         CFLAGS_EXTRA="%{rpmcflags}" \
228         LDFLAGS="%{ld_rpmldflags}" \
229         CC="%{__cc}"
230 %{__make} busybox.links docs/BusyBox.1
231
232 %install
233 rm -rf $RPM_BUILD_ROOT
234 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
235
236 %{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
237 %if %{with initrd}
238 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
239 install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/initrd-busybox
240 %endif
241
242 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
243 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
244 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
245
246 # install links to busybox binary, when linkfl is defined
247 %if %{with linkfl}
248 %{__make} install \
249         PREFIX=$RPM_BUILD_ROOT
250 %else
251 install busybox $RPM_BUILD_ROOT%{_bindir}
252 %endif
253
254 %clean
255 rm -rf $RPM_BUILD_ROOT
256
257 %files
258 %defattr(644,root,root,755)
259 %doc AUTHORS README .config
260
261 %if %{with linkfl}
262 %attr(755,root,root) /bin/*
263 %attr(755,root,root) /sbin/*
264 %attr(755,root,root) %{_bindir}/*
265 %attr(755,root,root) %{_sbindir}/*
266 %else
267 %attr(755,root,root) %{_bindir}/busybox
268 %endif
269
270 %{_libdir}/busybox
271 %{_mandir}/man1/*
272
273 %if %{with static}
274 %files static
275 %defattr(644,root,root,755)
276 %attr(755,root,root) %{_bindir}/busybox.static
277 %endif
278
279 %if %{with initrd}
280 %files initrd
281 %defattr(644,root,root,755)
282 %attr(755,root,root) %{_libdir}/initrd/initrd-busybox
283 %endif
This page took 0.09386 seconds and 3 git commands to generate.