]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
06fc115d534825b8e6316d0072da4c9d985174af
[packages/busybox.git] / busybox.spec
1 # TODO:
2 #       - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
3 #       - make internal commands work even if busybox is not in /bin/busybox
4 #
5 # Conditional build:
6 # alternative busybox config file (replaces default one) you should
7 # define cfgfile macro, i.e.
8 #
9 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
10 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
11 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
12 # Options below are useful, when you want fileutils and grep providing.
13 # For example, ash package requires fileutils and grep.
14 %bcond_with     fileutl_prov    # adds fileutils providing
15 %bcond_with     grep_prov       # adds grep providing
16 # Option below is useful, when busybox is built with shell support.
17 %bcond_with     sh_prov         # adds /bin/sh providing
18 # WARNING! Shell, fileutils and grep providing may depend on config file!
19 # Fileutils, grep and shell provided with busybox have not such
20 # functionality as their GNU countenders.
21 #
22 %bcond_without  static          # don't build static version
23 %bcond_without  initrd          # don't build initrd version
24 #%%bcond_with   dietlibc        # build dietlibc-based initrd version
25 %bcond_with     glibc           # build glibc-based initrd version
26 #
27 %ifnarch %{ix86} %{x8664} ppc
28 %define with_glibc 1
29 %endif
30 %ifarch ppc
31 %undefine       with_dietlibc
32 %endif
33 Summary:        Set of common unix utils for embeded systems
34 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
35 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
36 Name:           busybox
37 Version:        1.2.1
38 Release:        1
39 License:        GPL
40 Group:          Applications
41 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
42 # Source0-md5:  362b3dc0f2023ddfda901dc1f1a74391
43 Source1:        %{name}.config
44 Source2:        %{name}-initrd.config
45 %{?with_altconfig:Source3:      %{cfgfile}}
46 Patch1:         %{name}-logconsole.patch
47 Patch2:         %{name}-printf-gettext.patch
48 Patch3:         %{name}-loadfont.patch
49 Patch4:         %{name}-ash_exec.patch
50 Patch5:         %{name}-kernel_headers.patch
51 Patch6:         %{name}-insmod-morearchs.patch
52 Patch7:         %{name}-dhcp.patch
53 Patch8:         %{name}-fix_64_archs.patch
54 URL:            http://www.busybox.net/
55 BuildRequires:  gcc >= 3.2
56 %{?with_static:BuildRequires:   glibc-static}
57 %if %{with initrd}
58         %if %{with dietlibc}
59 BuildRequires:  dietlibc-static
60         %else
61                 %if %{with glibc}
62 BuildRequires:  glibc-static
63                 %else
64 %ifarch ppc %{x8664}
65 BuildRequires:  uClibc-static >= 2:0.9.29
66 %else
67 BuildRequires:  uClibc-static >= 2:0.9.21
68 %endif
69                 %endif
70         %endif
71 %endif
72 %{?with_fileutl_prov:Provides:  fileutils}
73 %{?with_grep_prov:Provides:     grep}
74 %{?with_sh_prov:Provides:       /bin/sh}
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77
78 %define         _bindir         /bin
79 %define         _initrd_bindir  /bin
80
81 %description
82 BusyBox combines tiny versions of many common UNIX utilities into a
83 single small executable. It provides minimalist replacements for most
84 of the utilities you usually find in fileutils, shellutils, findutils,
85 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
86 POSIX environment for any small or embedded system. The utilities in
87 BusyBox generally have fewer options than their full-featured GNU
88 cousins; however, the options that are included provide the expected
89 functionality and behave very much like their GNU counterparts.
90
91 BusyBox has been written with size-optimization and limited resources
92 in mind. It is also extremely modular so you can easily include or
93 exclude commands (or features) at compile time. This makes it easy to
94 customize your embedded systems. To create a working system, just add
95 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
96 ae).
97
98 %description -l pl
99 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
100 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
101 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
102 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
103 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
104 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
105 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
106 (np. elvis-tiny albo ae).
107
108 %description -l pt_BR
109 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
110 executável, fornecendo substitutos minimalistas para muitos dos
111 executáveis encontrados em pacotes como fileutils, shellutils,
112 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
113 em geral têm menos opções que os utilitários GNU, mas as opções
114 implementadas comportam-se de maneira similar aos equivalentes GNU.
115
116 %package static
117 Summary:        Static busybox
118 Summary(pl):    Statycznie skonsolidowany busybox
119 Group:          Applications
120
121 %description static
122 Static busybox.
123
124 %description static -l pl
125 Statycznie skonsolidowany busybox.
126
127 %package initrd
128 Summary:        Static busybox for initrd
129 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
130 Group:          Applications
131 Conflicts:      geninitrd < 3075
132
133 %description initrd
134 Static busybox for initrd.
135
136 %description initrd -l pl
137 Statycznie skonsolidowany busybox dla initrd.
138
139 %prep
140 %setup -q
141 %patch1 -p1
142 %patch2 -p1
143 %patch3 -p1
144 %patch4 -p1
145 %patch5 -p1
146 %patch6 -p1
147 %patch7 -p1
148 %patch8 -p1
149
150 %build
151 install %{SOURCE1} .config
152
153 %if %{with initrd}
154 install %{SOURCE2} .config
155 %{__make} oldconfig
156 %{__make} \
157         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
158         LDFLAGS="%{rpmldflags} -static" \
159 %if %{with dietlibc}
160         LIBRARIES="-lrpc" \
161         CC="diet gcc"
162 %else
163 %if %{with glibc}
164         CC="%{__cc}"
165 %else
166         CC="%{_target_cpu}-uclibc-gcc"
167 %endif
168 %endif
169
170 mv -f busybox busybox.initrd
171 %{__make} clean
172 install %{SOURCE1} .config
173 %endif
174
175 %if %{with altconfig}
176 install %{SOURCE3} .config
177 %endif
178
179 %if %{with static}
180 %{__make} oldconfig
181 %{__make} \
182         CFLAGS_EXTRA="%{rpmcflags}" \
183         LDFLAGS="%{rpmldflags} -static" \
184         CC="%{__cc}"
185 mv -f busybox busybox.static
186 %{__make} clean
187 %endif
188
189 %{__make} oldconfig
190 %{__make} \
191         CFLAGS_EXTRA="%{rpmcflags}" \
192         LDFLAGS="%{rpmldflags}" \
193         CC="%{__cc}"
194
195 %install
196 rm -rf $RPM_BUILD_ROOT
197 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
198
199 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
200 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
201
202 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
203 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
204 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
205
206 # install links to busybox binary, when linkfl is defined
207 %if %{with linkfl}
208 %{__make} install \
209         PREFIX=$RPM_BUILD_ROOT
210 %else
211 install busybox $RPM_BUILD_ROOT%{_bindir}
212 %endif
213
214 %clean
215 rm -rf $RPM_BUILD_ROOT
216
217 %files
218 %defattr(644,root,root,755)
219 %doc AUTHORS README .config
220
221 %if %{with linkfl}
222 %attr(755,root,root) /bin/*
223 %attr(755,root,root) /sbin/*
224 %attr(755,root,root) %{_bindir}/*
225 %attr(755,root,root) %{_sbindir}/*
226 %else
227 %attr(755,root,root) %{_bindir}/busybox
228 %endif
229
230 %{_libdir}/busybox
231 %{_mandir}/man1/*
232
233 %if %{with static}
234 %files static
235 %defattr(644,root,root,755)
236 %attr(755,root,root) %{_bindir}/busybox.static
237 %endif
238
239 %if %{with initrd}
240 %files initrd
241 %defattr(644,root,root,755)
242 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
243 %endif
This page took 0.032006 seconds and 2 git commands to generate.