]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- compilation with userspace kernel headers fixed (-kernel_headers.patch)
[packages/busybox.git] / busybox.spec
1
2 # alternative busybox config file (replaces default one) you should
3 # define cfgfile macro, i.e.
4 #
5 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
6 %bcond_with altconfig
7
8 %bcond_with linkfl # creates links to busybox binary and puts them into file list
9
10 # Options below are useful, when you want fileutils and grep providing.
11 # For example, ash package requires fileutils and grep.
12 %bcond_with fileutl_prov # adds fileutils providing
13 %bcond_with grep_prov    # adds grep providing
14
15 # Option below is useful, when busybox is built with shell support.
16 %bcond_with sh_prov      # adds /bin/sh providing
17
18 # WARNING! Shell, filetuils and grep providing may depend on config file!
19 # Fileutils, grep and shell provided with busybox have not such
20 # functionality as their GNU countenders.
21
22 %bcond_without static  # don't build static version
23 %bcond_without initrd  # don't build initrd version
24
25 %bcond_with dietlibc
26 %bcond_with glibc
27
28 %ifnarch %{ix86}
29 %define with_glibc 1
30 %endif
31
32 %define pre     pre4
33 Summary:        Set of common unix utils for embeded systems
34 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
35 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
36 Name:           busybox
37 Version:        1.00
38 Release:        0.%{pre}.1
39 License:        GPL
40 Group:          Applications
41 Source0:        http://www.busybox.net/downloads/%{name}-%{version}-pre4.tar.bz2
42 # Source0-md5:  e423335994b5cd2d078dad3492768d51
43 Source1:        %{name}.config
44 Source2:        %{name}-initrd.config
45 %{?with_altconfig:Source3:      %{cfgfile}}
46 Patch0:         %{name}-logconsole.patch
47 Patch1:         %{name}-print_ascii.patch
48 Patch2:         %{name}-printf-gettext.patch
49 Patch3:         %{name}-loadfont.patch
50 Patch4:         %{name}-pivot_root.patch
51 Patch5:         %{name}-malloc.patch
52 Patch6:         %{name}-raid_start.patch
53 Patch7:         %{name}-insmod_ng.patch
54 Patch8:         %{name}-force-dietlibc.patch
55 Patch9:         %{name}-ash_exec.patch
56 Patch10:        %{name}-amd64.patch
57 Patch11:        %{name}-kernel_headers.patch
58 URL:            http://www.busybox.net/
59 %{?with_fileutl_prov:Provides:  fileutils}
60 %{?with_grep_prov:Provides:     grep}
61 %{?with_sh_prov:Provides:       /bin/sh}
62 %{?with_static:BuildRequires:   glibc-static}
63 %if %{with initrd}
64   %if %{with dietlibc}
65 BuildRequires:  dietlibc-static
66   %else
67     %if %{with glibc}
68 BuildRequires:  glibc-static
69     %else
70 BuildRequires:  uClibc-static >= 0.9.21
71     %endif
72   %endif
73 %endif
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %define         _initrd_bindir  /bin
77
78 %description
79 BusyBox combines tiny versions of many common UNIX utilities into a
80 single small executable. It provides minimalist replacements for most
81 of the utilities you usually find in fileutils, shellutils, findutils,
82 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
83 POSIX environment for any small or embedded system. The utilities in
84 BusyBox generally have fewer options than their full-featured GNU
85 cousins; however, the options that are included provide the expected
86 functionality and behave very much like their GNU counterparts.
87
88 BusyBox has been written with size-optimization and limited resources
89 in mind. It is also extremely modular so you can easily include or
90 exclude commands (or features) at compile time. This makes it easy to
91 customize your embedded systems. To create a working system, just add
92 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
93 ae).
94
95 %description -l pl
96 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
97 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
98 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
99 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
100 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
101 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
102 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
103 (np. elvis-tiny albo ae).
104
105 %description -l pt_BR
106 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
107 executável, fornecendo substitutos minimalistas para muitos dos
108 executáveis encontrados em pacotes como fileutils, shellutils,
109 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
110 em geral têm menos opções que os utilitários GNU, mas as opções
111 implementadas comportam-se de maneira similar aos equivalentes GNU.
112
113 %package static
114 Summary:        Static busybox
115 Summary(pl):    Statycznie skonsolidowany busybox
116 Group:          Applications
117
118 %description static
119 Static busybox.
120
121 %description static -l pl
122 Statycznie skonsolidowany busybox.
123
124 %package initrd
125 Summary:        Static busybox for initrd
126 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
127 Group:          Applications
128
129 %description initrd
130 Static busybox for initrd.
131
132 %description initrd -l pl
133 Statycznie skonsolidowany busybox dla initrd.
134
135 %prep
136 %setup -q -n %{name}-%{version}-%{pre}
137 %patch0 -p1
138 %patch1 -p1
139 #X %patch2 -p1 // UPDATE ME
140 %patch3 -p1
141 %patch4 -p1
142 #%patch5 -p1 // not needed
143 %patch6 -p1
144 %patch7 -p1
145 %patch8 -p1
146 %patch9 -p1
147 %patch10 -p1
148 %patch11 -p1
149
150 %build
151 install %{SOURCE1} .config
152
153 %if %{with initrd}
154 install %{SOURCE2} .config
155 %{__make} oldconfig
156 %{__make} \
157         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
158         LDFLAGS="%{rpmldflags} -static" \
159 %if %{with dietlibc}
160         LIBRARIES="-lrpc" \
161         CC="diet gcc"
162 %else
163 %if %{with glibc}
164         CC="%{__cc}"
165 %else
166         CC="%{_target_cpu}-uclibc-gcc"
167 %endif
168 %endif
169
170 mv -f busybox busybox.initrd
171 %{__make} clean
172 install %{SOURCE1} .config
173 %endif
174
175 %if %{with altconfig}
176 install %{SOURCE3} .config
177 %endif
178
179 %if %{with static}
180 %{__make} oldconfig
181 %{__make}  \
182         CFLAGS_EXTRA="%{rpmcflags}" \
183         LDFLAGS="%{rpmldflags} -static" \
184         CC="%{__cc}"
185 mv -f busybox busybox.static
186 %{__make} clean
187 %endif
188
189 %{__make} oldconfig
190 %{__make} \
191         CFLAGS_EXTRA="%{rpmcflags}" \
192         LDFLAGS="%{rpmldflags}" \
193         CC="%{__cc}"
194
195 %install
196 rm -rf $RPM_BUILD_ROOT
197 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
198
199 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
200 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
201
202 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
203 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
204 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
205
206 # install links to busybox binary, when linkfl is defined
207 %if %{with linkfl}
208 make install \
209         PREFIX=$RPM_BUILD_ROOT
210 %else
211 install busybox $RPM_BUILD_ROOT%{_bindir}
212 %endif
213
214 %clean
215 rm -rf $RPM_BUILD_ROOT
216
217 %files
218 %defattr(644,root,root,755)
219 %doc AUTHORS TODO Changelog README .config
220
221 %if %{with linkfl}
222 %attr(755,root,root) /bin/*
223 %attr(755,root,root) /sbin/*
224 %attr(755,root,root) %{_bindir}/*
225 %attr(755,root,root) %{_sbindir}/*
226 %else
227 %attr(755,root,root) %{_bindir}/busybox
228 %endif
229
230 %{_libdir}/busybox
231 %{_mandir}/man1/*
232
233 %if %{with static}
234 %files static
235 %defattr(644,root,root,755)
236 %attr(755,root,root) %{_bindir}/busybox.static
237 %endif
238
239 %if %{with initrd}
240 %files initrd
241 %defattr(644,root,root,755)
242 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
243 %endif
This page took 0.0461 seconds and 3 git commands to generate.