]> git.pld-linux.org Git - packages/bush.git/blob - bush.spec
4fd0d7e3fbb416b32180bc9627b2679ca6fdfb39
[packages/bush.git] / bush.spec
1 Summary:        Business Shell (BUSH)
2 Summary(pl):    Pow³oka Biznesowa (BUSH)
3 Name:           bush
4 Version:        0.9.3
5 Release:        1
6 License:        GPL v2+
7 Group:          Applications/Shells
8 Source0:        http://tardis.dyn.dhs.org/smiab_download/other_projects/%{name}-%{version}-src.tgz
9 # Source0-md5:  05f4719e91b7e0f3194d8c4a16c2720d
10 Patch0:         %{name}-Makefile.patch
11 URL:            http://www.pegasoft.ca/bush.html
12 BuildRequires:  gcc-ada
13 BuildRequires:  postgresql-devel
14 Requires(post,preun):   grep
15 Requires(preun):        fileutils
16 Requires:       libgnat
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _bindir         /bin
20
21 %description
22 BUSH, the Business Shell, is a powerful Linux/UNIX shell for designing
23 secure, reliable scripts that can be later compiled as a fast
24 executable programs. It can also be used an an interactive login shell
25 or to generate Java Virtual Machine or .Net applications. BUSH is a
26 robust and readable alternative to BASH, CSH, and (to a certain
27 extent) Python and PERL. BUSH comes with 12 built-in packages
28 including numerics, string processing, sound and database access.
29
30 %description -l pl
31 BUSH, Pow³oka Biznesowa jest pow³ok± dla systemów Linux/UNIX o
32 bogatych mo¿liwo¶ciach. Stworzona jest z my¶l± o konstruowaniu
33 bezpiecznych i niezawodnych skryptów, które mog± potem zostaæ
34 skompilowane do postaci szybkich programów wykonywalnych. Mo¿e byæ ona
35 równie¿ u¿ywana jako pow³oka zg³oszeniowa, lub u¿yta do generowania
36 aplikacji Java Virtual Machine lub .Net. BUSH jest mocn± i czyteln±
37 alternatyw± w stosunku do pow³ok BASH, CSH, a tak¿e (w pewnym sensie)
38 do jêzyków takich jak Python czy PERL. BUSH zawiera 12 wbudowanych
39 pakietów w³±czaj±c w to operacje na liczbach, przetwarzanie ci±gów
40 znaków, d¼wiêki, oraz dostêp do baz danych.
41
42 %prep
43 %setup -q
44 %patch0 -p1
45
46 %build
47 %{__make} linux
48 %{__make} \
49         CC="%{__cc}" \
50         CFLAGS="%{rpmcflags}"
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT%{_bindir}
55
56 mv -f doc html
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post
65 umask 022
66 if [ ! -f /etc/shells ]; then
67         echo "/bin/bush" > /etc/shells
68 else
69         if ! grep -q '^/bin/bush$' /etc/shells; then
70                 echo "/bin/bush" >> /etc/shells
71         fi
72 fi
73
74 %preun
75 if [ "$1" = "0" ]; then
76         umask 022
77         grep -v /bin/bush /etc/shells > /etc/shells.new
78         mv -f /etc/shells.new /etc/shells
79 fi
80
81 %files
82 %defattr(644,root,root,755)
83 %doc README TODO html
84 %attr(755,root,root) %{_bindir}/bush
This page took 0.146899 seconds and 2 git commands to generate.