]> git.pld-linux.org Git - packages/buildbot.git/blob - buildbot.spec
- noarch, egg-info created on py2.4 too, fix duplicate files
[packages/buildbot.git] / buildbot.spec
1 Summary:        BuildBot build automation system
2 Name:           buildbot
3 Version:        0.7.9
4 Release:        2
5 License:        GPL v2
6 Group:          Development/Building
7 Source0:        http://dl.sourceforge.net/buildbot/%{name}-%{version}.tar.gz
8 # Source0-md5:  616c193a2508935499f26bcbfc56c08a
9 Patch0:         %{name}-fixes.patch
10 URL:            http://www.buildbot.net/
11 BuildRequires:  python-devel
12 BuildRequires:  rpmbuild(macros) >= 1.219
13 %pyrequires_eq  python-modules
14 Requires:       python-TwistedConch
15 Requires:       python-TwistedCore
16 Requires:       python-TwistedMail
17 Requires:       python-TwistedWeb
18 Requires:       python-TwistedWords
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The BuildBot is a system to automate the compile/test cycle required
24 by most software projects to validate code changes. By automatically
25 rebuilding and testing the tree each time something has changed, build
26 problems are pinpointed quickly, before other developers are
27 inconvenienced by the failure. The guilty developer can be identified
28 and harassed without human intervention. By running the builds on a
29 variety of platforms, developers who do not have the facilities to
30 test their changes everywhere before checkin will at least know
31 shortly afterwards whether they have broken the build or not. Warning
32 counts, lint checks, image size, compile time, and other build
33 parameters can be tracked over time, are more visible, and are
34 therefore easier to improve.
35
36 %prep
37 %setup -q
38 %patch0 -p1
39
40 %build
41 %{__python} setup.py build
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 %{__python} setup.py install \
46         --root=$RPM_BUILD_ROOT \
47         --optimize=2
48 %py_postclean
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc CREDITS NEWS README docs/*.html docs/examples docs/images
56 %doc contrib
57 %attr(755,root,root) %{_bindir}/buildbot
58 %{py_sitescriptdir}/buildbot
59 %{py_sitescriptdir}/buildbot*.egg-info
This page took 0.087611 seconds and 4 git commands to generate.